summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/xulrunner/PKGBUILD
diff options
context:
space:
mode:
authorGreg Frost <gregfrost1@bigpond.com>2009-07-29 09:29:30 (GMT)
committerGreg Frost <gregfrost1@bigpond.com>2009-07-29 09:29:30 (GMT)
commit4159bd66e3adbf81679c68dfbe6a01486a3f53db (patch)
tree01bd3c6700bce3d19f053d900598cac1df63fcb9 /abs/extra-testing/xulrunner/PKGBUILD
parentfd40ea704a335d923d7af765add1b3bad1ee5a9d (diff)
downloadlinhes_pkgbuild-4159bd66e3adbf81679c68dfbe6a01486a3f53db.zip
linhes_pkgbuild-4159bd66e3adbf81679c68dfbe6a01486a3f53db.tar.gz
linhes_pkgbuild-4159bd66e3adbf81679c68dfbe6a01486a3f53db.tar.bz2
firefox3.5.1upgrade: firefox nss nspr sqlite3 xulrunner
Diffstat (limited to 'abs/extra-testing/xulrunner/PKGBUILD')
-rw-r--r--abs/extra-testing/xulrunner/PKGBUILD45
1 files changed, 8 insertions, 37 deletions
diff --git a/abs/extra-testing/xulrunner/PKGBUILD b/abs/extra-testing/xulrunner/PKGBUILD
index 3f3f757..84d6734 100644
--- a/abs/extra-testing/xulrunner/PKGBUILD
+++ b/abs/extra-testing/xulrunner/PKGBUILD
@@ -2,56 +2,27 @@
# Maintainer: Alexander Baldeck <alexander@archlinux.org>
# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=xulrunner
-pkgver=1.9.0.9
-_ffoxver=3.0.9
+pkgver=1.9.1.1
+_ffoxver=3.5.1
pkgrel=2
pkgdesc="Mozilla Runtime Environment"
arch=(i686 x86_64)
license=('MPL' 'GPL' 'LGPL')
-depends=('gtk2>=2.16.0' 'gcc-libs>=4.3.3' 'libidl2>=0.8.13' 'mozilla-common' 'nss>=3.12.2' 'libxt' 'lcms' 'hunspell>=1.2.8' 'startup-notification>=0.9')
+depends=('gtk2>=2.16.0' 'gcc-libs>=4.3.3' 'libidl2>=0.8.13' 'mozilla-common' 'nss>=3.12.3' 'libxt' 'lcms'
+ 'hunspell>=1.2.8' 'startup-notification>=0.9')
makedepends=('zip' 'pkgconfig' 'diffutils' 'libgnomeui>=2.24.1')
provides=(gecko-sdk)
replaces=(gecko-sdk)
url="http://wiki.mozilla.org/XUL:Xul_Runner"
source=(http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${_ffoxver}/source/firefox-${_ffoxver}-source.tar.bz2
- mozconfig
- 100-system-hunspell-corrections.patch
- bzXXX_pc_honour_system_nspr_nss.patch
- mozilla-pkgconfig.patch
- fix-mozilla-launcher.patch
- mozilla-ps-pdf-simplify-operators.patch
- nsThreadUtils.patch)
-md5sums=('f80b085699db8201e5db6b30fc63c60d'
- '6509d12e6b17bfc51c09e1dc35259035'
- '5efd6772ed0ecf8eddec5d5650191d3c'
- '7a5151f90cb360bc1ea911e5cf7208e9'
- 'dfbfb4e35912112668ac66dae0783686'
- '63eee2d1da3b43c9d604f2253f242f40'
- '13dca58c04e62a8916691c63c5c492a0'
- 'ccc3a0672c783c043434f256fbd38c86')
+ mozconfig)
+md5sums=('18169e189785d680827d4fce94524449'
+ '6509d12e6b17bfc51c09e1dc35259035')
build() {
- cd ${startdir}/src/mozilla
+ cd ${startdir}/src/mozilla-1.9.1
cp ${startdir}/src/mozconfig .mozconfig
- #Upstream patch. Still not applied to 1.9.0.1
- patch -Np1 -i ${srcdir}/mozilla-ps-pdf-simplify-operators.patch || return 1
-
- #fix build with system hunspell - gentoo
- patch -Np0 -i ${srcdir}/100-system-hunspell-corrections.patch || return 1
-
- #fix pkgconfig files when building with system nss/nspr - ubuntu
- patch -Np1 -i ${srcdir}/bzXXX_pc_honour_system_nspr_nss.patch || return 1
-
- #fix libdir/sdkdir - fedora - with local modifications
- patch -Np1 -i ${srcdir}/mozilla-pkgconfig.patch || return 1
-
- #Fix stub launcher - archlinux
- patch -Np0 -i ${srcdir}/fix-mozilla-launcher.patch || return 1
-
- #Fix epiphany crashes - requires epiphany rebuild
- patch -Np1 -i ${srcdir}/nsThreadUtils.patch || return 1
-
unset CFLAGS
unset CXXFLAGS
export LDFLAGS="-Wl,-rpath,/usr/lib/xulrunner-1.9"