summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing/zip/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-11-08 19:55:52 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-11-08 19:55:52 (GMT)
commit62a85af977dfdaa2c5650611e92d165ff96c39af (patch)
tree988016870332e5339954b085cc679e085f0f6057 /abs/extra-testing/zip/PKGBUILD
parent562074d2036106b5cd46505fe9823c939c1e7ff1 (diff)
downloadlinhes_pkgbuild-62a85af977dfdaa2c5650611e92d165ff96c39af.zip
linhes_pkgbuild-62a85af977dfdaa2c5650611e92d165ff96c39af.tar.gz
linhes_pkgbuild-62a85af977dfdaa2c5650611e92d165ff96c39af.tar.bz2
fixes for zip.
These were taken from gentoo.
Diffstat (limited to 'abs/extra-testing/zip/PKGBUILD')
-rw-r--r--abs/extra-testing/zip/PKGBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/abs/extra-testing/zip/PKGBUILD b/abs/extra-testing/zip/PKGBUILD
index 54eae73..30cec8b 100644
--- a/abs/extra-testing/zip/PKGBUILD
+++ b/abs/extra-testing/zip/PKGBUILD
@@ -10,14 +10,23 @@ url="http://www.info-zip.org/pub/infozip/Zip.html"
depends=('glibc')
makedepends=('unzip')
source=(ftp://ftp.info-zip.org/pub/infozip/src/zip30.zip
- ftp://ftp.info-zip.org/pub/infozip/src/zcrypt.zip)
+ ftp://ftp.info-zip.org/pub/infozip/src/zcrypt.zip
+ zip-3.0-build.patch zip-3.0-no-crypt.patch
+ zip-3.0-exec-stack.patch zip-3.0-pic.patch
+ )
+
md5sums=('e88492c8abd68fa9cfba72bc08757dba'
'0c969ba1661183b041a142945ed2710e')
build() {
cd $startdir/src/${pkgname}30
- echo "A"| unzip ../zcrypt.zip
+# echo "A"| unzip ../zcrypt.zip
+ patch -p1 < $startdir/src/zip-3.0-build.patch
+ patch -p0 < $startdir/src/zip-3.0-no-crypt.patch || return 1
+ patch -p1 < $startdir/src/zip-3.0-exec-stack.patch
+ patch -p0 < $startdir/src/zip-3.0-pic.patch
+
make -f unix/Makefile LOCAL_ZIP="$CFLAGS" prefix=/usr generic_gcc || return 1
make -f unix/Makefile INSTALL=`which install` prefix=$startdir/pkg/usr install
}