summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-02-12 06:11:14 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-02-12 06:11:14 (GMT)
commit01df96d29e943375572640952520242f9c347b42 (patch)
tree2f1c8bb80d4603c6316fd5a2ffe7d498d28b9953 /abs/extra-testing
parentf8ad742e8993cfb53d85608f808eba2d236bec65 (diff)
downloadlinhes_pkgbuild-01df96d29e943375572640952520242f9c347b42.zip
linhes_pkgbuild-01df96d29e943375572640952520242f9c347b42.tar.gz
linhes_pkgbuild-01df96d29e943375572640952520242f9c347b42.tar.bz2
Fixes to get working.
Diffstat (limited to 'abs/extra-testing')
-rw-r--r--abs/extra-testing/mythvodka/PKGBUILD8
-rwxr-xr-xabs/extra-testing/mythvodka/hulu_grabber.sh2
-rw-r--r--abs/extra-testing/mythvodka/mythvodka.install5
3 files changed, 8 insertions, 7 deletions
diff --git a/abs/extra-testing/mythvodka/PKGBUILD b/abs/extra-testing/mythvodka/PKGBUILD
index 38af93b..ac6de1f 100644
--- a/abs/extra-testing/mythvodka/PKGBUILD
+++ b/abs/extra-testing/mythvodka/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=mythvodka
pkgver=0.7
-pkgrel=6
+pkgrel=8
pkgdesc="MythVodka (Video On Demand Killer App) is a plugin for MythTV allowing streaming of BBC iPlayer, Hulu, HTTP and NZB content."
arch=('i686' 'x86_64')
license=('GPL2')
url="http://code.google.com/p/mythvodka/"
-depends=('rtmpdump' 'perl-xml-dom')
+depends=('rtmpdump' 'perl-xml-dom' 'beautiful-soup')
install=mythvodka.install
source=('http://mythvodka.googlecode.com/files/mythvodka.07.tar.gz' 'mythvodka.diff' 'hulu_grabber.sh')
@@ -25,9 +25,9 @@ build() {
cp streams-ui.xml $startdir/pkg/usr/share/mythtv/themes/default/
mkdir -p $startdir/pkg/usr/share/mythtv/themes/default-wide/
cp theme-wide/streams-ui.xml $startdir/pkg/usr/share/mythtv/themes/default-wide/
- mkdir -p $startdir/pkg/usr/bin
+ mkdir -p $startdir/pkg/usr/local/bin
chmod a+x ../scripts/*
- cp -p ../scripts/* $startdir/pkg/usr/bin
+ cp -p ../scripts/* $startdir/pkg/usr/local/bin
mkdir -p $startdir/pkg/etc/cron.daily/
chmod 755 ../../hulu_grabber.sh
cp ../../hulu_grabber.sh $startdir/pkg/etc/cron.daily/
diff --git a/abs/extra-testing/mythvodka/hulu_grabber.sh b/abs/extra-testing/mythvodka/hulu_grabber.sh
index d285379..fa76a6a 100755
--- a/abs/extra-testing/mythvodka/hulu_grabber.sh
+++ b/abs/extra-testing/mythvodka/hulu_grabber.sh
@@ -3,7 +3,7 @@ log=/var/log/mythtv/hulu_grabber.log
out=/var/tmp/huludata.xml
rm -f $log
echo "Start on `date`" >>$log 2>&1
-time /usr/bin/gethulu.pl $out.new >>$log 2>&1
+time /usr/local/bin/gethulu.pl $out.new >>$log 2>&1
stat=$?
if [ $stat -ne 0 ]; then
echo "Bad status $stat from gethulu.pl" >>$log 2>&1
diff --git a/abs/extra-testing/mythvodka/mythvodka.install b/abs/extra-testing/mythvodka/mythvodka.install
index 796e603..4a9827e 100644
--- a/abs/extra-testing/mythvodka/mythvodka.install
+++ b/abs/extra-testing/mythvodka/mythvodka.install
@@ -30,8 +30,9 @@ post_install() {
}
# arg 1: the new package version
# arg 2: the old package version
-#post_upgrade() {
-#}
+post_upgrade() {
+ /bin/true
+}
# arg 1: the old package version
post_remove() {