summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2008-10-28 21:31:00 (GMT)
committerJames Meyer <james.meyer@operamail.com>2008-10-28 21:31:00 (GMT)
commit088d235213f43978790a0f6864a84b97a4817cf5 (patch)
tree39523a00ccb73600bc30213cd85a57e161705ca9 /abs/extra-testing
parentc8eb0fa27c78daf50c995b94f9f72f69b3404387 (diff)
downloadlinhes_pkgbuild-088d235213f43978790a0f6864a84b97a4817cf5.zip
linhes_pkgbuild-088d235213f43978790a0f6864a84b97a4817cf5.tar.gz
linhes_pkgbuild-088d235213f43978790a0f6864a84b97a4817cf5.tar.bz2
update mplayer
add xine various other libs needed by the above
Diffstat (limited to 'abs/extra-testing')
-rw-r--r--abs/extra-testing/libcaca/PKGBUILD20
-rw-r--r--abs/extra-testing/libdca/PKGBUILD22
-rw-r--r--abs/extra-testing/libmng/PKGBUILD25
-rw-r--r--abs/extra-testing/live-media/PKGBUILD31
-rw-r--r--abs/extra-testing/mplayer/PKGBUILD2
-rw-r--r--abs/extra-testing/wavpack/PKGBUILD25
-rw-r--r--abs/extra-testing/xine-lib/ChangeLog11
-rw-r--r--abs/extra-testing/xine-lib/PKGBUILD38
-rw-r--r--abs/extra-testing/xine-lib/xine-header.patch11
-rw-r--r--abs/extra-testing/xine-lib/xine-lib-1.1.1-configure-no-mcpu-march.patch13
-rw-r--r--abs/extra-testing/xine-ui/ChangeLog7
-rw-r--r--abs/extra-testing/xine-ui/PKGBUILD30
12 files changed, 234 insertions, 1 deletions
diff --git a/abs/extra-testing/libcaca/PKGBUILD b/abs/extra-testing/libcaca/PKGBUILD
new file mode 100644
index 0000000..f0c3710
--- /dev/null
+++ b/abs/extra-testing/libcaca/PKGBUILD
@@ -0,0 +1,20 @@
+# $Id: PKGBUILD 9776 2008-08-19 00:46:51Z eric $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=libcaca
+pkgver=0.9
+pkgrel=2
+pkgdesc="Color AsCii Art library"
+arch=('i686' 'x86_64')
+license=('LGPL')
+url="http://libcaca.zoy.org/"
+depends=('freetype2' 'imlib2' 'ncurses>=5.6-7')
+source=(http://libcaca.zoy.org/files/libcaca/${pkgname}-${pkgver}.tar.gz)
+md5sums=('97b0f526f39491389e159055f574c921')
+
+build() {
+ cd ${startdir}/src/${pkgname}-${pkgver}
+ ./configure --prefix=/usr --mandir=/usr/share/man --enable-shared --disable-doc
+ make || return 1
+ make DESTDIR=${startdir}/pkg install
+}
diff --git a/abs/extra-testing/libdca/PKGBUILD b/abs/extra-testing/libdca/PKGBUILD
new file mode 100644
index 0000000..4794c02
--- /dev/null
+++ b/abs/extra-testing/libdca/PKGBUILD
@@ -0,0 +1,22 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+
+pkgname=libdca
+pkgver=0.0.5
+pkgrel=1
+pkgdesc="Free library for decoding DTS Coherent Acoustics streams"
+arch=(i686 x86_64)
+license=('GPL')
+url="http://www.videolan.org/developers/libdca.html"
+source=(http://download.videolan.org/pub/videolan/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2)
+md5sums=('dab6b2795c66a82a6fcd4f8343343021')
+provides=('libdts')
+replaces=('libdts')
+options=('!libtool' '!emptydirs')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR=$startdir/pkg install
+}
diff --git a/abs/extra-testing/libmng/PKGBUILD b/abs/extra-testing/libmng/PKGBUILD
new file mode 100644
index 0000000..d0fd215
--- /dev/null
+++ b/abs/extra-testing/libmng/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+# Maintainer: judd <jvinet@zeroflux.org>
+pkgname=libmng
+pkgver=1.0.10
+pkgrel=1
+pkgdesc="A collection of routines used to create and manipulate MNG format graphics files"
+arch=('i686' 'x86_64')
+url="http://www.libmng.com/"
+license=('custom')
+depends=('zlib' 'libjpeg')
+options=(!libtool)
+source=(http://dl.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('a464ae7d679781beebdf7440d144b7bd')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ ln -s makefiles/configure.in .
+ ln -s makefiles/Makefile.am .
+ autoreconf --force --install
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR=$startdir/pkg install
+ install -D -m644 LICENSE $startdir/pkg/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/abs/extra-testing/live-media/PKGBUILD b/abs/extra-testing/live-media/PKGBUILD
new file mode 100644
index 0000000..5e37fe1
--- /dev/null
+++ b/abs/extra-testing/live-media/PKGBUILD
@@ -0,0 +1,31 @@
+#$Id: PKGBUILD 13918 2008-09-29 20:59:34Z giovanni $
+#Maintainer: Aaron, phrakture, Griffin <aaron@archlinux.org>
+#Contributor: Gilles CHAUVIN <gcnweb@gmail.com>
+
+pkgname=live-media
+pkgver=2008.10.07
+pkgrel=1
+pkgdesc="A set of C++ libraries for multimedia streaming"
+arch=('i686' 'x86_64')
+license=('LGPL')
+url="http://live555.com/liveMedia/"
+depends=(gcc-libs)
+source=(http://live555.com/liveMedia/public/live.$pkgver.tar.gz)
+
+build()
+{
+ cd $startdir/src/live
+ sed -i "s|COMPILE_OPTS =.*|COMPILE_OPTS = \$(INCLUDES) -I. -DSOCKLEN_T=socklen_t -D_LARGEFILE_SOURCE=1 $CFLAGS|g" config.linux
+ ./genMakefiles linux
+ make || return 1
+
+ for dir in BasicUsageEnvironment UsageEnvironment groupsock liveMedia; do
+ mkdir -p $startdir/pkg/usr/lib/$pkgname/$dir
+ cp -r $dir/*.a $dir/include $startdir/pkg/usr/lib/$pkgname/$dir
+ done
+
+ mkdir -p $startdir/pkg/usr/bin
+ for testprog in `find testProgs -type f -perm 755`; do
+ install $testprog $startdir/pkg/usr/bin
+ done
+}
diff --git a/abs/extra-testing/mplayer/PKGBUILD b/abs/extra-testing/mplayer/PKGBUILD
index f69a21a..43dad94 100644
--- a/abs/extra-testing/mplayer/PKGBUILD
+++ b/abs/extra-testing/mplayer/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Thomas Bächler <thomas@archlinux.org>
pkgname=mplayer
pkgver=1.0rc2
-pkgrel=5
+pkgrel=6
pkgdesc="A movie player for linux"
arch=(i686 x86_64)
depends=('libxxf86dga' 'libxv' 'libmad' 'giflib' 'cdparanoia' 'gtk2'
diff --git a/abs/extra-testing/wavpack/PKGBUILD b/abs/extra-testing/wavpack/PKGBUILD
new file mode 100644
index 0000000..c0ab01a
--- /dev/null
+++ b/abs/extra-testing/wavpack/PKGBUILD
@@ -0,0 +1,25 @@
+# $Id: PKGBUILD 3456 2008-06-22 19:29:25Z jgc $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: Shinlun Hsieh <yngwiexx@yahoo.com.tw>
+# Contributor: Michal Hybner <dta081@gmail.com>
+pkgname=wavpack
+pkgver=4.50.0
+pkgrel=1
+pkgdesc="A completely open audio compression format providing lossless, high-quality lossy, and a unique hybrid compression mode"
+arch=('i686' 'x86_64')
+url="http://www.wavpack.com/"
+license=('custom')
+depends=('glibc')
+options=('!libtool')
+source=(http://www.wavpack.com/${pkgname}-${pkgver}.tar.bz2)
+md5sums=('9cf854fc2e5757f6534a3a231ec6bfbc')
+
+build() {
+ cd ${startdir}/src/${pkgname}-${pkgver}
+ ./configure --prefix=/usr --enable-mmx --disable-static || return 1
+ make || return 1
+ make DESTDIR=${startdir}/pkg install || return 1
+ install -m755 -d ${pkgdir}/usr/share/licenses/${pkgname}
+ install -m644 license.txt ${pkgdir}/usr/share/licenses/${pkgname}/ || return 1
+ rm -f ${startdir}/pkg/usr/lib/*.a
+}
diff --git a/abs/extra-testing/xine-lib/ChangeLog b/abs/extra-testing/xine-lib/ChangeLog
new file mode 100644
index 0000000..57c843e
--- /dev/null
+++ b/abs/extra-testing/xine-lib/ChangeLog
@@ -0,0 +1,11 @@
+2008-08-14 Eric Belanger <eric@archlinux.org>
+
+ * xine-lib 1.1.15-1
+ * Upstream update
+
+2008-07-28 Eric Belanger <eric@archlinux.org>
+
+ * xine-lib 1.1.14-2
+ * Switched to the more recent externel ffmpeg snapshot (close FS#10286)
+ * Updated win32 codecs directory location (close FS#11011)
+ * Added ChangeLog
diff --git a/abs/extra-testing/xine-lib/PKGBUILD b/abs/extra-testing/xine-lib/PKGBUILD
new file mode 100644
index 0000000..de79173
--- /dev/null
+++ b/abs/extra-testing/xine-lib/PKGBUILD
@@ -0,0 +1,38 @@
+# $Id: PKGBUILD 10479 2008-08-29 07:46:38Z pierre $
+# Maintainer: Eric Belanger <eric@archlinux.org>
+# Contributor: Judd Vinet <jvinet@zeroflux.org>
+
+pkgname=xine-lib
+pkgver=1.1.15
+pkgrel=2
+pkgdesc="A free video player for Unix"
+arch=('i686' 'x86_64')
+url="http://xinehq.de/"
+license=('LGPL' 'GPL')
+depends=('libgl' 'libxvmc' 'flac>=1.1.4' 'libvorbis' 'sdl' 'libmng' 'libtheora'
+ 'libxcb' 'wavpack' 'ffmpeg>=20080715')
+makedepends=('pkgconfig' 'libtool' 'automake' 'autoconf' 'imagemagick'
+ 'smbclient' 'mesa' 'alsa-lib' )
+options=('!libtool')
+source=(http://downloads.sourceforge.net/sourceforge/xine/${pkgname}-${pkgver}.tar.bz2
+ xine-lib-1.1.1-configure-no-mcpu-march.patch xine-header.patch)
+md5sums=('42a2b4893b7f892eb334de2fc36d49c8' '9776df4eb54d2f1f68d8268adbc3b5c2'
+ 'b139ee72700f8d118f9051e9140473f5')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ patch -Np0 -i ../xine-lib-1.1.1-configure-no-mcpu-march.patch || return 1
+ patch -p0 -i ../xine-header.patch || return 1
+ libtoolize --force --copy || return 1
+ aclocal -I m4 || return 1
+ autoconf || return 1
+ automake --add-missing || return 1
+
+ ./configure --prefix=/usr --with-w32-path=/usr/lib/codecs \
+ --with-xv-path=/usr/lib --with-libflac --with-wavpack \
+ --without-arts --without-jack --without-speex \
+ --disable-gnomevfs --without-pulseaudio --disable-aalib \
+ --disable-modplug --with-external-ffmpeg || return 1
+ make || return 1
+ make DESTDIR=${pkgdir} install || return 1
+}
diff --git a/abs/extra-testing/xine-lib/xine-header.patch b/abs/extra-testing/xine-lib/xine-header.patch
new file mode 100644
index 0000000..a37bfb9
--- /dev/null
+++ b/abs/extra-testing/xine-lib/xine-header.patch
@@ -0,0 +1,11 @@
+--- src/xine-engine/buffer.h 2008-07-16 23:01:56.000000000 +0200
++++ src/xine-engine/buffer.h 2008-08-24 21:14:39.000000000 +0200
+@@ -676,7 +676,7 @@
+ /* convert xine_waveformatex struct from little endian */
+ void _x_waveformatex_le2me( xine_waveformatex *wavex ) XINE_PROTECTED;
+
+-static inline _x_is_fourcc(void *ptr, void *tag) {
++static __inline _x_is_fourcc(void *ptr, void *tag) {
+ return memcmp(ptr, tag, 4) == 0;
+ }
+
diff --git a/abs/extra-testing/xine-lib/xine-lib-1.1.1-configure-no-mcpu-march.patch b/abs/extra-testing/xine-lib/xine-lib-1.1.1-configure-no-mcpu-march.patch
new file mode 100644
index 0000000..4b6ba9e
--- /dev/null
+++ b/abs/extra-testing/xine-lib/xine-lib-1.1.1-configure-no-mcpu-march.patch
@@ -0,0 +1,13 @@
+--- m4/optimizations.m4.orig 2005-11-27 01:20:08.000000000 +0100
++++ m4/optimizations.m4 2005-11-27 01:22:56.000000000 +0100
+@@ -161,10 +161,6 @@
+ ;;
+
+ esac
+- if test x"$archopt_val" != x; then
+- CFLAGS="$sarchopt=$archopt_val $CFLAGS"
+- DEBUG_CFLAGS="$sarchopt=$archopt_val $DEBUG_CFLAGS"
+- fi
+ fi
+ else
+ dnl we have the Intel compiler
diff --git a/abs/extra-testing/xine-ui/ChangeLog b/abs/extra-testing/xine-ui/ChangeLog
new file mode 100644
index 0000000..e5fb3e8
--- /dev/null
+++ b/abs/extra-testing/xine-ui/ChangeLog
@@ -0,0 +1,7 @@
+2008-08-19 Eric Belanger <eric@archlinux.org>
+
+ * xine-ui 0.99.5-4
+ * Added xine and xine-remote binaries (missing in 0.99.5-3)
+ * Added missing libxt makedepends
+ * Replaced .install file by an optdepends
+ * Added ChangeLog
diff --git a/abs/extra-testing/xine-ui/PKGBUILD b/abs/extra-testing/xine-ui/PKGBUILD
new file mode 100644
index 0000000..79ab3c3
--- /dev/null
+++ b/abs/extra-testing/xine-ui/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id: PKGBUILD 9858 2008-08-19 23:56:23Z eric $
+# Maintainer: Eric Belanger <eric@archlinux.org>
+
+pkgname=xine-ui
+pkgver=0.99.5
+pkgrel=4
+pkgdesc="A free video player for Unix"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://xinehq.de/"
+depends=('xine-lib' 'curl>=7.16.2' 'libxtst' 'libxinerama' 'libxv' 'libpng' 'libxft' 'libsm' 'libxxf86vm' 'ncurses>=5.6-7')
+makedepends=('lirc' 'libxt')
+optdepends=('lirc')
+options=('!emptydirs')
+source=(http://downloads.sourceforge.net/sourceforge/xine/${pkgname}-${pkgver}.tar.gz)
+md5sums=('e643cd1fcad4d98a5ae4eb877ce5087b')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ #add missing constant (defined in xine.h from xine-lib cvs)
+ echo '#define XINE_MSG_AUDIO_OUT_UNAVAILABLE 11' >> src/xitk/common.h
+ ./configure --prefix=/usr --mandir=/usr/share/man \
+ --with-curses --with-x --enable-lirc --without-aalib
+ make || return 1
+ make DESTDIR=${pkgdir} install
+ install -d ${pkgdir}/usr/share/applications
+ echo "Categories=Application;AudioVideo;" >> ${pkgdir}/usr/share/xine/desktop/xine.desktop
+ mv ${pkgdir}/usr/share/xine/desktop/xine.desktop ${pkgdir}/usr/share/applications
+}