summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing
diff options
context:
space:
mode:
authorNathan Harris <nharris@eoimaging.com>2009-07-09 16:31:26 (GMT)
committerNathan Harris <nharris@eoimaging.com>2009-07-09 16:31:26 (GMT)
commit4edbece1bc1196306c0dd3f27f6d085038d67db7 (patch)
treea0e6f8b006a73be4851c6dba59f286237b2b28b0 /abs/extra-testing
parentabae5612155504ff82912331e9a586dafcab41f4 (diff)
downloadlinhes_pkgbuild-4edbece1bc1196306c0dd3f27f6d085038d67db7.zip
linhes_pkgbuild-4edbece1bc1196306c0dd3f27f6d085038d67db7.tar.gz
linhes_pkgbuild-4edbece1bc1196306c0dd3f27f6d085038d67db7.tar.bz2
Sun Java JRE: updated to 6u14
Diffstat (limited to 'abs/extra-testing')
-rw-r--r--abs/extra-testing/community/jre/PKGBUILD73
-rw-r--r--abs/extra-testing/community/jre/construct.sh282
-rw-r--r--abs/extra-testing/community/jre/jre.install7
3 files changed, 38 insertions, 324 deletions
diff --git a/abs/extra-testing/community/jre/PKGBUILD b/abs/extra-testing/community/jre/PKGBUILD
index ca22f01..cd9a932 100644
--- a/abs/extra-testing/community/jre/PKGBUILD
+++ b/abs/extra-testing/community/jre/PKGBUILD
@@ -1,55 +1,58 @@
-# Based on official Arch package by Jason Chu <jason@archlinux.org>
+# $Id: PKGBUILD,v 1.6 2009/06/01 19:10:05 wonder Exp $
+# Maintainer: Jason Chu <jason@archlinux.org>
+
pkgname=jre
-pkgver=6u12
+pkgver=6u14
pkgrel=1
pkgdesc="Sun's java runtime environment"
-arch=(i686 x86_64)
-[ "$CARCH" = "i686" ] && _arch=i586
-[ "$CARCH" = "x86_64" ] && _arch=amd64
+arch=('i686' 'x86_64')
+ [ "$CARCH" = "i686" ] && _arch=i586
+ [ "$CARCH" = "x86_64" ] && _arch=amd64
url="http://java.sun.com"
-depends=('glibc' 'libstdc++5')
+depends=('glibc' 'libxtst')
install="jre.install"
source=(http://download.java.net/dlj/binaries/jdk-$pkgver-dlj-linux-$_arch.bin
-https://jdk-distros.dev.java.net/source/browse/*checkout*/jdk-distros/trunk/utils/construct.sh
-jre.profile)
-[ "$CARCH" = "i686" ] && md5sums=('560a51cfeecc4918d01ca29abc858d52'
-'94065b612df0046d9ae758943f9f6a75'
-'50b4f5ac4129097461d246645d73a622')
-[ "$CARCH" = "x86_64" ] && md5sums=('9dce878be77b4a93337fa85b40b29069'
-'94065b612df0046d9ae758943f9f6a75'
-'50b4f5ac4129097461d246645d73a622')
+ https://jdk-distros.dev.java.net/source/browse/*checkout*/jdk-distros/trunk/utils/construct.sh
+ jre.profile)
+[ "$CARCH" = "i686" ] && md5sums=('299c445e4b14bfbb2a05323734d89c0c'
+ '94065b612df0046d9ae758943f9f6a75'
+ '50b4f5ac4129097461d246645d73a622')
+[ "$CARCH" = "x86_64" ] && md5sums=('6e866db04748296fc34ed83a92420403'
+ '94065b612df0046d9ae758943f9f6a75'
+ '50b4f5ac4129097461d246645d73a622')
+
+
replaces=('j2re')
conflicts=('j2re' 'java-runtime')
-provides=('j2re' 'java-runtime')
+provides=('j2re' 'java-runtime=6')
license=('custom')
build() {
- cd $startdir/src
+ cd $startdir/src
+
+ mkdir unbundle-jdk
+ cd unbundle-jdk
- mkdir unbundle-jdk
- cd unbundle-jdk
+ sh ../jdk-$pkgver-dlj-linux-$_arch.bin --accept-license
- sh ../jdk-$pkgver-dlj-linux-$_arch.bin --accept-license
+ cd ..
- cd ..
+ sh construct.sh unbundle-jdk linux-jdk linux-jre
- sh construct.sh unbundle-jdk linux-jdk linux-jre
+ mkdir -p $startdir/pkg/opt/java
+ mv linux-jdk/jre $startdir/pkg/opt/java
- mkdir -p $startdir/pkg/opt/java
- mv linux-jdk/jre $startdir/pkg/opt/java
+ install -D -m755 $startdir/src/${pkgname}.profile $startdir/pkg/etc/profile.d/${pkgname}.sh
- install -D -m755 $startdir/src/${pkgname}.profile $startdir/pkg/etc/profile.d/${pkgname}.sh
+ mkdir -p $startdir/pkg/usr/lib/mozilla/plugins
- if [ "$CARCH" = "i686" ]; then
- mkdir -p $startdir/pkg/usr/lib/mozilla/plugins
- ln -s /opt/java/jre/plugin/i386/ns7/libjavaplugin_oji.so $startdir/pkg/usr/lib/mozilla/plugins
- elif [ "$CARCH" = "x86_64" ]; then
- mkdir -p $startdir/pkg/usr/lib/mozilla/plugins
- ln -s /opt/java/jre/lib/amd64/libnpjp2.so $startdir/pkg/usr/lib/mozilla/plugins
- fi
+ if [ "$CARCH" = "i686" ]; then
+ ln -s /opt/java/jre/lib/i386/libnpjp2.so $startdir/pkg/usr/lib/mozilla/plugins
+ else ln -s /opt/java/jre/lib/amd64/libnpjp2.so $startdir/pkg/usr/lib/mozilla/plugins
+ fi
- mkdir -p $startdir/pkg/usr/share/licenses/jre
- cp $startdir/pkg/opt/java/jre/COPYRIGHT $startdir/pkg/usr/share/licenses/jre
- cp $startdir/pkg/opt/java/jre/LICENSE $startdir/pkg/usr/share/licenses/jre
- cp $startdir/pkg/opt/java/jre/THIRDPARTYLICENSEREADME.txt $startdir/pkg/usr/share/licenses/jre
+ mkdir -p $startdir/pkg/usr/share/licenses/jre
+ cp $startdir/pkg/opt/java/jre/COPYRIGHT $startdir/pkg/usr/share/licenses/jre
+ cp $startdir/pkg/opt/java/jre/LICENSE $startdir/pkg/usr/share/licenses/jre
+ cp $startdir/pkg/opt/java/jre/THIRDPARTYLICENSEREADME.txt $startdir/pkg/usr/share/licenses/jre
}
diff --git a/abs/extra-testing/community/jre/construct.sh b/abs/extra-testing/community/jre/construct.sh
deleted file mode 100644
index 5f6ff7f..0000000
--- a/abs/extra-testing/community/jre/construct.sh
+++ /dev/null
@@ -1,282 +0,0 @@
-#!/bin/bash
-# construct.sh
-# example construction of JRE and JDK directories from the DLJ bundles
-#
-# Copyright © 2006 Sun Microsystems, Inc.
-#
-# Permission is hereby granted, free of charge, to any person obtaining
-# a copy of this software and associated documentation files (the
-# "Software"), to deal in the Software without restriction, including
-# without limitation the rights to use, copy, modify, merge, publish,
-# distribute, sublicense, and/or sell copies of the Software, and to
-# permit persons to whom the Software is furnished to do so, subject to
-# the following conditions:
-#
-# The above copyright notice and this permission notice shall be
-# included in all copies or substantial portions of the Software.
-#
-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
-# EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
-# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
-# NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
-# LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
-# OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
-# WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
-#
-# Sun, Sun Microsystems, the Sun logo and Java, Java HotSpot,
-# and JVM trademarks or registered trademarks of Sun Microsystems,
-# Inc. in the U.S. and other countries.
-
-
-program=`basename $0`
-
-usage () {
- echo "usage: ${program} path/to/unbundle-jdk path/to/linux-jdk path/to/linux-jre"
-}
-
-getargs() {
- undir=$1
- jdkdir=$2
- jredir=$3
- if [ ! -d $undir ]; then
- echo "${program}: unbundle directory not found: $undir"
- exit 2
- fi
- # make sure javahome is the JDK
- javahome=`echo $undir/*/demo`
- if [ ! -d $javahome ]; then
- echo "${program}: unbundle directory incorrect: $undir"
- echo " expecting $undir/jdk1.5.0_xx"
- exit 2
- else
- javahome=`dirname $javahome`
- fi
- # verify JDK dir
- jdkdirp=`dirname $jdkdir`
- jdkbase=`basename $jdkdir`
- if [ ! -d $jdkdirp ]; then
- echo "${program}: parent directory for JDK does not exist: $jdkdirp"
- exit 2
- fi
- savedir=`pwd`
- cd $jdkdirp
- jdkdirp=`pwd`
- cd $savedir
- jdkdir=$jdkdirp/$jdkbase
- # verify JRE dir
- jredirp=`dirname $jredir`
- jrebase=`basename $jredir`
- if [ ! -d $jredirp ]; then
- echo "${program}: parent directory for JRE does not exist: $jredirp"
- exit 2
- fi
- savedir=`pwd`
- cd $jredirp
- jredirp=`pwd`
- cd $savedir
- jredir=$jredirp/$jrebase
-}
-
-checkfiles() {
- if [ -r $jdkdir ]; then
- echo "${program}: directory for JDK already exists: $jdkdir"
- exit 2
- fi
- if [ -r $jredir ]; then
- echo "${program}: directory for JRE already exists: $jredir"
- exit 2
- fi
-}
-
-copytree() {
- echo "copying over the JDK tree..."
- cp -a $javahome $jdkdir
-}
-
-linkrel() {
- target=$1
- link=$2
- # make a softlink from the $link to the $target
- # make this a relative link
- targetb=(`echo $target | tr '/' ' '`)
- linkb=(`echo $link | tr '/' ' '`)
- (( n = ${#targetb[*]} ))
- (( m = ${#linkb[*]} ))
- c=$n # common length
- if [ $m -lt $c ]; then
- (( c = m ))
- fi
- for (( i = 0 ; i < c ; i++ )); do
- if [ ${targetb[$i]} != ${linkb[$i]} ]; then
- # echo components differ, stopping
- break
- fi
- done
- rel=""
- for (( j = i + 1; j < m ; j++ )); do
- if [ -z $rel ]; then
- rel=".."
- else
- rel="$rel/.."
- fi
- done
- for (( j = i; j < n ; j++ )); do
- if [ -z $rel ]; then
- rel=${targetb[$j]}
- else
- rel="$rel/${targetb[$j]}"
- fi
- done
- ln -s $rel $link
-}
-
-createjre() {
- echo "creating JRE directory..."
- # absolute link
- # ln -s $jdkdir/jre $jredir
- # relative link
- linkrel $jdkdir/jre $jredir
-}
-
-unpackjars() {
- echo "unpacking jars..."
- unpack200=$jdkdir/bin/unpack200
- if [ ! -x $unpack200 ]; then
- echo "${program}: file missing $unpack200"
- exit 1
- fi
- cd $jdkdir
- PACKED_JARS=`find . -name '*.pack'`
- for i in $PACKED_JARS; do
- # echo $i
- jdir=`dirname $i`
- jbase=`basename $i .pack`
- if ! $unpack200 $jdkdir/$jdir/$jbase.pack $jdkdir/$jdir/$jbase.jar; then
- echo "${program}: error unpacking $jdkdir/$jdir/$jbase.jar"
- fi
- if [ ! -r $jdkdir/$jdir/$jbase.jar ]; then
- echo "${program}: missing $jdkdir/$jdir/$jbase.jar"
- else
- echo " $jdir/$jbase.jar"
- # remove pack file
- rm $jdkdir/$jdir/$jbase.pack
- fi
- done
-}
-
-preparecds() {
- # if this is a client installation...
- compiler="`$jdkdir/bin/java -client -version 2>&1 | tail -n +3 | cut -d' ' -f1-4`"
- if [ "X$compiler" = "XJava HotSpot(TM) Client VM" ]; then
- # create the CDS archive
- echo "creating the class data sharing archive..."
- if ! $jdkdir/bin/java -client -Xshare:dump > /dev/null 2>&1; then
- echo "returned error code $?"
- fi
- fi
-}
-
-jreman () {
- echo "setting up the JRE man pages..."
- # note this list is slightly different for OpenSolaris bundles
- jreman=/tmp/jre.man.txt
-cat <<EOF > $jreman
-man/ja_JP.eucJP/man1/java.1
-man/ja_JP.eucJP/man1/javaws.1
-man/ja_JP.eucJP/man1/keytool.1
-man/ja_JP.eucJP/man1/kinit.1
-man/ja_JP.eucJP/man1/klist.1
-man/ja_JP.eucJP/man1/ktab.1
-man/ja_JP.eucJP/man1/orbd.1
-man/ja_JP.eucJP/man1/pack200.1
-man/ja_JP.eucJP/man1/policytool.1
-man/ja_JP.eucJP/man1/rmid.1
-man/ja_JP.eucJP/man1/rmiregistry.1
-man/ja_JP.eucJP/man1/servertool.1
-man/ja_JP.eucJP/man1/tnameserv.1
-man/ja_JP.eucJP/man1/unpack200.1
-man/man1/java.1
-man/man1/javaws.1
-man/man1/keytool.1
-man/man1/kinit.1
-man/man1/klist.1
-man/man1/ktab.1
-man/man1/orbd.1
-man/man1/pack200.1
-man/man1/policytool.1
-man/man1/rmid.1
-man/man1/rmiregistry.1
-man/man1/servertool.1
-man/man1/tnameserv.1
-man/man1/unpack200.1
-EOF
- # create jre/man directory
- # mkdir $jdkdir/jre/man
- # move the real JRE man pages to jre/man
- # link the JDK JRE man pages to jre/man
- # real JDK man pages stay where they are
- for m in `cat $jreman`; do
- manpath=`dirname $jdkdir/jre/$m`
- mkdir -p $manpath
- mv $jdkdir/$m $jdkdir/jre/$m
- linkrel $jdkdir/jre/$m $jdkdir/$m
- done
- # link in Japanese man pages
- ln -s ja_JP.eucJP $jdkdir/jre/man/ja
- rm $jreman
-}
-
-elimdups() {
- echo "eliminating duplication between the JDK and JDK/jre..."
- jdkcomm=/tmp/jdk.bin.comm.txt
-cat <<EOF > $jdkcomm
-bin/ControlPanel
-bin/java
-bin/javaws
-bin/keytool
-bin/kinit
-bin/klist
-bin/ktab
-bin/orbd
-bin/pack200
-bin/policytool
-bin/rmid
-bin/rmiregistry
-bin/servertool
-bin/tnameserv
-bin/unpack200
-EOF
- # note there is little point in linking these common files
- # COPYRIGHT
- # LICENSE
- # THIRDPARTYLICENSEREADME.txt
- # And this file is unique to the JDK
- # README.html
- # And these files are unique to the JDK/jre/
- # CHANGES
- # README
- # Welcome.html
- for p in `cat $jdkcomm`; do
- rm $jdkdir/$p
- # this is a relative link
- ln -s ../jre/$p $jdkdir/$p
- done
- rm $jdkcomm
-}
-
-if [ $# -eq 3 ] ; then
- getargs $1 $2 $3
- checkfiles
- copytree
- createjre
- unpackjars
- preparecds
- jreman
- elimdups
-else
- usage
- exit 1
-fi
-
-exit 0
-
diff --git a/abs/extra-testing/community/jre/jre.install b/abs/extra-testing/community/jre/jre.install
index 778a5fd..4e557a7 100644
--- a/abs/extra-testing/community/jre/jre.install
+++ b/abs/extra-testing/community/jre/jre.install
@@ -10,13 +10,6 @@ post_install() {
sed -e '/application\/x-java-jnlp-file/d' -i /etc/mailcap
fi
echo 'application/x-java-jnlp-file;/opt/java/jre/bin/javaws %s' >>/etc/mailcap
-cat << _EOF
-
-==> In order to have java applets support in firefox you should install
-==> libxtst (pacman -S libxtst).
-
-_EOF
-
}
post_remove() {