summaryrefslogtreecommitdiffstats
path: root/abs/extra-testing
diff options
context:
space:
mode:
authorBob Igo <bob@stormlogic.com>2009-02-17 17:38:18 (GMT)
committerBob Igo <bob@stormlogic.com>2009-02-17 17:38:18 (GMT)
commit87d276ce0cf6b051d7198adf004ce15590ae294e (patch)
tree507520977c5d6047430f0f9fcd3960dfeaefc022 /abs/extra-testing
parentb1b1890741091e465c5ed2d3bea92f7141b81362 (diff)
parent9d327823ebe603376dce4001876c25149c388c8d (diff)
downloadlinhes_pkgbuild-87d276ce0cf6b051d7198adf004ce15590ae294e.zip
linhes_pkgbuild-87d276ce0cf6b051d7198adf004ce15590ae294e.tar.gz
linhes_pkgbuild-87d276ce0cf6b051d7198adf004ce15590ae294e.tar.bz2
Merge branch 'master' of ssh://igo@knoppmyth.net/mount/repository/LinHES-PKGBUILD
Diffstat (limited to 'abs/extra-testing')
-rw-r--r--abs/extra-testing/community/athcool/PKGBUILD19
-rw-r--r--abs/extra-testing/community/athcool/athcool35
-rwxr-xr-xabs/extra-testing/nvram-wake/PKGBUILD8
-rw-r--r--abs/extra-testing/x11vnc/PKGBUILD22
4 files changed, 80 insertions, 4 deletions
diff --git a/abs/extra-testing/community/athcool/PKGBUILD b/abs/extra-testing/community/athcool/PKGBUILD
new file mode 100644
index 0000000..2f38191
--- /dev/null
+++ b/abs/extra-testing/community/athcool/PKGBUILD
@@ -0,0 +1,19 @@
+pkgname=athcool
+pkgver=0.3.12
+pkgrel=1
+pkgdesc="Small utility allowing to enable powersaving mode on AMD Duron/Athlon/Athlon XP processors."
+url="http://members.jcom.home.ne.jp/jacobi/linux/softwares.html"
+depends=(pciutils)
+license="GPL"
+arch=(i686)
+source=(http://members.jcom.home.ne.jp/jacobi/linux/files/$pkgname-$pkgver.tar.gz
+ athcool)
+md5sums=('f2e0f4fbd04f5e1f09aa60a3ecb24645'
+ 'bbf32484cec6431568ccf51c2516f9e7')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ make || return 1
+ make DESTDIR=$startdir/pkg install
+ /bin/install -D -m0755 ../athcool $startdir/pkg/etc/rc.d/athcool
+}
diff --git a/abs/extra-testing/community/athcool/athcool b/abs/extra-testing/community/athcool/athcool
new file mode 100644
index 0000000..f49bd40
--- /dev/null
+++ b/abs/extra-testing/community/athcool/athcool
@@ -0,0 +1,35 @@
+#!/bin/bash
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+ATHCOOL=/usr/sbin/athcool
+
+case "$1" in
+ start)
+ stat_busy "Enabling Athcool"
+ $ATHCOOL on > /dev/null
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Disabling Athcool"
+ $ATHCOOL off > /dev/null
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ /bin/sleep 1
+ $0 start
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart}"
+esac
+exit 0
diff --git a/abs/extra-testing/nvram-wake/PKGBUILD b/abs/extra-testing/nvram-wake/PKGBUILD
index f4d3d38..8072eb4 100755
--- a/abs/extra-testing/nvram-wake/PKGBUILD
+++ b/abs/extra-testing/nvram-wake/PKGBUILD
@@ -1,11 +1,11 @@
-pkgname=nvram-wakeup
-pkgver=0.97
+pkgname=nvram-wakup
+pkgver=0.99b
pkgrel=1
pkgdesc="set the wakeup time of the localpc"
license="GPL"
arch=(i686)
-url="http://ahh.sourceforge.net/wol/"
-source=(http://easynews.dl.sourceforge.net/sourceforge/nvram-wakeup/nvram-wakeup-0.97.tar.bz2 )
+url="http://sourceforge.net/projects/nvram-wakeup/"
+source=(http://superb-west.dl.sourceforge.net/sourceforge/nvram-wakeup/nvram-wakup-0.99b.tar.gz )
build() {
diff --git a/abs/extra-testing/x11vnc/PKGBUILD b/abs/extra-testing/x11vnc/PKGBUILD
new file mode 100644
index 0000000..4c04573
--- /dev/null
+++ b/abs/extra-testing/x11vnc/PKGBUILD
@@ -0,0 +1,22 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: damir <damir@archlinux.org>
+
+pkgname=x11vnc
+pkgver=0.9.7
+pkgrel=1
+pkgdesc="a VNC server for real X displays"
+arch=("i686" "x86_64")
+license=("GPL2")
+#source=(http://dl.sourceforge.net/sourceforge/libvncserver/$pkgname-$pkgver.tar.gz)
+url="http://www.karlrunge.com/x11vnc/"
+source=("http://x11vnc.sourceforge.net/dev/x11vnc-0.9.7.tar.gz")
+depends=('openssl' 'libjpeg' 'zlib' 'libx11' 'libxtst' 'libxinerama' 'libxdamage' 'libxrandr' 'avahi')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ ./configure
+ make || return 1
+ make prefix=$startdir/pkg/usr install || return 1
+}
+
+md5sums=('0ed95ab69c1ccacab83c5a2abd5b43f5')