summaryrefslogtreecommitdiffstats
path: root/abs/extra/apache-ant/ant_diagnostics.patch
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2011-08-06 19:10:30 (GMT)
committerCecil <knoppmyth@gmail.com>2011-08-06 19:10:30 (GMT)
commitad58e3033f6bb5137b8dcb0e7eca12d50d888402 (patch)
tree9321335a68173bc3e4c1d237c19c8880411fa676 /abs/extra/apache-ant/ant_diagnostics.patch
parent998faf16b1b62493b39aa13b3cb53dfac266ef4c (diff)
parent9709ca528ca5dfbdb6ec6ea283ac6670e8f33b9d (diff)
downloadlinhes_pkgbuild-ad58e3033f6bb5137b8dcb0e7eca12d50d888402.zip
linhes_pkgbuild-ad58e3033f6bb5137b8dcb0e7eca12d50d888402.tar.gz
linhes_pkgbuild-ad58e3033f6bb5137b8dcb0e7eca12d50d888402.tar.bz2
Merge branch 'testing' of ssh://cesman@linhes.org/mount/repository/linhes_pkgbuild into testing
Conflicts: abs/core/tzdata/PKGBUILD
Diffstat (limited to 'abs/extra/apache-ant/ant_diagnostics.patch')
-rw-r--r--abs/extra/apache-ant/ant_diagnostics.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/extra/apache-ant/ant_diagnostics.patch b/abs/extra/apache-ant/ant_diagnostics.patch
new file mode 100644
index 0000000..38148b4
--- /dev/null
+++ b/abs/extra/apache-ant/ant_diagnostics.patch
@@ -0,0 +1,23 @@
+--- a/src/main/org/apache/tools/ant/Diagnostics.java
++++ b/src/main/org/apache/tools/ant/Diagnostics.java
+@@ -179,7 +179,10 @@
+ * @param clazz the class to get the information from.
+ * @since Ant 1.8.0
+ */
+- private static URL getClassLocation(Class clazz) {
++ private static URL getClassLocation(Class clazz) {
++ if (clazz.getProtectionDomain().getCodeSource() == null) {
++ return null;
++ }
+ return clazz.getProtectionDomain().getCodeSource().getLocation();
+ }
+
+@@ -241,7 +244,7 @@
+ }
+ Transformer transformer = null;
+ try {
+- transformer = transformerFactory.newTransformer();
++ transformer = transformerFactory.newTransformer();
+ } catch (Exception e) {
+ // ignore
+ ignoreThrowable(e);