summaryrefslogtreecommitdiffstats
path: root/abs/extra/apcupsd/PKGBUILD
diff options
context:
space:
mode:
authorCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
committerCecil Hugh Watson <knoppmyth@gmail.com>2009-09-26 01:57:08 (GMT)
commit7b29169fff9e7c624890c5edffe85def8a293136 (patch)
tree47753889faa3a2063b66d1c7e7681e703eb1b39a /abs/extra/apcupsd/PKGBUILD
parentc491dea779dac29afff3578bf8245943817c2339 (diff)
downloadlinhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.zip
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.gz
linhes_pkgbuild-7b29169fff9e7c624890c5edffe85def8a293136.tar.bz2
LinHES 6.01.00
Diffstat (limited to 'abs/extra/apcupsd/PKGBUILD')
-rw-r--r--abs/extra/apcupsd/PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/abs/extra/apcupsd/PKGBUILD b/abs/extra/apcupsd/PKGBUILD
new file mode 100644
index 0000000..9f66f5d
--- /dev/null
+++ b/abs/extra/apcupsd/PKGBUILD
@@ -0,0 +1,38 @@
+# $Id: PKGBUILD,v 1.17 2009/01/19 10:34:32 sergej Exp $
+# Maintainer: Sergej Pupykin <sergej@aur.archlinux.org>
+# Maintainer: Todd Musall <tmusall@comcast.net>
+
+pkgname=apcupsd
+pkgver=3.14.5
+pkgrel=2
+pkgdesc="Apcupsd can be used for power mangement and controlling most of APC's UPS models on Unix and Windows machines."
+arch=(i686 x86_64)
+url="http://www.apcupsd.org"
+license=('GPL')
+depends=('gcc-libs' 'gd' 'gconf')
+makedepends=('pkgconfig')
+backup=(etc/apcupsd/apcupsd.conf etc/apcupsd/hosts.conf \
+ etc/apcupsd/multimon.conf)
+source=(http://switch.dl.sf.net/sourceforge/apcupsd/$pkgname-$pkgver.tar.gz \
+ apcupsd
+ apcupsd.conf
+ run)
+md5sums=('4ac73ec91d8ab56f3fac894e172567c4'
+ '5eae3c4d921eeb81798a0250fe3dd111'
+ '2f533aec32c9445510bb2127b453b175'
+ 'd4b8c755ecd30f57810f71a6d6435dd3')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ ./configure --prefix=/usr --enable-cgi --enable-usb --enable-net \
+ --with-upstype=usb --with-upscable=usb \
+ --with-serial-dev=/dev/usb/hid/hiddev[0-9] \
+ --enable-pthreads --enable-gapcmon
+ make || return 1
+ make DESTDIR=$startdir/pkg install || return 1
+ install -D -m755 ../apcupsd $startdir/pkg/etc/rc.d/apcupsd && \
+ chmod 755 $startdir/pkg/sbin/*
+ cp ../apcupsd.conf $startdir/pkg/etc/apcupsd/
+ mkdir -p $startdir/pkg/etc/sv/apcupsd/supervise
+ install -D -m755 ../run $startdir/pkg/etc/sv/apcupsd
+}