summaryrefslogtreecommitdiffstats
path: root/abs/extra/autogen
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 19:40:15 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 19:40:15 (GMT)
commit3bba55032b8c49e1ab7a0dd1421f3779bfb543d2 (patch)
treeb58dd8e9c12d94b895137f04193ac703c5e97c61 /abs/extra/autogen
parent6e08e7b9e0cd1d5cdaa3ea1a7dcd75f01c198100 (diff)
downloadlinhes_pkgbuild-3bba55032b8c49e1ab7a0dd1421f3779bfb543d2.zip
linhes_pkgbuild-3bba55032b8c49e1ab7a0dd1421f3779bfb543d2.tar.gz
linhes_pkgbuild-3bba55032b8c49e1ab7a0dd1421f3779bfb543d2.tar.bz2
autogen 5.15
Diffstat (limited to 'abs/extra/autogen')
-rw-r--r--abs/extra/autogen/PKGBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/abs/extra/autogen/PKGBUILD b/abs/extra/autogen/PKGBUILD
index eea072e..dda533b 100644
--- a/abs/extra/autogen/PKGBUILD
+++ b/abs/extra/autogen/PKGBUILD
@@ -1,24 +1,29 @@
-# $Id: PKGBUILD 54700 2009-10-11 18:35:07Z jgc $
+# $Id: PKGBUILD 157991 2012-04-30 17:51:02Z dan $
# Maintainer: Jan de Groot <jgc@archlinux.org>
# Contributor: Arjan Timmerman <arjan@soufly.nl>
# Contributor: Tor Krill
pkgname=autogen
-pkgver=5.11.5
+pkgver=5.15
pkgrel=1
pkgdesc="A tool designed to simplify the creation and maintenance of programs that contain large amounts of repetitious text"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
url="http://autogen.sourceforge.net/"
license=('GPL3')
-depends=('guile>=1.8.6' 'libxml2>=2.7.3' 'libtool>=2.2.6a')
-options=('!libtool' '!makeflags')
+depends=('guile' 'libxml2')
+options=('!libtool')
install=autogen.install
-source=(http://downloads.sourceforge.net/autogen/${pkgname}-${pkgver}.tar.bz2)
+source=(http://ftp.gnu.org/gnu/${pkgname}/rel${pkgver}/${pkgname}-${pkgver}.tar.xz{,.sig})
+md5sums=('5fba3c0e1ec0965061f27e8e79bd6da2'
+ 'ed74e586ade1a61f753d391f3849c25b')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix=/usr || return 1
- make || return 1
- make DESTDIR="${pkgdir}" install || return 1
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
}
-md5sums=('51c841eab6114de22b55f77a1c4f85b8')