summaryrefslogtreecommitdiffstats
path: root/abs/extra/bash-completion
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-08-30 22:26:00 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-08-30 22:26:00 (GMT)
commit1f175a7b07b9553ce98d0546ac04dbb925ec0bc9 (patch)
treec969070115611a8a75f23d468aa5e0cf86a08121 /abs/extra/bash-completion
parentc4bd4457b5d640e1c8f5afbca7cd54c53691e5fc (diff)
downloadlinhes_pkgbuild-1f175a7b07b9553ce98d0546ac04dbb925ec0bc9.zip
linhes_pkgbuild-1f175a7b07b9553ce98d0546ac04dbb925ec0bc9.tar.gz
linhes_pkgbuild-1f175a7b07b9553ce98d0546ac04dbb925ec0bc9.tar.bz2
RESYNC EXTRA:
synced extra-testing -> extra repo Signed-off-by: James Meyer <james.meyer@operamail.com>
Diffstat (limited to 'abs/extra/bash-completion')
-rw-r--r--abs/extra/bash-completion/PKGBUILD34
-rw-r--r--abs/extra/bash-completion/cowsay.bashcomp34
2 files changed, 68 insertions, 0 deletions
diff --git a/abs/extra/bash-completion/PKGBUILD b/abs/extra/bash-completion/PKGBUILD
new file mode 100644
index 0000000..5aa6b22
--- /dev/null
+++ b/abs/extra/bash-completion/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id: PKGBUILD 67318 2010-02-06 09:38:55Z eric $
+# Maintainer: Aaron Griffin <aaron@archlinux.org>
+# Contributor: Aurelien Foret <orelien@chez.com>
+# Contributor: Evangelos Foutras <foutrelis@gmail.com>
+
+pkgname=bash-completion
+pkgver=1.2
+pkgrel=1
+pkgdesc="Programmable completion for the bash shell"
+arch=(any)
+url="http://bash-completion.alioth.debian.org/"
+license=('GPL')
+depends=('bash')
+source=(http://bash-completion.alioth.debian.org/files/$pkgname-$pkgver.tar.gz cowsay.bashcomp)
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # fixes for archlinux
+ sed -i 's#/sbin/lsmod#/bin/lsmod#' bash_completion || return 1
+
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make || return 1
+ make DESTDIR="$pkgdir" install
+ install -D -m644 "$srcdir/cowsay.bashcomp" "$pkgdir/etc/bash_completion.d/cowsay"
+
+ # apache2ctl doesn't work, even when renamed to apachectl (and sed'd)
+ rm "$pkgdir/etc/bash_completion.d/apache2ctl"
+ # munin-node doesn't work, even i've updated munin to 1.4.0
+ rm "$pkgdir/etc/bash_completion.d/munin-node"
+}
+# vim:set ts=2 sw=2 et:
+md5sums=('457c8808ed54f2b2cdd737b1f37ffa24'
+ 'e9766bdc391caf825cb24e704422987e')
diff --git a/abs/extra/bash-completion/cowsay.bashcomp b/abs/extra/bash-completion/cowsay.bashcomp
new file mode 100644
index 0000000..77d8be9
--- /dev/null
+++ b/abs/extra/bash-completion/cowsay.bashcomp
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/www/viewcvs.gentoo.org/raw_cvs/gentoo-x86/games-misc/cowsay/files/cowsay.bashcomp,v 1.1 2005/02/06 14:37:54 ka0ttic Exp $
+
+# bash command-line completion for cowsay
+# Author: Aaron Walker <ka0ttic@gentoo.org>
+# Modified by: Michal Bentkowski <mr.ecik at gmail.com>
+
+_cowsay() {
+ local cur prev opts x
+ COMPREPLY=()
+ cur="${COMP_WORDS[COMP_CWORD]}"
+ prev="${COMP_WORDS[COMP_CWORD-1]}"
+ opts="-e -f -h -l -n -T -W -b -d -g -p -s -t -w -y"
+
+ if [[ "${cur}" == -* || ${COMP_CWORD} -eq 1 ]] ; then
+ COMPREPLY=( $(compgen -W "${opts}" -- ${cur}) )
+ return 0
+ fi
+
+ case "${prev}" in
+ -f)
+ COMPREPLY=( $( command ls /usr/share/cowsay| \
+ sed -ne 's/^\('$cur'.*\)\.cow$/\1/p') )
+ return 0
+ ;;
+ -[eTW])
+ COMPREPLY=()
+ ;;
+ esac
+}
+complete -o filenames -F _cowsay cowsay cowthink
+
+# vim: set ft=sh tw=80 sw=4 et :