summaryrefslogtreecommitdiffstats
path: root/abs/extra/bash-completion
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-12-03 03:25:38 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-12-03 03:25:38 (GMT)
commit4004c7c21e83a7f90db802b5f603fd510304e81e (patch)
treea99969acf267ce6a65e486d4a4b33f44546168d2 /abs/extra/bash-completion
parent1c526448111bc7a04b0df663a2f4539e106faca0 (diff)
downloadlinhes_pkgbuild-4004c7c21e83a7f90db802b5f603fd510304e81e.zip
linhes_pkgbuild-4004c7c21e83a7f90db802b5f603fd510304e81e.tar.gz
linhes_pkgbuild-4004c7c21e83a7f90db802b5f603fd510304e81e.tar.bz2
bash-completion: upgrade
Diffstat (limited to 'abs/extra/bash-completion')
-rw-r--r--abs/extra/bash-completion/PKGBUILD31
1 files changed, 15 insertions, 16 deletions
diff --git a/abs/extra/bash-completion/PKGBUILD b/abs/extra/bash-completion/PKGBUILD
index 5aa6b22..a20fa08 100644
--- a/abs/extra/bash-completion/PKGBUILD
+++ b/abs/extra/bash-completion/PKGBUILD
@@ -1,34 +1,33 @@
-# $Id: PKGBUILD 67318 2010-02-06 09:38:55Z eric $
+# $Id: PKGBUILD 95183 2010-10-16 21:57:23Z eric $
# Maintainer: Aaron Griffin <aaron@archlinux.org>
-# Contributor: Aurelien Foret <orelien@chez.com>
-# Contributor: Evangelos Foutras <foutrelis@gmail.com>
pkgname=bash-completion
pkgver=1.2
-pkgrel=1
+pkgrel=2
pkgdesc="Programmable completion for the bash shell"
-arch=(any)
+arch=('any')
url="http://bash-completion.alioth.debian.org/"
license=('GPL')
depends=('bash')
-source=(http://bash-completion.alioth.debian.org/files/$pkgname-$pkgver.tar.gz cowsay.bashcomp)
+source=(http://bash-completion.alioth.debian.org/files/$pkgname-$pkgver.tar.bz2)
+md5sums=('88c022a98a02a02293716f840eadd884')
+sha1sums=('47e6fb919ae227e74172870379b0fe999a2ae70d')
build() {
cd "$srcdir/$pkgname-$pkgver"
# fixes for archlinux
- sed -i 's#/sbin/lsmod#/bin/lsmod#' bash_completion || return 1
+ sed -i 's#/sbin" lsmod#/bin" lsmod#' bash_completion
./configure --prefix=/usr --sysconfdir=/etc
- make || return 1
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
- install -D -m644 "$srcdir/cowsay.bashcomp" "$pkgdir/etc/bash_completion.d/cowsay"
- # apache2ctl doesn't work, even when renamed to apachectl (and sed'd)
- rm "$pkgdir/etc/bash_completion.d/apache2ctl"
- # munin-node doesn't work, even i've updated munin to 1.4.0
- rm "$pkgdir/etc/bash_completion.d/munin-node"
+# Doesn't work on Arch Linux and cause problems (FS#20112)
+ rm "$pkgdir/etc/bash_completion.d/service"
}
-# vim:set ts=2 sw=2 et:
-md5sums=('457c8808ed54f2b2cdd737b1f37ffa24'
- 'e9766bdc391caf825cb24e704422987e')
+