summaryrefslogtreecommitdiffstats
path: root/abs/extra/bluez
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-08-30 22:26:00 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-08-30 22:26:00 (GMT)
commit1f175a7b07b9553ce98d0546ac04dbb925ec0bc9 (patch)
treec969070115611a8a75f23d468aa5e0cf86a08121 /abs/extra/bluez
parentc4bd4457b5d640e1c8f5afbca7cd54c53691e5fc (diff)
downloadlinhes_pkgbuild-1f175a7b07b9553ce98d0546ac04dbb925ec0bc9.zip
linhes_pkgbuild-1f175a7b07b9553ce98d0546ac04dbb925ec0bc9.tar.gz
linhes_pkgbuild-1f175a7b07b9553ce98d0546ac04dbb925ec0bc9.tar.bz2
RESYNC EXTRA:
synced extra-testing -> extra repo Signed-off-by: James Meyer <james.meyer@operamail.com>
Diffstat (limited to 'abs/extra/bluez')
-rw-r--r--abs/extra/bluez/PKGBUILD24
-rw-r--r--abs/extra/bluez/__Changelog11
-rw-r--r--abs/extra/bluez/bluez.install15
-rw-r--r--abs/extra/bluez/run.bluetoothd12
-rw-r--r--abs/extra/bluez/run.dund14
-rw-r--r--abs/extra/bluez/run.hidd14
-rw-r--r--abs/extra/bluez/run.pand14
-rw-r--r--abs/extra/bluez/run.rfcomm17
8 files changed, 114 insertions, 7 deletions
diff --git a/abs/extra/bluez/PKGBUILD b/abs/extra/bluez/PKGBUILD
index 9e8f13b..f8dfbe5 100644
--- a/abs/extra/bluez/PKGBUILD
+++ b/abs/extra/bluez/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Geoffroy Carrier <geoffroy@archlinux.org>
pkgname=bluez
-pkgver=4.30
+pkgver=4.69
pkgrel=1
pkgdesc="Libraries and tools for the Bluetooth protocol stack"
url="http://www.bluez.org/"
@@ -12,11 +12,13 @@ optdepends=('gstreamer0.10-base' 'alsa-lib' 'libusb')
conflicts=('bluez-libs' 'bluez-utils')
provides=('bluez-libs' 'bluez-utils')
replaces=('bluez-libs' 'bluez-utils')
+install='bluez.install'
backup=(etc/bluetooth/{main,rfcomm,audio,network,input}.conf
etc/conf.d/bluetooth)
source=("http://www.kernel.org/pub/linux/bluetooth/$pkgname-$pkgver.tar.bz2"
- 'bluetooth.conf.d'
- 'rc.bluetooth')
+ bluetooth.conf.d run.bluetoothd run.hidd run.dund run.pand
+ run.rfcomm)
+
build() {
cd "$srcdir/$pkgname-$pkgver"
./configure --prefix=/usr \
@@ -45,9 +47,17 @@ build() {
install -D -m644 "$srcdir/$pkgname-$pkgver/network/network.conf" "$pkgdir/etc/bluetooth/" || return 1
install -D -m644 "$srcdir/$pkgname-$pkgver/input/input.conf" "$pkgdir/etc/bluetooth/" || return 1
install -D -m644 "$srcdir/$pkgname-$pkgver/audio/audio.conf" "$pkgdir/etc/bluetooth/" || return 1
- install -D -m755 "$srcdir/rc.bluetooth" "$pkgdir/etc/rc.d/bluetooth" || return 1
- install -D -m644 "$srcdir/bluetooth.conf.d" "$pkgdir/etc/conf.d/bluetooth" || return 1
+ install -D -m644 "$srcdir/bluetooth.conf.d" "$pkgdir/etc/conf.d/bluetooth" || return 1
+ install -D -m755 "$srcdir/run.bluetoothd" "$pkgdir/etc/sv/bluetoothd/run" || return 1
+ install -D -m755 "$srcdir/run.hidd" "$pkgdir/etc/sv/hidd/run" || return 1
+ install -D -m755 "$srcdir/run.dund" "$pkgdir/etc/sv/dund/run" || return 1
+ install -D -m755 "$srcdir/run.pand" "$pkgdir/etc/sv/pand/run" || return 1
+ install -D -m755 "$srcdir/run.rfcomm" "$pkgdir/etc/sv/rfcomm/run" || return 1
}
-md5sums=('5c37fb99c03f40269b9245eec3e7b7f4'
+md5sums=('350568aa11a95eac6e56e9289ff1f91d'
'd12be5b494525bb1ba6eac5c3983dd3e'
- '03d4f2463b1b580e8d2ada3767140685')
+ '1c88fcd455920ad8ee0c7cae3fe15771'
+ 'a9c1b4da8b5a3969865272bd0fb01da2'
+ '89c073f43a074844b87e28103e48623d'
+ '8ee99afea417561d01012b8047fd06d5'
+ '934a9eaa25c275d18115068101fb75e8')
diff --git a/abs/extra/bluez/__Changelog b/abs/extra/bluez/__Changelog
new file mode 100644
index 0000000..124d0eb
--- /dev/null
+++ b/abs/extra/bluez/__Changelog
@@ -0,0 +1,11 @@
+# by mihanson
+I really have no idea how this bluetooth stuff works. If anyone wants to
+take a stab at getting this working properly with runit, feel free. I
+only need this package to get mythpywii working.
+
+2010-04-01:
+Make this package work with runit. All daemons were seperated into their
+own run scripts. Of particular interest is rfcomm and hid2hci utilities.
+They are not daemons and I added "/sbin/sv <executable> down ." in their
+respective run files. All based on this thread:
+http://article.gmane.org/gmane.comp.sysutils.supervision.general/1585/
diff --git a/abs/extra/bluez/bluez.install b/abs/extra/bluez/bluez.install
new file mode 100644
index 0000000..f9b757b
--- /dev/null
+++ b/abs/extra/bluez/bluez.install
@@ -0,0 +1,15 @@
+post_install() {
+ add_service.sh bluetoothd
+ echo ">>> Only the bluetoothd daemon is started by default."
+ echo ">>> You can optionally add the following as required:"
+ echo ">>> hidd dund pand rfcomm"
+ echo ">>> $ sudo add_service.sh <service_name>"
+}
+
+pre_remove() {
+ for d in { bluetoothd,hidd,dund,pand,rfcomm } ; do
+ if [ -d /var/service/${d} ] ; then
+ remove_servcie.sh $d
+ fi
+ done
+}
diff --git a/abs/extra/bluez/run.bluetoothd b/abs/extra/bluez/run.bluetoothd
new file mode 100644
index 0000000..7a92437
--- /dev/null
+++ b/abs/extra/bluez/run.bluetoothd
@@ -0,0 +1,12 @@
+#!/bin/sh
+#
+# Start/stop the Bluetooth daemons
+#
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+[ -f /etc/conf.d/bluetooth ] && . /etc/conf.d/bluetooth
+
+ stat_runit "Starting bluetooth subsystem:"
+ exec /usr/sbin/bluetoothd -n
diff --git a/abs/extra/bluez/run.dund b/abs/extra/bluez/run.dund
new file mode 100644
index 0000000..c42cfa1
--- /dev/null
+++ b/abs/extra/bluez/run.dund
@@ -0,0 +1,14 @@
+#!/bin/sh
+#
+# Start/stop the Bluetooth daemons
+#
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+[ -f /etc/conf.d/bluetooth ] && . /etc/conf.d/bluetooth
+
+svwaitup -s 3 /var/service/bluetoothd || exit 1
+
+ stat_runit "Starting BlueZ Bluetooth dial-up networking daemon"
+ exec /usr/bin/dund -n -s
diff --git a/abs/extra/bluez/run.hidd b/abs/extra/bluez/run.hidd
new file mode 100644
index 0000000..e4f66d3
--- /dev/null
+++ b/abs/extra/bluez/run.hidd
@@ -0,0 +1,14 @@
+#!/bin/sh
+#
+# Start/stop the Bluetooth daemons
+#
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+[ -f /etc/conf.d/bluetooth ] && . /etc/conf.d/bluetooth
+
+svwaitup -s 3 /var/service/bluetoothd || exit 1
+
+ stat_runit "Starting Bluetooth HID daemon:"
+ exec /usr/bin/hidd -n --server
diff --git a/abs/extra/bluez/run.pand b/abs/extra/bluez/run.pand
new file mode 100644
index 0000000..ab15ef6
--- /dev/null
+++ b/abs/extra/bluez/run.pand
@@ -0,0 +1,14 @@
+#!/bin/sh
+#
+# Start/stop the Bluetooth daemons
+#
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+[ -f /etc/conf.d/bluetooth ] && . /etc/conf.d/bluetooth
+
+svwaitup -s 3 /var/service/bluetoothd || exit 1
+
+ stat_runit "Starting BlueZ Bluetooth PAN daemon"
+ exec /usr/bin/pand -n -s
diff --git a/abs/extra/bluez/run.rfcomm b/abs/extra/bluez/run.rfcomm
new file mode 100644
index 0000000..8bc619b
--- /dev/null
+++ b/abs/extra/bluez/run.rfcomm
@@ -0,0 +1,17 @@
+#!/bin/sh
+#
+# Start/stop the Bluetooth daemons
+#
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+[ -f /etc/conf.d/bluetooth ] && . /etc/conf.d/bluetooth
+
+RFCOMM_CONFIG="/etc/bluetooth/rfcomm.conf"
+
+svwaitup -s 3 /var/service/bluetoothd || exit 1
+
+ stat_runit "Starting RFCOMM for the bluetooth subsystem"
+ /usr/bin/rfcomm -f $RFCOMM_CONFIG bind all
+ /sbin/sv down .