summaryrefslogtreecommitdiffstats
path: root/abs/extra/bluez
diff options
context:
space:
mode:
authorMichael Hanson <mihanson@linhes.org>2012-04-14 05:09:55 (GMT)
committerMichael Hanson <mihanson@linhes.org>2012-04-14 05:09:55 (GMT)
commit8e721470713e6a5a164f1d7682b0d248cb87b03c (patch)
treea3051009b758ee305e97199da4938ca30e52d15c /abs/extra/bluez
parent5b565b694d7e82a62c1a72f0aa0e563c8352122e (diff)
downloadlinhes_pkgbuild-8e721470713e6a5a164f1d7682b0d248cb87b03c.zip
linhes_pkgbuild-8e721470713e6a5a164f1d7682b0d248cb87b03c.tar.gz
linhes_pkgbuild-8e721470713e6a5a164f1d7682b0d248cb87b03c.tar.bz2
bluez: Minor fixes v4.99
Diffstat (limited to 'abs/extra/bluez')
-rw-r--r--abs/extra/bluez/PKGBUILD17
-rw-r--r--abs/extra/bluez/__changelog3
2 files changed, 14 insertions, 6 deletions
diff --git a/abs/extra/bluez/PKGBUILD b/abs/extra/bluez/PKGBUILD
index 4090fdc..bfc7e25 100644
--- a/abs/extra/bluez/PKGBUILD
+++ b/abs/extra/bluez/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Geoffroy Carrier <geoffroy@archlinux.org>
pkgname=bluez
-pkgver=4.98
-pkgrel=2
+pkgver=4.99
+pkgrel=3
pkgdesc="Libraries and tools for the Bluetooth protocol stack"
url="http://www.bluez.org/"
arch=('i686' 'x86_64')
@@ -13,7 +13,6 @@ optdepends=("gstreamer0.10-base: bluetooth GStreamer support"
"dbus-python: to run bluez-simple-agent"
"pygobject: to run bluez-simple-agent"
"libusb-compat: USB adapters support"
- "cups: CUPS backend"
"libnl: netlink plugin")
conflicts=('bluez-libs' 'bluez-utils')
provides=('bluez-libs' 'bluez-utils')
@@ -29,7 +28,7 @@ source=("http://www.kernel.org/pub/linux/bluetooth/$pkgname-$pkgver.tar.bz2"
build() {
cd "$srcdir/$pkgname-$pkgver"
- # Add directive that allows audio streaming
+ # Add directive that allows audio streaming out-of-the-box
patch -Np1 -i ${srcdir}/bluez-4.98_audio-streaming.patch || return 1
./configure --prefix=/usr \
@@ -45,6 +44,8 @@ build() {
--enable-hidd \
--enable-pand \
--enable-dund \
+ --enable-wiimote \
+ --disable-test \
--disable-cups || return 1
make || return 1
@@ -65,9 +66,13 @@ package() {
"$pkgdir/etc/conf.d/bluetooth" || return 1
install -Dm755 test/simple-agent ${pkgdir}/usr/bin/bluez-simple-agent
+ install -Dm755 test/test-device "${pkgdir}"/usr/bin/bluez-test-device
+ install -Dm755 test/test-input "${pkgdir}"/usr/bin/bluez-test-input
sed -i 's#/usr/bin/python#/usr/bin/python2#' \
- ${pkgdir}/usr/bin/bluez-simple-agent
+ ${pkgdir}/usr/bin/bluez-simple-agent \
+ ${pkgdir}/usr/bin/bluez-test-device \
+ ${pkgdir}/usr/bin/bluez-test-input
}
-md5sums=('4aca8a0929250212e9a75fb60dd75b05'
+md5sums=('2387053eb5a7b02f37df4871df022a02'
'da4ec22ee1a5c3e84d5d934440167526'
'd12be5b494525bb1ba6eac5c3983dd3e')
diff --git a/abs/extra/bluez/__changelog b/abs/extra/bluez/__changelog
index 124d0eb..7627514 100644
--- a/abs/extra/bluez/__changelog
+++ b/abs/extra/bluez/__changelog
@@ -9,3 +9,6 @@ own run scripts. Of particular interest is rfcomm and hid2hci utilities.
They are not daemons and I added "/sbin/sv <executable> down ." in their
respective run files. All based on this thread:
http://article.gmane.org/gmane.comp.sysutils.supervision.general/1585/
+
+2012-04-13
+disable cups