summaryrefslogtreecommitdiffstats
path: root/abs/extra/bluez
diff options
context:
space:
mode:
authorMichael Hanson <mihanson@linhes.org>2012-06-20 07:39:16 (GMT)
committerMichael Hanson <mihanson@linhes.org>2012-06-20 07:39:16 (GMT)
commitc68f826a062b09d7fbdc4a55eddf4181d5b37785 (patch)
treeac14d308045d72c99ff22a0d9c580d177d0ecdf6 /abs/extra/bluez
parent7d86eb13f037848cbfac20de0197b501a2df8ad6 (diff)
downloadlinhes_pkgbuild-c68f826a062b09d7fbdc4a55eddf4181d5b37785.zip
linhes_pkgbuild-c68f826a062b09d7fbdc4a55eddf4181d5b37785.tar.gz
linhes_pkgbuild-c68f826a062b09d7fbdc4a55eddf4181d5b37785.tar.bz2
bluez: update to version 4.100
Diffstat (limited to 'abs/extra/bluez')
-rw-r--r--abs/extra/bluez/PKGBUILD24
-rw-r--r--abs/extra/bluez/__changelog5
-rw-r--r--abs/extra/bluez/org.bluez.service5
3 files changed, 22 insertions, 12 deletions
diff --git a/abs/extra/bluez/PKGBUILD b/abs/extra/bluez/PKGBUILD
index e6837e9..a26b874 100644
--- a/abs/extra/bluez/PKGBUILD
+++ b/abs/extra/bluez/PKGBUILD
@@ -4,14 +4,14 @@
# Contributor: Geoffroy Carrier <geoffroy@archlinux.org>
pkgname=bluez
-pkgver=4.99
-pkgrel=3
+pkgver=4.100
+pkgrel=1
pkgdesc="Libraries and tools for the Bluetooth protocol stack"
url="http://www.bluez.org/"
arch=('i686' 'x86_64')
license=('GPL2')
depends=('dbus-core' 'python2' 'udev')
-makedepends=('gstreamer0.10-base' 'libusb-compat' 'libsndfile')
+makedepends=('gstreamer0.10-base' 'libusb-compat' 'libsndfile' 'libusb')
optdepends=("gstreamer0.10-base: bluetooth GStreamer support"
"alsa-lib: Audio bluetooth devices support"
"dbus-python: to run bluez-simple-agent"
@@ -24,9 +24,9 @@ replaces=('bluez-libs' 'bluez-utils')
options=('!libtool')
backup=(etc/bluetooth/{main,rfcomm,audio,network,input,serial}.conf
'etc/conf.d/bluetooth' 'etc/dbus-1/system.d/bluetooth.conf')
-install='bluez.install'
source=("http://www.kernel.org/pub/linux/bluetooth/${pkgname}-${pkgver}.tar.bz2"
'bluetooth.conf.d'
+ 'org.bluez.service'
'audio-streaming.patch')
build() {
@@ -35,6 +35,8 @@ build() {
# Add setting that allows audio streaming out-of-the-box
patch -Np1 -i ${srcdir}/audio-streaming.patch || return 1
+ cp ../org.bluez.service src/
+
./configure --prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
@@ -49,9 +51,11 @@ build() {
--enable-hidd \
--enable-pand \
--enable-dund \
- --disable-cups \
+ --enable-cups \
--enable-wiimote \
- --disable-test
+ --disable-test \
+ --with-systemdunitdir=/usr/lib/systemd/system
+
make
}
@@ -59,8 +63,6 @@ package() {
cd ${srcdir}/${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
-# install -Dm755 ${srcdir}/rc.bluetooth ${pkgdir}/etc/rc.d/bluetooth
-
install -d ${pkgdir}/etc/bluetooth
install -m644 network/network.conf \
input/input.conf \
@@ -79,10 +81,8 @@ package() {
"${pkgdir}"/usr/bin/bluez-simple-agent \
"${pkgdir}"/usr/bin/bluez-test-device \
"${pkgdir}"/usr/bin/bluez-test-input
-
- # http://mailman.archlinux.org/pipermail/arch-general/2011-April/019787.html
-# rm "${pkgdir}"/usr/lib/udev/rules.d/97-bluetooth.rules
}
-md5sums=('2387053eb5a7b02f37df4871df022a02'
+md5sums=('54809d476c52665ff64594b6828016b5'
'7412982b440f29fa7f76a41a87fef985'
+ '54c7de598327bf11d56592235d0702f4'
'cc9c86af1ced7ad46fc7be114d32adfb')
diff --git a/abs/extra/bluez/__changelog b/abs/extra/bluez/__changelog
index 62a2048..e6448b6 100644
--- a/abs/extra/bluez/__changelog
+++ b/abs/extra/bluez/__changelog
@@ -17,3 +17,8 @@ http://article.gmane.org/gmane.comp.sysutils.supervision.general/1585/
2012-04-13
re-add audio-streaming.patch for ootb audio streaming
+
+2012-06-19
+- change 'systemd-tools' dependency back to 'udev'
+- change 'libusbx' dependency back to 'libusb'
+- remove refrences to rc.bluetooth
diff --git a/abs/extra/bluez/org.bluez.service b/abs/extra/bluez/org.bluez.service
new file mode 100644
index 0000000..dd7ae8f
--- /dev/null
+++ b/abs/extra/bluez/org.bluez.service
@@ -0,0 +1,5 @@
+[D-BUS Service]
+Name=org.bluez
+Exec=/bin/false
+User=root
+SystemdService=dbus-org.bluez.service