summaryrefslogtreecommitdiffstats
path: root/abs/extra/boost
diff options
context:
space:
mode:
authorMichael Hanson <mihanson@linhes.org>2012-05-01 23:40:44 (GMT)
committerMichael Hanson <mihanson@linhes.org>2012-05-01 23:40:44 (GMT)
commiteb1b08fe37ff143fd212e844e1dee22c24c1df8b (patch)
tree4c1772b3b388e1c0a4f56064f52b67573851f8ad /abs/extra/boost
parent42ae9b94604db5f6bd515863e0ffd3a44b6c866e (diff)
downloadlinhes_pkgbuild-eb1b08fe37ff143fd212e844e1dee22c24c1df8b.zip
linhes_pkgbuild-eb1b08fe37ff143fd212e844e1dee22c24c1df8b.tar.gz
linhes_pkgbuild-eb1b08fe37ff143fd212e844e1dee22c24c1df8b.tar.bz2
boost: upgrade to 1.49. Dep of mkvtoolnix.
Diffstat (limited to 'abs/extra/boost')
-rw-r--r--abs/extra/boost/PKGBUILD12
-rw-r--r--abs/extra/boost/exceptions.patch25
2 files changed, 34 insertions, 3 deletions
diff --git a/abs/extra/boost/PKGBUILD b/abs/extra/boost/PKGBUILD
index 37bb2de..f9502a9 100644
--- a/abs/extra/boost/PKGBUILD
+++ b/abs/extra/boost/PKGBUILD
@@ -6,13 +6,14 @@
pkgbase=boost
pkgname=('boost-libs' 'boost')
-pkgver=1.47.0
+pkgver=1.49.0
_boostver=${pkgver//./_}
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.boost.org/"
makedepends=('icu' 'python2' 'bzip2' 'zlib' 'openmpi')
-source=(http://downloads.sourceforge.net/sourceforge/${pkgbase}/${pkgbase}_${_boostver}.tar.gz)
+source=(http://downloads.sourceforge.net/sourceforge/${pkgbase}/${pkgbase}_${_boostver}.tar.gz
+ exceptions.patch)
license=('custom')
_stagedir="${srcdir}/stagedir"
@@ -24,6 +25,10 @@ build() {
#echo "using python : 3.2 : /usr/bin/python : /usr/include/python3.2mu : /usr/lib ;" >> build/v2/user-config.jam
echo "using mpi ;" >> build/v2/user-config.jam
+ cd "${srcdir}"/${pkgbase}_${_boostver}
+ # https://svn.boost.org/trac/boost/ticket/5731
+ patch -p0 -i "${srcdir}/exceptions.patch"
+
# build bjam
cd "${srcdir}/${pkgbase}_${_boostver}/tools/build/v2/engine"
./build.sh cc
@@ -106,4 +111,5 @@ package_boost-libs() {
install -D -m644 "${srcdir}/${pkgbase}_${_boostver}/LICENSE_1_0.txt" \
"${pkgdir}"/usr/share/licenses/boost-libs/LICENSE_1_0.txt
}
-md5sums=('ff180a5276bec773a7625cac7e2288e8')
+md5sums=('e0defc8c818e4f1c5bbb29d0292b76ca'
+ 'bedd276510b6ad1ff2b4d143de21373e')
diff --git a/abs/extra/boost/exceptions.patch b/abs/extra/boost/exceptions.patch
new file mode 100644
index 0000000..0322db6
--- /dev/null
+++ b/abs/extra/boost/exceptions.patch
@@ -0,0 +1,25 @@
+diff -up boost/numeric/conversion/converter_policies.hpp\~ boost/numeric/conversion/converter_policies.hpp
+--- boost/numeric/conversion/converter_policies.hpp~ 2008-10-13 11:00:03.000000000 +0200
++++ boost/numeric/conversion/converter_policies.hpp 2011-07-22 11:46:40.961876274 +0200
+@@ -20,6 +20,7 @@
+
+ #include "boost/mpl/if.hpp"
+ #include "boost/mpl/integral_c.hpp"
++#include "boost/throw_exception.hpp"
+
+ namespace boost { namespace numeric
+ {
+@@ -159,9 +160,9 @@ struct def_overflow_handler
+ void operator() ( range_check_result r ) // throw(negative_overflow,positive_overflow)
+ {
+ if ( r == cNegOverflow )
+- throw negative_overflow() ;
++ boost::throw_exception( negative_overflow() ) ;
+ else if ( r == cPosOverflow )
+- throw positive_overflow() ;
++ boost::throw_exception( positive_overflow() ) ;
+ }
+ } ;
+
+
+Diff finished. Fri Jul 22 11:46:49 2011