summaryrefslogtreecommitdiffstats
path: root/abs/extra/camlp4
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-06-08 16:25:01 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-06-08 16:25:01 (GMT)
commit13de637f5d23ba04e62b1ee7443394c552c5c88b (patch)
tree06e857ce05cc229df56d604a710e3506539d4965 /abs/extra/camlp4
parent74807f5f416c4dd58b6c85b3df17b769413cced5 (diff)
downloadlinhes_pkgbuild-13de637f5d23ba04e62b1ee7443394c552c5c88b.zip
linhes_pkgbuild-13de637f5d23ba04e62b1ee7443394c552c5c88b.tar.gz
linhes_pkgbuild-13de637f5d23ba04e62b1ee7443394c552c5c88b.tar.bz2
camlp4: initial inclusion. dep of lablgtk2
Diffstat (limited to 'abs/extra/camlp4')
-rw-r--r--abs/extra/camlp4/PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/abs/extra/camlp4/PKGBUILD b/abs/extra/camlp4/PKGBUILD
new file mode 100644
index 0000000..9f66a18
--- /dev/null
+++ b/abs/extra/camlp4/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id$
+# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+# Contributor: Tobias Powalowski <tpowa@archlinux.org>
+
+pkgname=camlp4
+pkgver=4.02+6
+pkgrel=1
+pkgdesc='Caml preprocessor and pretty-printer'
+arch=('x86_64' 'i686')
+license=('GPL2')
+url='https://github.com/ocaml/camlp4/releases'
+depends=('ocaml')
+makedepends=('git')
+options=('!makeflags' '!emptydirs' 'staticlibs')
+source=("git://github.com/ocaml/camlp4#tag=$pkgver")
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname"
+
+ ./configure
+ make all camlp4/META
+}
+
+package() {
+ make -C "$pkgname" \
+ BINDIR="$pkgdir/usr/bin" \
+ LIBDIR="$pkgdir/usr/lib/ocaml" \
+ PKGDIR="$pkgdir/usr/lib/ocaml" \
+ install install-META
+}
+
+# vim:set ts=2 sw=2 et: