summaryrefslogtreecommitdiffstats
path: root/abs/extra/chromium
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2013-02-19 21:10:18 (GMT)
committerJames Meyer <james.meyer@operamail.com>2013-02-19 21:10:18 (GMT)
commit2648e999d277eac5c3d331a3609bcc73fafbea71 (patch)
tree40951fb8e7fdbe28a0baa324ae615055203f1e2e /abs/extra/chromium
parentc759b5e0c4aa6fc37412b4dee2cf9ad993fd376d (diff)
parent7e6f7ca174e1af67178dc5293a312a4a733eb095 (diff)
downloadlinhes_pkgbuild-2648e999d277eac5c3d331a3609bcc73fafbea71.zip
linhes_pkgbuild-2648e999d277eac5c3d331a3609bcc73fafbea71.tar.gz
linhes_pkgbuild-2648e999d277eac5c3d331a3609bcc73fafbea71.tar.bz2
Merge branch 'testing'
# By James Meyer (1091) and others # Via James Meyer (5) and others * testing: (1148 commits) LinHES-config: during install don't kill off lirc. This keeps the remote active all the way to the finish Change version numbers to 8.0 to match the release number. LinHES-conifg LinHES-system mythdb-initial runit-scripts supplemental-web LinHES-conifig: mv_install.py for the last partition don't go all the way to the end. Gotta leave room for gpt tables. xf86-video-ati: xorg ati driver. LinHES-config: timezip.py add syncing up of parental lvl passwords and starting level with MBE. LinHES-system: correct the logic for breaking out of the wmctrl loop. As written it would break out of the inner loop..but not the 60 iteration loop. e16_theme_settings: remove slide-in prop for new windows. For whatever reason this was preventing mplayer from being positioned correctly for appletrailers. LinHES-config, mythinstall: change case of hd_pvr and serial to all lower refs #902 zilog-firmware: firmware for TX support of the hdpvr and pvr-150 In general I can't recommend anybody using these transmitters but including the firmware just in case someone really wants to linhes-udev-rules: added hdprv_lirc rule. All of these lirc rules are limited to exactly one device. If more then one device is present then only the last device in init will get the symlink runit-scripts: fix logging for igdeamon, add support to remote init script so that the blaster is always the first device in the chain. added support specificly for hd_pvr LinHES-system: add lh_system_restore and lh_system_backup. These scripts are called from the mythmenu. refs #900 iguanair: rebuild with python 2.7 LinHES-system: msg_daemon.py fix init and nasty bug related to timeout. In a nutshell timeout wouldn't work unless a msg without a timeout was called first. linhes-udev-rules: add rules for mce,streamzap,serial lirc devices. mythinstall: recompile for matching libs mythtv: latest .25-fixes and change mythbackup/restore call lh_system_$op to replace mythbackup/mythrestore. mythbackup no longer works correctly with the new windowmanager linhes-scripts: myth2mp3, myth2x264, myth2xvid: use mythutil to get cutlist LinHES-config, supplimental-web: Fix proxy numbering for Ceton infiniTV linhes-system: add additional stuff to the system backup and also introduced an exclude file. The exclude/include files are locate in /home/mythtv/backup_config/ ...
Diffstat (limited to 'abs/extra/chromium')
-rw-r--r--abs/extra/chromium/PKGBUILD139
-rw-r--r--abs/extra/chromium/chromium-20.0.1132.57-glib-2.16-use-siginfo_t.patch35
-rw-r--r--abs/extra/chromium/chromium-ppapi-r0.patch11
-rw-r--r--abs/extra/chromium/chromium.default4
-rw-r--r--abs/extra/chromium/chromium.desktop113
-rw-r--r--abs/extra/chromium/chromium.install12
-rwxr-xr-xabs/extra/chromium/chromium.sh16
7 files changed, 330 insertions, 0 deletions
diff --git a/abs/extra/chromium/PKGBUILD b/abs/extra/chromium/PKGBUILD
new file mode 100644
index 0000000..821ba39
--- /dev/null
+++ b/abs/extra/chromium/PKGBUILD
@@ -0,0 +1,139 @@
+# $Id: PKGBUILD 170409 2012-11-07 11:29:05Z foutrelis $
+# Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
+# Contributor: Pierre Schmitz <pierre@archlinux.de>
+# Contributor: Jan "heftig" Steffens <jan.steffens@gmail.com>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+
+pkgname=chromium
+pkgver=23.0.1271.64
+pkgrel=1
+pkgdesc="The open-source project behind Google Chrome, an attempt at creating a safer, faster, and more stable browser"
+arch=('i686' 'x86_64')
+url="http://www.chromium.org/"
+license=('BSD')
+depends=('gtk2' 'dbus-glib' 'nss' 'alsa-lib' 'xdg-utils' 'bzip2' 'libevent'
+ 'libxss' 'libgcrypt' 'ttf-dejavu' 'desktop-file-utils'
+ 'hicolor-icon-theme')
+makedepends=('python2' 'perl' 'gperf' 'yasm' 'mesa' 'libgnome-keyring'
+ 'elfutils' 'subversion' 'nacl-toolchain-newlib')
+optdepends=('kdebase-kdialog: needed for file dialogs in KDE')
+backup=('etc/chromium/default')
+install=chromium.install
+source=(http://commondatastorage.googleapis.com/chromium-browser-official/$pkgname-$pkgver.tar.bz2
+ chromium.desktop
+ chromium.default
+ chromium.sh
+ chromium-20.0.1132.57-glib-2.16-use-siginfo_t.patch
+ chromium-ppapi-r0.patch)
+sha256sums=('e894bb22d4747c69fc34b181be3a25e20fd9599ed93f08779df600fe3402ffe7'
+ '09bfac44104f4ccda4c228053f689c947b3e97da9a4ab6fa34ce061ee83d0322'
+ '478340d5760a9bd6c549e19b1b5d1c5b4933ebf5f8cfb2b3e2d70d07443fe232'
+ '4999fded897af692f4974f0a3e3bbb215193519918a1fa9b31ed51e74a2dccb9'
+ 'c1baf14121502efbc2a31b64029dcafa0e28ca5b71ad0e28a3c6342d18198615'
+ '1f4b57670d317959bc2dc60e5d2a44aa8fc6028f7ed540cdb502fa0aa99c81bd')
+
+build() {
+ cd "$srcdir/chromium-$pkgver"
+
+ # Fix build with glibc 2.16
+ patch -Np1 -i "$srcdir/chromium-20.0.1132.57-glib-2.16-use-siginfo_t.patch"
+
+ # Fix build without NaCl glibc toolchain (patch from Gentoo)
+ patch -Np0 -i "$srcdir/chromium-ppapi-r0.patch"
+
+ # http://code.google.com/p/chromium/issues/detail?id=109527
+ sed -i 's|glib/gutils.h|glib.h|' ui/base/l10n/l10n_util.cc
+
+ # Missing gyp files in tarball (http://crbug.com/144823)
+ sed -i '/nacl_test_data\.gyp/d' chrome/chrome_tests.gypi
+
+ # Use Python 2
+ find . -type f -exec sed -i -r \
+ -e 's|/usr/bin/python$|&2|g' \
+ -e 's|(/usr/bin/python2)\.4$|\1|g' \
+ {} +
+ # There are still a lot of relative calls which need a workaround
+ mkdir "$srcdir/python2-path"
+ ln -s /usr/bin/python2 "$srcdir/python2-path/python"
+ export PATH="$srcdir/python2-path:$PATH"
+
+ # Prepare NaCL toolchain
+ mkdir -p sdk native_client/toolchain/.tars
+ cp -a /usr/lib/nacl-toolchain-newlib sdk/nacl-sdk
+ tar czf native_client/toolchain/.tars/naclsdk_linux_x86.tgz sdk
+ rm -r sdk
+
+ # CFLAGS are passed through release_extra_cflags below
+ export -n CFLAGS CXXFLAGS
+
+ # Silence "identifier 'nullptr' is a keyword in C++11" warnings
+ CFLAGS+=' -Wno-c++0x-compat'
+
+ build/gyp_chromium --depth=. \
+ -Dwerror= \
+ -Dlinux_sandbox_path=/usr/lib/chromium/chromium-sandbox \
+ -Dlinux_strip_binary=1 \
+ -Dlinux_use_gold_binary=0 \
+ -Dlinux_use_gold_flags=0 \
+ -Drelease_extra_cflags="$CFLAGS" \
+ -Dffmpeg_branding=Chrome \
+ -Dproprietary_codecs=1 \
+ -Duse_system_bzip2=1 \
+ -Duse_system_ffmpeg=0 \
+ -Duse_system_libevent=1 \
+ -Duse_system_libjpeg=1 \
+ -Duse_system_libpng=1 \
+ -Duse_system_libxml=0 \
+ -Duse_system_ssl=0 \
+ -Duse_system_yasm=1 \
+ -Duse_system_zlib=0 \
+ -Duse_gconf=0 \
+ -Ddisable_glibc=1 \
+ -Ddisable_pnacl=1 \
+ -Ddisable_sse2=1
+
+ make chrome chrome_sandbox BUILDTYPE=Release
+}
+
+package() {
+ cd "$srcdir/chromium-$pkgver"
+
+ install -D out/Release/chrome "$pkgdir/usr/lib/chromium/chromium"
+
+ install -Dm4755 -o root -g root out/Release/chrome_sandbox \
+ "$pkgdir/usr/lib/chromium/chromium-sandbox"
+
+ cp out/Release/{*.pak,libffmpegsumo.so,nacl_helper{,_bootstrap}} \
+ out/Release/{libppGoogleNaClPluginChrome.so,nacl_irt_*.nexe} \
+ "$pkgdir/usr/lib/chromium/"
+
+ if [[ $CARCH == i686 ]]; then
+ rm "$pkgdir/usr/lib/chromium/nacl_irt_x86_64.nexe"
+ fi
+
+ # Allow users to override command-line options
+ install -Dm644 "$srcdir/chromium.default" "$pkgdir/etc/chromium/default"
+
+ cp -a out/Release/locales "$pkgdir/usr/lib/chromium/"
+
+ install -Dm644 out/Release/chrome.1 "$pkgdir/usr/share/man/man1/chromium.1"
+
+ install -Dm644 "$srcdir/chromium.desktop" \
+ "$pkgdir/usr/share/applications/chromium.desktop"
+
+ for size in 22 24 48 64 128 256; do
+ install -Dm644 "chrome/app/theme/chromium/product_logo_$size.png" \
+ "$pkgdir/usr/share/icons/hicolor/${size}x${size}/apps/chromium.png"
+ done
+
+ for size in 16 32; do
+ install -Dm644 "chrome/app/theme/default_100_percent/chromium/product_logo_$size.png" \
+ "$pkgdir/usr/share/icons/hicolor/${size}x${size}/apps/chromium.png"
+ done
+
+ install -D "$srcdir/chromium.sh" "$pkgdir/usr/bin/chromium"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/chromium/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/abs/extra/chromium/chromium-20.0.1132.57-glib-2.16-use-siginfo_t.patch b/abs/extra/chromium/chromium-20.0.1132.57-glib-2.16-use-siginfo_t.patch
new file mode 100644
index 0000000..1d11a39
--- /dev/null
+++ b/abs/extra/chromium/chromium-20.0.1132.57-glib-2.16-use-siginfo_t.patch
@@ -0,0 +1,35 @@
+diff -upr chromium-20.0.1132.57.orig/third_party/tcmalloc/chromium/src/base/linux_syscall_support.h chromium-20.0.1132.57/third_party/tcmalloc/chromium/src/base/linux_syscall_support.h
+--- chromium-20.0.1132.57.orig/third_party/tcmalloc/chromium/src/base/linux_syscall_support.h 2012-07-10 10:48:31.000000000 +0300
++++ chromium-20.0.1132.57/third_party/tcmalloc/chromium/src/base/linux_syscall_support.h 2012-07-11 23:44:11.000000000 +0300
+@@ -243,14 +243,13 @@ struct kernel_rusage {
+ long ru_nivcsw;
+ };
+
+-struct siginfo;
+ #if defined(__i386__) || defined(__arm__) || defined(__PPC__)
+
+ /* include/asm-{arm,i386,mips,ppc}/signal.h */
+ struct kernel_old_sigaction {
+ union {
+ void (*sa_handler_)(int);
+- void (*sa_sigaction_)(int, struct siginfo *, void *);
++ void (*sa_sigaction_)(int, siginfo_t *, void *);
+ };
+ unsigned long sa_mask;
+ unsigned long sa_flags;
+@@ -287,13 +286,13 @@ struct kernel_sigaction {
+ unsigned long sa_flags;
+ union {
+ void (*sa_handler_)(int);
+- void (*sa_sigaction_)(int, struct siginfo *, void *);
++ void (*sa_sigaction_)(int, siginfo_t *, void *);
+ };
+ struct kernel_sigset_t sa_mask;
+ #else
+ union {
+ void (*sa_handler_)(int);
+- void (*sa_sigaction_)(int, struct siginfo *, void *);
++ void (*sa_sigaction_)(int, siginfo_t *, void *);
+ };
+ unsigned long sa_flags;
+ void (*sa_restorer)(void);
diff --git a/abs/extra/chromium/chromium-ppapi-r0.patch b/abs/extra/chromium/chromium-ppapi-r0.patch
new file mode 100644
index 0000000..fb7e160
--- /dev/null
+++ b/abs/extra/chromium/chromium-ppapi-r0.patch
@@ -0,0 +1,11 @@
+--- ppapi/ppapi_untrusted.gyp.orig 2012-06-12 10:20:16.000000000 +0200
++++ ppapi/ppapi_untrusted.gyp 2012-06-12 10:20:52.000000000 +0200
+@@ -80,7 +80,7 @@
+ ],
+ },
+ 'conditions': [
+- ['target_arch!="arm"', {
++ ['target_arch!="arm" and disable_glibc==0', {
+ 'variables': {
+ 'build_glibc': 1,
+ # NOTE: Use /lib, not /lib64 here; it is a symbolic link which
diff --git a/abs/extra/chromium/chromium.default b/abs/extra/chromium/chromium.default
new file mode 100644
index 0000000..2632024
--- /dev/null
+++ b/abs/extra/chromium/chromium.default
@@ -0,0 +1,4 @@
+# Default settings for chromium. This file is sourced by /usr/bin/chromium
+
+# Options to pass to chromium
+CHROMIUM_FLAGS=""
diff --git a/abs/extra/chromium/chromium.desktop b/abs/extra/chromium/chromium.desktop
new file mode 100644
index 0000000..18446d4
--- /dev/null
+++ b/abs/extra/chromium/chromium.desktop
@@ -0,0 +1,113 @@
+[Desktop Entry]
+Version=1.0
+Name=Chromium
+# Only KDE 4 seems to use GenericName, so we reuse the KDE strings.
+# From Ubuntu's language-pack-kde-XX-base packages, version 9.04-20090413.
+GenericName=Web Browser
+GenericName[ar]=متصفح الشبكة
+GenericName[bg]=Уеб браузър
+GenericName[ca]=Navegador web
+GenericName[cs]=WWW prohlížeč
+GenericName[da]=Browser
+GenericName[de]=Web-Browser
+GenericName[el]=Περιηγητής ιστού
+GenericName[en_GB]=Web Browser
+GenericName[es]=Navegador web
+GenericName[et]=Veebibrauser
+GenericName[fi]=WWW-selain
+GenericName[fr]=Navigateur Web
+GenericName[gu]=વેબ બ્રાઉઝર
+GenericName[he]=דפדפן אינטרנט
+GenericName[hi]=वेब ब्राउज़र
+GenericName[hu]=Webböngésző
+GenericName[it]=Browser Web
+GenericName[ja]=ウェブブラウザ
+GenericName[kn]=ಜಾಲ ವೀಕ್ಷಕ
+GenericName[ko]=웹 브라우저
+GenericName[lt]=Žiniatinklio naršyklė
+GenericName[lv]=Tīmekļa pārlūks
+GenericName[ml]=വെബ് ബ്രൌസര്‍
+GenericName[mr]=वेब ब्राऊजर
+GenericName[nb]=Nettleser
+GenericName[nl]=Webbrowser
+GenericName[pl]=Przeglądarka WWW
+GenericName[pt]=Navegador Web
+GenericName[pt_BR]=Navegador da Internet
+GenericName[ro]=Navigator de Internet
+GenericName[ru]=Веб-браузер
+GenericName[sl]=Spletni brskalnik
+GenericName[sv]=Webbläsare
+GenericName[ta]=இணைய உலாவி
+GenericName[th]=เว็บเบราว์เซอร์
+GenericName[tr]=Web Tarayıcı
+GenericName[uk]=Навігатор Тенет
+GenericName[zh_CN]=网页浏览器
+GenericName[zh_HK]=網頁瀏覽器
+GenericName[zh_TW]=網頁瀏覽器
+# Not translated in KDE, from Epiphany 2.26.1-0ubuntu1.
+GenericName[bn]=ওয়েব ব্রাউজার
+GenericName[fil]=Web Browser
+GenericName[hr]=Web preglednik
+GenericName[id]=Browser Web
+GenericName[or]=ଓ୍ବେବ ବ୍ରାଉଜର
+GenericName[sk]=WWW prehliadač
+GenericName[sr]=Интернет прегледник
+GenericName[te]=మహాతల అన్వేషి
+GenericName[vi]=Bộ duyệt Web
+# Gnome and KDE 3 uses Comment.
+Comment=Access the Internet
+Comment[ar]=الدخول إلى الإنترنت
+Comment[bg]=Достъп до интернет
+Comment[bn]=ইন্টারনেটটি অ্যাক্সেস করুন
+Comment[ca]=Accedeix a Internet
+Comment[cs]=Přístup k internetu
+Comment[da]=Få adgang til internettet
+Comment[de]=Internetzugriff
+Comment[el]=Πρόσβαση στο Διαδίκτυο
+Comment[en_GB]=Access the Internet
+Comment[es]=Accede a Internet.
+Comment[et]=Pääs Internetti
+Comment[fi]=Käytä internetiä
+Comment[fil]=I-access ang Internet
+Comment[fr]=Accéder à Internet
+Comment[gu]=ઇંટરનેટ ઍક્સેસ કરો
+Comment[he]=גישה אל האינטרנט
+Comment[hi]=इंटरनेट तक पहुंच स्थापित करें
+Comment[hr]=Pristup Internetu
+Comment[hu]=Internetelérés
+Comment[id]=Akses Internet
+Comment[it]=Accesso a Internet
+Comment[ja]=インターネットにアクセス
+Comment[kn]=ಇಂಟರ್ನೆಟ್ ಅನ್ನು ಪ್ರವೇಶಿಸಿ
+Comment[ko]=인터넷 연결
+Comment[lt]=Interneto prieiga
+Comment[lv]=Piekļūt internetam
+Comment[ml]=ഇന്റര്‍‌നെറ്റ് ആക്‌സസ് ചെയ്യുക
+Comment[mr]=इंटरनेटमध्ये प्रवेश करा
+Comment[nb]=Gå til Internett
+Comment[nl]=Verbinding maken met internet
+Comment[or]=ଇଣ୍ଟର୍ନେଟ୍ ପ୍ରବେଶ କରନ୍ତୁ
+Comment[pl]=Skorzystaj z internetu
+Comment[pt]=Aceder à Internet
+Comment[pt_BR]=Acessar a internet
+Comment[ro]=Accesaţi Internetul
+Comment[ru]=Доступ в Интернет
+Comment[sk]=Prístup do siete Internet
+Comment[sl]=Dostop do interneta
+Comment[sr]=Приступите Интернету
+Comment[sv]=Gå ut på Internet
+Comment[ta]=இணையத்தை அணுகுதல்
+Comment[te]=ఇంటర్నెట్‌ను ఆక్సెస్ చెయ్యండి
+Comment[th]=เข้าถึงอินเทอร์เน็ต
+Comment[tr]=İnternet'e erişin
+Comment[uk]=Доступ до Інтернету
+Comment[vi]=Truy cập Internet
+Comment[zh_CN]=访问互联网
+Comment[zh_HK]=連線到網際網路
+Comment[zh_TW]=連線到網際網路
+Exec=chromium %U
+Terminal=false
+Icon=chromium
+Type=Application
+Categories=GTK;Network;WebBrowser;
+MimeType=text/html;text/xml;application/xhtml+xml;text/mml;x-scheme-handler/http;x-scheme-handler/https;
diff --git a/abs/extra/chromium/chromium.install b/abs/extra/chromium/chromium.install
new file mode 100644
index 0000000..d43ea7c
--- /dev/null
+++ b/abs/extra/chromium/chromium.install
@@ -0,0 +1,12 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &>/dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/abs/extra/chromium/chromium.sh b/abs/extra/chromium/chromium.sh
new file mode 100755
index 0000000..ba8a7e6
--- /dev/null
+++ b/abs/extra/chromium/chromium.sh
@@ -0,0 +1,16 @@
+#!/bin/bash
+
+# Allow users to override command-line options
+# Based on Gentoo's chromium package (and by extension, Debian's)
+if [[ -f /etc/chromium/default ]]; then
+ . /etc/chromium/default
+fi
+
+# Prefer user defined CHROMIUM_USER_FLAGS (from env) over system
+# default CHROMIUM_FLAGS (from /etc/chromium/default)
+CHROMIUM_FLAGS=${CHROMIUM_USER_FLAGS:-$CHROMIUM_FLAGS}
+
+export CHROME_WRAPPER=$(readlink -f "$0")
+export CHROME_DESKTOP=chromium.desktop
+
+exec /usr/lib/chromium/chromium $CHROMIUM_FLAGS "$@"