summaryrefslogtreecommitdiffstats
path: root/abs/extra/community/fluidsynth
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-11-25 04:49:14 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-11-25 04:49:14 (GMT)
commitf591ead4c8a9b64b0630900aa12c260027a7db6f (patch)
tree091b31cdc3a24c0b9108f0ea718ecaad166cc834 /abs/extra/community/fluidsynth
parent9b35fb3e4f637252b4674a78adf9026faeaa5340 (diff)
downloadlinhes_pkgbuild-f591ead4c8a9b64b0630900aa12c260027a7db6f.zip
linhes_pkgbuild-f591ead4c8a9b64b0630900aa12c260027a7db6f.tar.gz
linhes_pkgbuild-f591ead4c8a9b64b0630900aa12c260027a7db6f.tar.bz2
compiled/added programs needed by xbmc: Moved some programs out of community into extra.
libmpeg2 pm-utils afpfs-ng fluidsynth libmodplug libnfs libshairport dbus-c__ doxygen libocnfig libffado libimobiledevice libmicrothttpd sdl_image sdl_mixer smpeg upower usbmuxd vdpau-video
Diffstat (limited to 'abs/extra/community/fluidsynth')
-rw-r--r--abs/extra/community/fluidsynth/PKGBUILD45
-rw-r--r--abs/extra/community/fluidsynth/fluidsynth.conf2
-rw-r--r--abs/extra/community/fluidsynth/fluidsynthd40
3 files changed, 0 insertions, 87 deletions
diff --git a/abs/extra/community/fluidsynth/PKGBUILD b/abs/extra/community/fluidsynth/PKGBUILD
deleted file mode 100644
index 944222e..0000000
--- a/abs/extra/community/fluidsynth/PKGBUILD
+++ /dev/null
@@ -1,45 +0,0 @@
-# $Id: PKGBUILD 94804 2010-10-11 11:48:58Z schiv $
-# Maintainer: Ray Rashif <schiv@archlinux.org>
-# Contributor: damir <damir@archlinux.org>
-
-pkgname=fluidsynth
-pkgver=1.1.3
-pkgrel=1
-pkgdesc="A real-time software synthesizer based on the SoundFont 2 specifications"
-arch=(i686 x86_64)
-url="http://www.fluidsynth.org/"
-depends=('glib2' 'jack' 'dbus-core')
-makedepends=('cmake' 'ladspa' 'doxygen')
-optdepends=('bash: init script')
-license=('LGPL')
-backup=('etc/conf.d/fluidsynth')
-source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
- fluidsynth.conf
- fluidsynthd)
-md5sums=('0d3e3cc770b4da413010dfb7dfdce9c8'
- '16c5f4d4cbdddc6c5fcbd4fd4cc142f1'
- 'b296dbfb524c2164f552f68bd9abe2ec')
-
-build() {
- cd "$srcdir/$pkgname-$pkgver"
-
- cmake . -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -Denable-ladspa=ON \
- -DLIB_SUFFIX=""
- make
-}
-
-package() {
- cd "$srcdir/$pkgname-$pkgver"
-
- make DESTDIR="$pkgdir/" install
-
- install -Dm644 "$srcdir/fluidsynth.conf" \
- "$pkgdir/etc/conf.d/fluidsynth"
-
- install -Dm755 "$srcdir/fluidsynthd" \
- "$pkgdir/etc/rc.d/fluidsynth"
-}
-
-# vim:set ts=2 sw=2 et:
diff --git a/abs/extra/community/fluidsynth/fluidsynth.conf b/abs/extra/community/fluidsynth/fluidsynth.conf
deleted file mode 100644
index 5267d58..0000000
--- a/abs/extra/community/fluidsynth/fluidsynth.conf
+++ /dev/null
@@ -1,2 +0,0 @@
-FSYNTH_OPTS="-a alsa -m alsa_seq -r 48000"
-FSYNTH_SOUNDFONT="" \ No newline at end of file
diff --git a/abs/extra/community/fluidsynth/fluidsynthd b/abs/extra/community/fluidsynth/fluidsynthd
deleted file mode 100644
index ca1e8fa..0000000
--- a/abs/extra/community/fluidsynth/fluidsynthd
+++ /dev/null
@@ -1,40 +0,0 @@
-#!/bin/bash
-
-. /etc/rc.conf
-. /etc/rc.d/functions
-
-[ -f /etc/conf.d/fluidsynth ] && . /etc/conf.d/fluidsynth
-
-PID=`pidof -o %PPID /usr/bin/fluidsynth`
-case "$1" in
- start)
- stat_busy "Starting Fluidsynth soundfont synthesizer"
- [ -z "$PID" ] && /usr/bin/fluidsynth -is $FSYNTH_OPTS $FSYNTH_SOUNDFONT > /dev/null 2>&1 &
- if [ $? -gt 0 ]; then
- stat_fail
- else
- echo $PID > /var/run/fluidsynth.pid
- add_daemon fluidsynth
- stat_done
- fi
- ;;
- stop)
- stat_busy "Stopping Fluidsynth soundfont synthesizer"
- [ ! -z "$PID" ] && kill $PID &> /dev/null 2>&1
- if [ $? -gt 0 ]; then
- stat_fail
- else
- rm /var/run/fluidsynth.pid
- rm_daemon fluidsynth
- stat_done
- fi
- ;;
- restart)
- $0 stop
- sleep 1
- $0 start
- ;;
- *)
- echo "usage: $0 {start|stop|restart}"
-esac
-exit 0