summaryrefslogtreecommitdiffstats
path: root/abs/extra/community/libdnet
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-11-06 18:49:00 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-11-06 18:49:00 (GMT)
commit181eafab8fbe39fa6c76f4e6a375e268e7a136a8 (patch)
tree5c3bc598d11b3371ba02c183870277beb0367515 /abs/extra/community/libdnet
parent211b62b13978675a5bd9f1369ed23ff6e2425338 (diff)
downloadlinhes_pkgbuild-181eafab8fbe39fa6c76f4e6a375e268e7a136a8.zip
linhes_pkgbuild-181eafab8fbe39fa6c76f4e6a375e268e7a136a8.tar.gz
linhes_pkgbuild-181eafab8fbe39fa6c76f4e6a375e268e7a136a8.tar.bz2
libdnet: initial import, needed for vmware-tools
Diffstat (limited to 'abs/extra/community/libdnet')
-rw-r--r--abs/extra/community/libdnet/PKGBUILD33
-rw-r--r--abs/extra/community/libdnet/libdnet.install3
2 files changed, 36 insertions, 0 deletions
diff --git a/abs/extra/community/libdnet/PKGBUILD b/abs/extra/community/libdnet/PKGBUILD
new file mode 100644
index 0000000..70cf6e4
--- /dev/null
+++ b/abs/extra/community/libdnet/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 27071 2010-09-17 12:26:08Z schuay $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: James Fryman <jfryman@gmail.com>
+
+pkgname=libdnet
+pkgver=1.12
+pkgrel=5
+pkgdesc="A simplified, portable interface to several low-level networking routines"
+arch=(i686 x86_64)
+makedepends=(python2)
+optdepends=(python2)
+install=(libdnet.install)
+license=("BSD")
+url="http://code.google.com/p/libdnet/"
+options=('!libtool')
+source=(http://libdnet.googlecode.com/files/libdnet-$pkgver.tgz)
+md5sums=('9253ef6de1b5e28e9c9a62b882e44cc9')
+
+build() {
+ mkdir -p $pkgdir/usr/bin
+
+ [ $CARCH == "x86_64" ] && export CFLAGS=-fPIC
+
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ make && make DESTDIR=$pkgdir install
+
+ cd python && \
+ python2 setup.py install --root=$pkgdir
+
+ install -D -m0644 ../LICENSE $pkgdir/usr/share/licenses/libdnet/license
+ mv $pkgdir/usr/man $startdir/pkg/usr/share/
+}
diff --git a/abs/extra/community/libdnet/libdnet.install b/abs/extra/community/libdnet/libdnet.install
new file mode 100644
index 0000000..cb8146f
--- /dev/null
+++ b/abs/extra/community/libdnet/libdnet.install
@@ -0,0 +1,3 @@
+post_install() {
+ /sbin/ldconfig
+}