summaryrefslogtreecommitdiffstats
path: root/abs/extra/community
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 19:42:42 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 19:42:42 (GMT)
commit24cedac21bb09bb9a895054fb4cec679487ab6a8 (patch)
tree248f3324776158f36498a4d51c677efe9cd61fa8 /abs/extra/community
parentda8d18587536334f9548cab4069ba12e81c31e3b (diff)
downloadlinhes_pkgbuild-24cedac21bb09bb9a895054fb4cec679487ab6a8.zip
linhes_pkgbuild-24cedac21bb09bb9a895054fb4cec679487ab6a8.tar.gz
linhes_pkgbuild-24cedac21bb09bb9a895054fb4cec679487ab6a8.tar.bz2
gstreamer -base .10.36
Diffstat (limited to 'abs/extra/community')
-rw-r--r--abs/extra/community/gstreamer0.10-base/PKGBUILD35
1 files changed, 21 insertions, 14 deletions
diff --git a/abs/extra/community/gstreamer0.10-base/PKGBUILD b/abs/extra/community/gstreamer0.10-base/PKGBUILD
index 8b115a1..5bfea48 100644
--- a/abs/extra/community/gstreamer0.10-base/PKGBUILD
+++ b/abs/extra/community/gstreamer0.10-base/PKGBUILD
@@ -1,46 +1,53 @@
-# $Id: PKGBUILD 87769 2010-08-18 09:20:05Z jgc $
+# $Id: PKGBUILD 153257 2012-03-12 15:48:41Z jgc $
# Maintainer: Jan de Groot <jgc@archlinux.org>
pkgbase=('gstreamer0.10-base')
pkgname=('gstreamer0.10-base' 'gstreamer0.10-base-plugins')
-pkgver=0.10.30
+pkgver=0.10.36
pkgrel=1
arch=('i686' 'x86_64')
license=('LGPL')
-makedepends=('pkgconfig' 'gstreamer0.10>=0.10.30' 'orc>=0.4.6' 'libsm>=1.1.1' 'libxv>=1.0.5' 'alsa-lib>=1.0.23' 'cdparanoia>=10.2' 'libvisual>=0.4.0' 'libvorbis>=1.3.1' 'libtheora>=1.1.1' 'pango>=1.28.1' 'udev>=151' 'gobject-introspection')
+makedepends=('pkgconfig' 'gstreamer0.10>=0.10.35' 'orc' 'libxv' 'alsa-lib' 'cdparanoia' 'libvisual' 'libvorbis' 'libtheora' 'pango' 'gobject-introspection')
options=(!libtool !emptydirs)
url="http://gstreamer.freedesktop.org/"
-source=(${url}/src/gst-plugins-base/gst-plugins-base-${pkgver}.tar.bz2)
-sha256sums=('63938641380be9935c804ae8d55acdcfd93920ed2deb72dcf70f027a78b085d7')
+source=(${url}/src/gst-plugins-base/gst-plugins-base-${pkgver}.tar.xz)
+sha256sums=('1fe45c3894903001d4d008b0713dab089f53726dcb5842d5b40c2595a984e64a')
build() {
cd "${srcdir}/gst-plugins-base-${pkgver}"
+ sed -i '/AC_PATH_XTRA/d' configure.ac
+ autoreconf
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
--disable-static --enable-experimental --disable-gnome_vfs \
--with-package-name="GStreamer Base Plugins (Archlinux)" \
- --with-package-origin="http://www.archlinux.org/" || return 1
+ --with-package-origin="http://www.archlinux.org/"
- make || return 1
- sed -e 's/^SUBDIRS_EXT =.*/SUBDIRS_EXT =/' -i Makefile || return 1
+ make
+ sed -e 's/^SUBDIRS_EXT =.*/SUBDIRS_EXT =/' -i Makefile
+}
+
+check() {
+ cd "${srcdir}/gst-plugins-base-${pkgver}"
+ make check
}
package_gstreamer0.10-base() {
pkgdesc="GStreamer Multimedia Framework Base plugin libraries"
- depends=('gstreamer0.10>=0.10.30' 'orc>=0.4.6' 'libsm>=1.1.1' 'libxv>=1.0.5' 'udev>=151')
+ depends=('gstreamer0.10>=0.10.35' 'orc' 'libxv')
cd "${srcdir}/gst-plugins-base-${pkgver}"
- make DESTDIR="${pkgdir}" install || return 1
+ make DESTDIR="${pkgdir}" install
}
package_gstreamer0.10-base-plugins() {
pkgdesc="GStreamer Multimedia Framework Base Plugins (gst-plugins-base)"
- depends=("gstreamer0.10-base=${pkgver}" 'alsa-lib>=1.0.23' 'cdparanoia>=10.2' 'libvisual>=0.4.0' 'libvorbis>=1.3.1' 'libtheora>=1.1.1' 'pango>=1.28.1')
+ depends=("gstreamer0.10-base=${pkgver}" 'alsa-lib' 'cdparanoia' 'libvisual' 'libvorbis' 'libtheora' 'pango')
replaces=('gstreamer0.10-alsa' 'gstreamer0.10-theora' 'gstreamer0.10-libvisual' 'gstreamer0.10-pango' 'gstreamer0.10-cdparanoia' 'gstreamer0.10-vorbis' 'gstreamer0.10-ogg')
conflicts=('gstreamer0.10-alsa' 'gstreamer0.10-theora' 'gstreamer0.10-libvisual' 'gstreamer0.10-pango' 'gstreamer0.10-cdparanoia' 'gstreamer0.10-vorbis' 'gstreamer0.10-ogg')
groups=('gstreamer0.10-plugins')
cd "${srcdir}/gst-plugins-base-${pkgver}"
- make -C gst-libs DESTDIR="${pkgdir}" install || return 1
- make -C ext DESTDIR="${pkgdir}" install || return 1
- make -C gst-libs DESTDIR="${pkgdir}" uninstall || return 1
+ make -C gst-libs DESTDIR="${pkgdir}" install
+ make -C ext DESTDIR="${pkgdir}" install
+ make -C gst-libs DESTDIR="${pkgdir}" uninstall
}