summaryrefslogtreecommitdiffstats
path: root/abs/extra/community
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-15 15:41:53 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-15 15:41:53 (GMT)
commit31eff8d1946b1c6203f0e65f329860dbab7bafe4 (patch)
treedca3ce5c1c41efb55d46de0a1e139e5dace6111a /abs/extra/community
parent460a1306956f83ac2355f40ccfb00eb554973d87 (diff)
downloadlinhes_pkgbuild-31eff8d1946b1c6203f0e65f329860dbab7bafe4.zip
linhes_pkgbuild-31eff8d1946b1c6203f0e65f329860dbab7bafe4.tar.gz
linhes_pkgbuild-31eff8d1946b1c6203f0e65f329860dbab7bafe4.tar.bz2
libtorrent-rasterbar: .16.2
Diffstat (limited to 'abs/extra/community')
-rw-r--r--abs/extra/community/libtorrent-rasterbar/PKGBUILD31
-rw-r--r--abs/extra/community/libtorrent-rasterbar/__changelog1
2 files changed, 16 insertions, 16 deletions
diff --git a/abs/extra/community/libtorrent-rasterbar/PKGBUILD b/abs/extra/community/libtorrent-rasterbar/PKGBUILD
index dc719f9..ea71f07 100644
--- a/abs/extra/community/libtorrent-rasterbar/PKGBUILD
+++ b/abs/extra/community/libtorrent-rasterbar/PKGBUILD
@@ -1,30 +1,31 @@
-# $Id: PKGBUILD 100316 2010-11-22 16:29:19Z ibiru $
+# $Id: PKGBUILD 163820 2012-07-20 21:36:20Z ibiru $
# Maintainer : Ionut Biru <ibiru@archlinux.org>
# Contributor: Hugo Doria <hugo@archlinux.org>
-# Contributor: Andrea Scarpino <bash.lnx@gmail.com>
pkgname=libtorrent-rasterbar
-pkgver=0.15.4
-pkgrel=3
+pkgver=0.16.2
+pkgrel=1
+epoch=1
pkgdesc="A C++ library that aims to be a good alternative to all the other bittorrent implementations around"
url="http://www.rasterbar.com/products/libtorrent/"
arch=('i686' 'x86_64')
license=('custom')
-depends=('boost-libs>=1.44.0' 'python2')
+depends=('boost-libs' 'geoip' 'python2')
makedepends=('boost')
-source=(http://libtorrent.googlecode.com/files/${pkgname}-${pkgver}.tar.gz)
-md5sums=('58750b3a246d056335745f9e805bb949')
+options=('!libtool' '!emptydirs')
+source=(http://libtorrent.googlecode.com/files/$pkgname-$pkgver.tar.gz)
+sha1sums=('04da641d21d0867fc103f4f57ffd41b3fce19ead')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix=/usr --enable-python-binding \
- --with-boost-filesystem=mt \
- --with-boost-thread=mt
+ cd $pkgname-$pkgver
+ PYTHON2=/usr/bin/python2 ./configure --prefix=/usr \
+ --enable-python-binding \
+ --with-libgeoip=system
make
}
+
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
- install -D COPYING "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+ install -D COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-
diff --git a/abs/extra/community/libtorrent-rasterbar/__changelog b/abs/extra/community/libtorrent-rasterbar/__changelog
deleted file mode 100644
index 6528095..0000000
--- a/abs/extra/community/libtorrent-rasterbar/__changelog
+++ /dev/null
@@ -1 +0,0 @@
-change boost-lib dep to >=1.44