summaryrefslogtreecommitdiffstats
path: root/abs/extra/community
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2012-04-27 04:13:29 (GMT)
committerCecil <knoppmyth@gmail.com>2012-04-27 04:13:29 (GMT)
commit710498de3e1a0d6870e7461ca5a65415b1ea5398 (patch)
tree863d7e22962468ee02fcaa73349ceec487c69c10 /abs/extra/community
parentc7112b961322bf9c20282e3bbfb95b2ccf3fa97f (diff)
downloadlinhes_pkgbuild-710498de3e1a0d6870e7461ca5a65415b1ea5398.zip
linhes_pkgbuild-710498de3e1a0d6870e7461ca5a65415b1ea5398.tar.gz
linhes_pkgbuild-710498de3e1a0d6870e7461ca5a65415b1ea5398.tar.bz2
dolphin-emu:Version 3.0, initial inclusion.
Diffstat (limited to 'abs/extra/community')
-rw-r--r--abs/extra/community/dolphin-emu/Dolphin_Logo.pngbin0 -> 62052 bytes
-rw-r--r--abs/extra/community/dolphin-emu/PKGBUILD75
-rw-r--r--abs/extra/community/dolphin-emu/dolphin-emu.desktop11
-rw-r--r--abs/extra/community/dolphin-emu/unistd.diff11
4 files changed, 97 insertions, 0 deletions
diff --git a/abs/extra/community/dolphin-emu/Dolphin_Logo.png b/abs/extra/community/dolphin-emu/Dolphin_Logo.png
new file mode 100644
index 0000000..63450da
--- /dev/null
+++ b/abs/extra/community/dolphin-emu/Dolphin_Logo.png
Binary files differ
diff --git a/abs/extra/community/dolphin-emu/PKGBUILD b/abs/extra/community/dolphin-emu/PKGBUILD
new file mode 100644
index 0000000..a617981
--- /dev/null
+++ b/abs/extra/community/dolphin-emu/PKGBUILD
@@ -0,0 +1,75 @@
+# Maintainer: schuay <jakob.gruber@gmail.com>
+# Contributor: Jeremy Newton (Mystro256)
+# Special thanks to the contributors of dolphin-emu-svn: for the icon, desktop file and some lines from the PKGBUILD
+# Thanks to all that contributed! :)
+
+pkgname=dolphin-emu
+pkgver=3.0
+pkgrel=9
+epoch=1
+pkgdesc="A GameCube and Wii emulator (stable git branch)"
+arch=('i686' 'x86_64')
+url="http://www.dolphin-emulator.com/"
+license=('GPL2')
+
+makedepends=('git' 'cmake' 'glproto' 'opencl-headers')
+depends=('sdl' 'libxxf86vm' 'libao' 'wxgtk' 'wiiuse' 'nvidia-cg-toolkit' \
+ 'glew' 'mesa' 'libgl' 'openal' 'portaudio' 'lzo2')
+
+# Cannot be BUILT with sfml later than 1.6
+# IF YOU NEED SFML>=1.7 FOR SOMETHING ELSE, TRY REMOVING THE CONFLICT
+# BELOW AND ONLY TEMPORARY UNINSTALLING SFML TO BUILD/INSTALL DOLPHIN
+conflicts=('dolphin-emu-git' 'sfml>=1.7' 'sfml-git')
+
+source=('dolphin-emu.desktop'
+ 'unistd.diff'
+ 'Dolphin_Logo.png')
+
+_gitroot=https://code.google.com/p/dolphin-emu/
+_gitname=dolphin-emu-3.0
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin 3.0
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+
+ msg "Checking out at stable 3.0 branch"
+ git checkout 3.0
+
+ msg "GIT checkout done or server timeout"
+
+ patch -Np2 < ${srcdir}/unistd.diff
+
+ mkdir build && cd build
+ export CXXFLAGS="$CXXFLAGS -fpermissive"
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/dolphin-emu-3.0-build/build"
+
+ make DESTDIR=${pkgdir} install
+
+ install -Dm644 "${srcdir}/dolphin-emu.desktop" "${pkgdir}/usr/share/applications/dolphin-emu.desktop"
+ install -Dm644 "${srcdir}/Dolphin_Logo.png" "${pkgdir}/usr/share/pixmaps/dolphin-emu.png"
+}
+
+# vim:set ts=2 sw=2 et:
+
+md5sums=('feed4580c2e6bfbc7f6c67dad861daae'
+ 'a463b96d02462b5f6b0894f6ced821ab'
+ 'd15c51f547b4bd47e510faac40bcc9d6')
diff --git a/abs/extra/community/dolphin-emu/dolphin-emu.desktop b/abs/extra/community/dolphin-emu/dolphin-emu.desktop
new file mode 100644
index 0000000..96317d1
--- /dev/null
+++ b/abs/extra/community/dolphin-emu/dolphin-emu.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Dolphin
+Categories=Game;Emulator;GTK;
+GenericName=GameCube and Wii Emulator
+Comment=An emulator for the GameCube and Wii consoles
+Exec=dolphin-emu
+Icon=dolphin-emu
+StartupNotify=false
+Name[en_US]=Dolphin
diff --git a/abs/extra/community/dolphin-emu/unistd.diff b/abs/extra/community/dolphin-emu/unistd.diff
new file mode 100644
index 0000000..2b39063
--- /dev/null
+++ b/abs/extra/community/dolphin-emu/unistd.diff
@@ -0,0 +1,11 @@
+--- src/dolphin-emu-3.0/Source/Core/Common/Src/CommonFuncs.h 2012-04-07 10:47:47.595151504 +0200
++++ src/dolphin-emu-3.0-build/Source/Core/Common/Src/CommonFuncs.h 2012-04-07 10:53:25.371113081 +0200
+@@ -18,6 +18,8 @@
+ #ifndef _COMMONFUNCS_H_
+ #define _COMMONFUNCS_H_
+
++#include <unistd.h>
++
+ #ifdef _WIN32
+ #define SLEEP(x) Sleep(x)
+ #else