summaryrefslogtreecommitdiffstats
path: root/abs/extra/community
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-31 00:28:39 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-31 00:28:39 (GMT)
commita2ae6e3637c5a1fa46c2269b1dfc661db9a03009 (patch)
treec8d806a114414fef0b72ae3bdf8ec4b8f11ee8dc /abs/extra/community
parentaeee21c9afdd4d93c5a793b28a04e5a947fee30f (diff)
downloadlinhes_pkgbuild-a2ae6e3637c5a1fa46c2269b1dfc661db9a03009.zip
linhes_pkgbuild-a2ae6e3637c5a1fa46c2269b1dfc661db9a03009.tar.gz
linhes_pkgbuild-a2ae6e3637c5a1fa46c2269b1dfc661db9a03009.tar.bz2
mythpywii remove references to /home/mythtv
Diffstat (limited to 'abs/extra/community')
-rw-r--r--abs/extra/community/mythpywii/PKGBUILD11
-rw-r--r--abs/extra/community/mythpywii/mythpywii.install14
2 files changed, 17 insertions, 8 deletions
diff --git a/abs/extra/community/mythpywii/PKGBUILD b/abs/extra/community/mythpywii/PKGBUILD
index 3d4cf92..509db19 100644
--- a/abs/extra/community/mythpywii/PKGBUILD
+++ b/abs/extra/community/mythpywii/PKGBUILD
@@ -13,6 +13,9 @@ install=mythpywii.install
source=(http://www.benjiegillam.com/code/myth_py_wii.py \
wiimote.rules mythpywii.install CONTROLS)
+. /usr/MythVantage/bin/install_functions.sh
+home_check
+
build() {
/bin/true
@@ -22,13 +25,13 @@ build() {
package() {
install -D -m755 ${srcdir}/myth_py_wii.py ${startdir}/pkg/usr/bin/myth_py_wii.py || return 1
install -D -m644 ${srcdir}/wiimote.rules ${startdir}/pkg/etc/udev/rules.d/z90-wiimote.rules || return 1
- install -d -o mythtv -g mythtv ${startdir}/pkg/home/mythtv/.cwiid/wminput || return 1
- install -D -m755 -o mythtv -g mythtv /etc/cwiid/wminput/{acc_led,buttons,gamepad,neverball,nunchuk_stick2btn,acc_ptr,ir_ptr,nunchuk_acc_ptr} ${startdir}/pkg/home/mythtv/.cwiid/wminput || return 1
+ install -d -o mythtv -g mythtv ${startdir}/pkg/$MYTHHOME/.cwiid/wminput || return 1
+ install -D -m755 -o mythtv -g mythtv /etc/cwiid/wminput/{acc_led,buttons,gamepad,neverball,nunchuk_stick2btn,acc_ptr,ir_ptr,nunchuk_acc_ptr} ${startdir}/pkg/$MYTHHOME/.cwiid/wminput || return 1
install -D -m644 ${srcdir}/CONTROLS ${startdir}/pkg/usr/share/docs/mythpywii/CONTROLS || return 1
- cd ${startdir}/pkg/home/mythtv/.cwiid/wminput
+ cd ${startdir}/pkg$MYTHHOME/.cwiid/wminput
ln -s acc_led default
}
md5sums=('52b756c403349640c3e66f485b6c0a54'
'0d817a971d414b9320587a4cf289386b'
- '64fa8dbd324dac68f71753ebd828d358'
+ '18a4c2936a731191e2db92211b254b66'
'0872cbdb3def3dd9aa2b97b191ad76d8')
diff --git a/abs/extra/community/mythpywii/mythpywii.install b/abs/extra/community/mythpywii/mythpywii.install
index 8d0b867..76b9c6e 100644
--- a/abs/extra/community/mythpywii/mythpywii.install
+++ b/abs/extra/community/mythpywii/mythpywii.install
@@ -1,5 +1,5 @@
post_install() {
- . /home/mythtv/.mythtv/mysql.txt
+ . /$MYTHHOME/.mythtv/mysql.txt
# Enable the Network Remote Control Interface for use with the wiimote.
# Get local machine's hostname
HOST=`cat /etc/hostname`
@@ -12,7 +12,7 @@ post_install() {
echo "changed it to something else."
echo "------------------------------------------------------------"
# Add myth_py_wii.py to ~/mythtv/.fluxbox/apps before LinHES-run
- sed -i '/LinHES-run/ i [startup] {/usr/bin/myth_py_wii.py >/dev/null}' /home/mythtv/.fluxbox/apps
+ sed -i '/LinHES-run/ i [startup] {/usr/bin/myth_py_wii.py >/dev/null}' /$MYTHHOME/.fluxbox/apps
# udev needs to pick up our new rule for the mythpywii.
udevadm trigger --subsystem-match="misc" --subsystem-match="bluetooth"
# Add the uinput module
@@ -45,15 +45,21 @@ post_install() {
}
post_remove() {
- . /home/mythtv/.mythtv/mysql.txt
+ . /$MYTHHOME/.mythtv/mysql.txt
# kill myth_py_wii.py
WIIPID=`pidof -o %PPID /usr/bin/myth_py_wii.py`
[ -n "$WIIPID" ] && kill $WIIPID
# Remove uinput
sed -i '/uinput/d' /etc/modules.mythvantage
# Remove line in .fluxbox/apps
- sed -i '/myth_py_wii.py/d' /home/mythtv/.fluxbox/apps
+ sed -i '/myth_py_wii.py/d' /$MYTHHOME/.fluxbox/apps
# Remove network remote control support
mysql -u mythtv -pmythtv --host=${DBHostName} mythconverg -e \
"UPDATE settings SET data = '0' WHERE value = 'NetworkControlEnabled' AND hostname = '${HOST}'";
}
+
+if [ x$MYTHHOME = x ]
+then
+ . /etc/profile.d/MythVantage.sh
+fi
+