summaryrefslogtreecommitdiffstats
path: root/abs/extra/community
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2011-08-06 02:48:18 (GMT)
committerBritney Fransen <brfransen@gmail.com>2011-08-06 02:48:18 (GMT)
commitad2f28b7bca8b2664f47284739e95af7a47882fc (patch)
treef28aa38e32df48acee5545c5d4b00e1da3cdf430 /abs/extra/community
parent1cd2a5f6b60f85be880bb56d4a61351dc62bb06f (diff)
downloadlinhes_pkgbuild-ad2f28b7bca8b2664f47284739e95af7a47882fc.zip
linhes_pkgbuild-ad2f28b7bca8b2664f47284739e95af7a47882fc.tar.gz
linhes_pkgbuild-ad2f28b7bca8b2664f47284739e95af7a47882fc.tar.bz2
zvbi: Bump to latest.
Diffstat (limited to 'abs/extra/community')
-rw-r--r--abs/extra/community/zvbi/PKGBUILD30
-rw-r--r--abs/extra/community/zvbi/fix-includes.patch36
2 files changed, 53 insertions, 13 deletions
diff --git a/abs/extra/community/zvbi/PKGBUILD b/abs/extra/community/zvbi/PKGBUILD
index f638f29..9bc150c 100644
--- a/abs/extra/community/zvbi/PKGBUILD
+++ b/abs/extra/community/zvbi/PKGBUILD
@@ -1,21 +1,25 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: Alexander Baldeck <alexander@archlinux.org>
+# $Id$
+# Maintainer:
+# Contributor: Alexander Baldeck <alexander@archlinux.org>
# Contributor: dorphell <dorphell@archlinux.org>
pkgname=zvbi
-pkgver=0.2.26
-pkgrel=1
-pkgdesc="zvbi is needed for zapping"
+pkgver=0.2.33
+pkgrel=3
+pkgdesc="VBI capture and decoding library"
+url="http://zapping.sourceforge.net/cgi-bin/view/ZVBI/WebHome"
arch=(i686 x86_64)
-depends=('libpng')
+depends=('libpng' 'libx11')
license=('GPL')
options=('!libtool')
-source=(http://downloads.sourceforge.net/sourceforge/zapping/$pkgname-$pkgver.tar.bz2)
-url="http://zapping.sourceforge.net/cgi-bin/view/ZVBI/WebHome"
+source=(http://downloads.sourceforge.net/sourceforge/zapping/${pkgname}-${pkgver}.tar.bz2
+ fix-includes.patch)
+md5sums=('1741a6045c3eedfb611d645f2da69ac8'
+ '38766bc59e1571133d0399f0102da653')
build() {
- cd $startdir/src/$pkgname-$pkgver
- ./configure --prefix=/usr
- make || return 1
- make prefix=$startdir/pkg/usr install
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np1 -i "${srcdir}/fix-includes.patch"
+ ./configure --prefix=/usr --disable-static --mandir=/usr/share/man
+ make
+ make DESTDIR="${pkgdir}" install
}
-md5sums=('82805319ca61f6ffd7b7bb64d7433448')
diff --git a/abs/extra/community/zvbi/fix-includes.patch b/abs/extra/community/zvbi/fix-includes.patch
new file mode 100644
index 0000000..2825264
--- /dev/null
+++ b/abs/extra/community/zvbi/fix-includes.patch
@@ -0,0 +1,36 @@
+Add proper #includes so that we do not get undef errors to S_ISCHR
+during linking.
+
+Signed-off-by: Alex Chiang <achiang@canonical.com>
+---
+--- zvbi-0.2.33.orig/src/io-dvb.c
++++ zvbi-0.2.33/src/io-dvb.c
+@@ -29,6 +29,8 @@
+ #include <errno.h>
+ #include <sys/select.h>
+ #include <sys/ioctl.h>
++#include <sys/types.h>
++#include <sys/stat.h>
+
+ #ifndef HAVE_S64_U64
+ /* Linux 2.6.x asm/types.h defines __s64 and __u64 only
+--- zvbi-0.2.33.orig/src/io-v4l.c
++++ zvbi-0.2.33/src/io-v4l.c
+@@ -42,6 +42,7 @@ static const char rcsid [] =
+ #include <assert.h>
+ #include <sys/time.h> /* timeval */
+ #include <sys/types.h> /* fd_set, uid_t */
++#include <sys/stat.h> /* S_ISCHR */
+ #include <sys/ioctl.h> /* for (_)videodev.h */
+ #include <pthread.h>
+
+--- zvbi-0.2.33.orig/contrib/ntsc-cc.c
++++ zvbi-0.2.33/contrib/ntsc-cc.c
+@@ -34,6 +34,7 @@
+ #include <locale.h>
+ #include <sys/ioctl.h>
+ #include <sys/types.h>
++#include <sys/stat.h>
+ #include <sys/time.h>
+ #ifdef HAVE_GETOPT_LONG
+ # include <getopt.h>