summaryrefslogtreecommitdiffstats
path: root/abs/extra/community
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2011-08-09 21:01:45 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2011-08-09 21:01:45 (GMT)
commitcffec9e13095fa6f4eaca2bfbbe7bb4df73db5f3 (patch)
tree560a407c249084dafbbe59f4a7764c574d8f9e29 /abs/extra/community
parentd448b681fe3feef23e4df4959396300557504952 (diff)
downloadlinhes_pkgbuild-cffec9e13095fa6f4eaca2bfbbe7bb4df73db5f3.zip
linhes_pkgbuild-cffec9e13095fa6f4eaca2bfbbe7bb4df73db5f3.tar.gz
linhes_pkgbuild-cffec9e13095fa6f4eaca2bfbbe7bb4df73db5f3.tar.bz2
chromium: Update to 13.0.782.112 and some minor PKGBUILD changes
Diffstat (limited to 'abs/extra/community')
-rw-r--r--abs/extra/community/chromium/PKGBUILD22
-rw-r--r--abs/extra/community/chromium/__changelog2
-rw-r--r--[-rwxr-xr-x]abs/extra/community/chromium/chromium.sh0
-rw-r--r--abs/extra/community/chromium/gcc-4.6.patch49
-rw-r--r--abs/extra/community/chromium/make-hash-tools-use-if-instead-of-switch.patch37
5 files changed, 54 insertions, 56 deletions
diff --git a/abs/extra/community/chromium/PKGBUILD b/abs/extra/community/chromium/PKGBUILD
index 013f1cc..e5518e9 100644
--- a/abs/extra/community/chromium/PKGBUILD
+++ b/abs/extra/community/chromium/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=chromium
-pkgver=12.0.742.112
+pkgver=13.0.782.112
pkgrel=1
pkgdesc="The open-source project behind Google Chrome, an attempt at creating a safer, faster, and more stable browser"
arch=('i686' 'x86_64')
@@ -15,19 +15,17 @@ depends=('gtk2' 'dbus-glib' 'nss' 'alsa-lib' 'xdg-utils' 'bzip2' 'libevent'
'libxss' 'libxtst' 'ttf-dejavu' 'desktop-file-utils'
'hicolor-icon-theme')
makedepends=('python2' 'perl' 'gperf' 'yasm' 'mesa' 'libgnome-keyring')
+optdepends=('mozplugger-chromium: A Mozilla multimedia plugin for Chromium')
provides=('chromium-browser')
conflicts=('chromium-browser')
+replaces=('firefox' 'firefox-i18n' 'mozplugger')
install=chromium.install
source=(http://build.chromium.org/official/chromium-$pkgver.tar.bz2
chromium.desktop
chromium.sh
gcc-4.6.patch
- glibc-2.14.patch)
-md5sums=('8a5b7b4b30f5fe8de10fcf7d984321b8'
- '075c3c2fa5902e16b8547dd31d437191'
- '096a46ef386817988250d2d7bddd1b34'
- '0ea28c80c49a0a4440786e05b5251678'
- '543a32b09f138fd47858b9a4a7c82dfb')
+ glibc-2.14.patch
+ make-hash-tools-use-if-instead-of-switch.patch)
build() {
cd "$srcdir/chromium-$pkgver"
@@ -42,6 +40,10 @@ build() {
# http://code.google.com/p/chromium/issues/detail?id=86646
patch -Np2 -i "$srcdir/glibc-2.14.patch"
+# Fix build with Perl 5.14
+ patch -d third_party/WebKit -Np2 -i \
+ "$srcdir/make-hash-tools-use-if-instead-of-switch.patch"
+
### Configure
# Use Python 2
@@ -126,3 +128,9 @@ package() {
}
# vim:set ts=2 sw=2 et:
+md5sums=('a0ddccb65b0075419d089087a9de785c'
+ '075c3c2fa5902e16b8547dd31d437191'
+ '096a46ef386817988250d2d7bddd1b34'
+ '690f2be42bf2a31755753a466653eb33'
+ '543a32b09f138fd47858b9a4a7c82dfb'
+ '9d9e66c8365d7333e55305796b49fd77')
diff --git a/abs/extra/community/chromium/__changelog b/abs/extra/community/chromium/__changelog
new file mode 100644
index 0000000..0b5b4c8
--- /dev/null
+++ b/abs/extra/community/chromium/__changelog
@@ -0,0 +1,2 @@
+* Add replaces=('firefox' 'firefox-i18n' 'mozplugger') array
+* Add optdepends=('mozplugger-chromium: A Mozilla multimedia plugin for Chromium')
diff --git a/abs/extra/community/chromium/chromium.sh b/abs/extra/community/chromium/chromium.sh
index e1c3388..e1c3388 100755..100644
--- a/abs/extra/community/chromium/chromium.sh
+++ b/abs/extra/community/chromium/chromium.sh
diff --git a/abs/extra/community/chromium/gcc-4.6.patch b/abs/extra/community/chromium/gcc-4.6.patch
index 931cd64..220fe7a 100644
--- a/abs/extra/community/chromium/gcc-4.6.patch
+++ b/abs/extra/community/chromium/gcc-4.6.patch
@@ -31,17 +31,6 @@ diff -u -r ppapi/cpp/paint_aggregator.h ppapi/cpp/paint_aggregator.h
namespace pp {
-diff -u -r third_party/libjingle/source/talk/base/sigslot.h third_party/libjingle/source/talk/base/sigslot.h
---- third_party/libjingle/source/talk/base/sigslot.h 2011-04-13 13:25:41.000000000 +0400
-+++ third_party/libjingle/source/talk/base/sigslot.h 2011-04-20 20:00:43.000000000 +0400
-@@ -80,6 +80,7 @@
-
- #include <set>
- #include <list>
-+#include <cstddef>
-
- // On our copy of sigslot.h, we force single threading
- #define SIGSLOT_PURE_ISO
diff -u -r third_party/ots/src/os2.cc third_party/ots/src/os2.cc
--- third_party/ots/src/os2.cc 2011-04-13 13:24:06.000000000 +0400
+++ third_party/ots/src/os2.cc 2011-04-20 19:45:44.000000000 +0400
@@ -119,41 +108,3 @@ diff -u -r ui/gfx/codec/jpeg_codec.h ui/gfx/codec/jpeg_codec.h
class SkBitmap;
---- ppapi/cpp/paint_aggregator.h 2010-12-23 18:10:27.000000000 -0600
-+++ ppapi/cpp/paint_aggregator.h~ 2011-04-19 05:34:56.085582885 -0500
-@@ -5,6 +5,7 @@
- #ifndef PPAPI_CPP_PAINT_AGGREGATOR_H_
- #define PPAPI_CPP_PAINT_AGGREGATOR_H_
-
-+#include <cstddef>
- #include <vector>
-
- #include "ppapi/cpp/point.h"
-Index: Source/WebCore/ChangeLog
-===================================================================
---- third_party/WebKit/Source/WebCore/ChangeLog (revision 84120)
-+++ third_party/WebKit/Source/WebCore/ChangeLog (revision 84123)
-@@ -1,2 +1,24 @@
-+2011-04-17 Thierry Reding <thierry.reding@avionic-design.de>
-+
-+ Reviewed by Adam Barth.
-+
-+ Fix build with GCC 4.6.
-+
-+ * dom/make_names.pl: Execute preprocessor without the -P option. The
-+ preprocessor in GCC 4.6 eats empty lines, effectively breaking the
-+ parsing performed by this script. Dropping the -P option when invoking
-+ the preprocessor keeps the empty lines but as a side-effect also adds
-+ additional linemarkers.
-+
-+ From the cpp manpage:
-+
-+ -P Inhibit generation of linemarkers in the output from the
-+ preprocessor. This might be useful when running the preprocessor
-+ on something that is not C code, and will be sent to a program
-+ which might be confused by the linemarkers.
-+
-+ The linemarkers are not problematic, however, because the script
-+ properly handles them by ignoring all lines starting with a #.
-+
- 2011-04-17 David Kilzer <ddkilzer@apple.com>
diff --git a/abs/extra/community/chromium/make-hash-tools-use-if-instead-of-switch.patch b/abs/extra/community/chromium/make-hash-tools-use-if-instead-of-switch.patch
new file mode 100644
index 0000000..1b917ba
--- /dev/null
+++ b/abs/extra/community/chromium/make-hash-tools-use-if-instead-of-switch.patch
@@ -0,0 +1,37 @@
+Index: /trunk/Source/WebCore/make-hash-tools.pl
+===================================================================
+--- /trunk/Source/WebCore/make-hash-tools.pl (revision 72664)
++++ /trunk/Source/WebCore/make-hash-tools.pl (revision 89265)
+@@ -21,5 +21,4 @@
+
+ use strict;
+-use Switch;
+ use File::Basename;
+
+@@ -29,7 +28,5 @@
+
+
+-switch ($option) {
+-
+-case "DocTypeStrings" {
++if ($option eq "DocTypeStrings") {
+
+ my $docTypeStringsGenerated = "$outdir/DocTypeStrings.cpp";
+@@ -39,7 +36,5 @@
+ system("gperf --key-positions=\"*\" -s 2 $docTypeStringsGperf > $docTypeStringsGenerated") == 0 || die "calling gperf failed: $?";
+
+-} # case "DocTypeStrings"
+-
+-case "ColorData" {
++} elsif ($option eq "ColorData") {
+
+ my $colorDataGenerated = "$outdir/ColorData.cpp";
+@@ -49,5 +44,5 @@
+ system("gperf --key-positions=\"*\" -D -s 2 $colorDataGperf > $colorDataGenerated") == 0 || die "calling gperf failed: $?";
+
+-} # case "ColorData"
+-
+-} # switch ($option)
++} else {
++ die "Unknown option.";
++}