summaryrefslogtreecommitdiffstats
path: root/abs/extra/community
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2012-04-27 04:14:26 (GMT)
committerCecil <knoppmyth@gmail.com>2012-04-27 04:14:26 (GMT)
commitddd3cca11c55e087b67c54bb53ea8d4d0180c7ea (patch)
tree38ac203498a71284a3b7911646c5cf8e54972a3a /abs/extra/community
parent7191fd41fade855ead562d652367e3841e1df04b (diff)
downloadlinhes_pkgbuild-ddd3cca11c55e087b67c54bb53ea8d4d0180c7ea.zip
linhes_pkgbuild-ddd3cca11c55e087b67c54bb53ea8d4d0180c7ea.tar.gz
linhes_pkgbuild-ddd3cca11c55e087b67c54bb53ea8d4d0180c7ea.tar.bz2
opencl-headers:initial inclusion, dep of dolphin-emu.
Diffstat (limited to 'abs/extra/community')
-rw-r--r--abs/extra/community/opencl-headers/LICENSE.txt20
-rw-r--r--abs/extra/community/opencl-headers/PKGBUILD53
2 files changed, 73 insertions, 0 deletions
diff --git a/abs/extra/community/opencl-headers/LICENSE.txt b/abs/extra/community/opencl-headers/LICENSE.txt
new file mode 100644
index 0000000..a89e4f5
--- /dev/null
+++ b/abs/extra/community/opencl-headers/LICENSE.txt
@@ -0,0 +1,20 @@
+ * Copyright (c) 2008-2010 The Khronos Group Inc.
+ *
+ * Permission is hereby granted, free of charge, to any person obtaining a
+ * copy of this software and/or associated documentation files (the
+ * "Materials"), to deal in the Materials without restriction, including
+ * without limitation the rights to use, copy, modify, merge, publish,
+ * distribute, sublicense, and/or sell copies of the Materials, and to
+ * permit persons to whom the Materials are furnished to do so, subject to
+ * the following conditions:
+ *
+ * The above copyright notice and this permission notice shall be included
+ * in all copies or substantial portions of the Materials.
+ *
+ * THE MATERIALS ARE PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+ * EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+ * MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+ * IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+ * CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
+ * TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+ * MATERIALS OR THE USE OR OTHER DEALINGS IN THE MATERIALS.
diff --git a/abs/extra/community/opencl-headers/PKGBUILD b/abs/extra/community/opencl-headers/PKGBUILD
new file mode 100644
index 0000000..0a21ce2
--- /dev/null
+++ b/abs/extra/community/opencl-headers/PKGBUILD
@@ -0,0 +1,53 @@
+# $Id: PKGBUILD 60629 2011-12-15 19:18:50Z stephane $
+# Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
+# Contributor: Sylvain HENRY <hsyl20@yahoo.fr>
+
+pkgname=opencl-headers
+pkgver=1.1.20110526
+_clbasever=1.1
+pkgrel=1
+epoch=1
+pkgdesc='OpenCL (Open Computing Language) header files'
+arch=('any')
+url='http://www.khronos.org/registry/cl/'
+license=('custom')
+optdepends=('libcl: OpenCL library')
+source=("ftp://ftp.archlinux.org/other/community/${pkgname}/${pkgname}-${pkgver}.src.tar.xz"
+ 'LICENSE.txt')
+_headers=("http://www.khronos.org/registry/cl/api/${_clbasever}/cl_ext.h"
+ "http://www.khronos.org/registry/cl/api/${_clbasever}/cl_gl_ext.h"
+ "http://www.khronos.org/registry/cl/api/${_clbasever}/cl_gl.h"
+ "http://www.khronos.org/registry/cl/api/${_clbasever}/cl.h"
+ "http://www.khronos.org/registry/cl/api/${_clbasever}/cl.hpp"
+ "http://www.khronos.org/registry/cl/api/${_clbasever}/cl_platform.h"
+ "http://www.khronos.org/registry/cl/api/${_clbasever}/opencl.h")
+sha1sums=('b9deedbae4f87fa0987ca7b2347f68d608284a02'
+ '98abb35b2eca82d0fc19db6d28fcc7bd20be0655')
+
+# source PKGBUILD && mksource
+mksource() {
+ cd "${srcdir}"
+ _dirname=${pkgname}-${pkgver}
+ mkdir ${_dirname}
+
+ pushd ${_dirname}
+ for _h in ${_headers[@]}; do
+ wget ${_h}
+ done
+ popd
+
+ tar -cJv --exclude=CVS -f ${_dirname}.src.tar.xz ${_dirname}
+ rm -rf ${_dirname}
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ install -dm755 "${pkgdir}"/usr/include/CL
+
+ for h in $(ls -1 *.h *.hpp); do
+ install -m 644 ${h} "${pkgdir}"/usr/include/CL/
+ done
+
+ install -D -m644 ../LICENSE.txt "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}