summaryrefslogtreecommitdiffstats
path: root/abs/extra/crda/0001-crda-Fix-the-linking-order-to-avoid-compilation-erro.patch
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-04-16 17:16:01 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-04-16 17:16:01 (GMT)
commit8e41fcf367697e694aa00b9c6e5e0613803548b0 (patch)
tree259f2842bc8d453c208a7131c08455c4b40f8128 /abs/extra/crda/0001-crda-Fix-the-linking-order-to-avoid-compilation-erro.patch
parent0fd0dca48ba1af407f134304909c7ccb25f42b61 (diff)
downloadlinhes_pkgbuild-8e41fcf367697e694aa00b9c6e5e0613803548b0.zip
linhes_pkgbuild-8e41fcf367697e694aa00b9c6e5e0613803548b0.tar.gz
linhes_pkgbuild-8e41fcf367697e694aa00b9c6e5e0613803548b0.tar.bz2
crda: update to 3.13. refs #961
Diffstat (limited to 'abs/extra/crda/0001-crda-Fix-the-linking-order-to-avoid-compilation-erro.patch')
-rw-r--r--abs/extra/crda/0001-crda-Fix-the-linking-order-to-avoid-compilation-erro.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/abs/extra/crda/0001-crda-Fix-the-linking-order-to-avoid-compilation-erro.patch b/abs/extra/crda/0001-crda-Fix-the-linking-order-to-avoid-compilation-erro.patch
new file mode 100644
index 0000000..6807e99
--- /dev/null
+++ b/abs/extra/crda/0001-crda-Fix-the-linking-order-to-avoid-compilation-erro.patch
@@ -0,0 +1,52 @@
+From fefefdb2c52c8fbedbb339b4badb8226cad7e7e0 Mon Sep 17 00:00:00 2001
+From: Krishna Chaitanya <chaitanya.mgit@gmail.com>
+Date: Mon, 16 Dec 2013 21:57:39 +0530
+Subject: [PATCH] crda: Fix the linking order to avoid compilation error
+
+While linking the crda.o and libreg.so, first put crda.o
+and then -lreg. This fixed the below error:
+
+ GEN keys-gcrypt.c
+ Trusted pubkeys: pubkeys/linville.key.pub.pem
+ CC libreg.so
+ CC crda.o
+ LD crda
+crda.o: In function `main':
+crda/crda.c:196: undefined reference to `reglib_get_rd_alpha2'
+collect2: ld returned 1 exit status
+make: *** [crda] Error 1
+
+Note: This still doesn't fix the below error (will send another mail)
+
+ CHK /usr/lib/crda/regulatory.bin
+Database signature verification failed.
+Invalid or empty regulatory file, note: a binary regulatory file should be used.
+make: *** [verify] Error 234
+
+Signed-off-by: Luis R. Rodriguez <mcgrof@do-not-panic.com>
+Signed-off-by: Chaitanya T K <chaitanya.mgit@gmail.com>
+---
+ Makefile | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 4a351c6..0b2f0d7 100644
+--- a/Makefile
++++ b/Makefile
+@@ -28,10 +28,11 @@ RUNTIME_PUBKEY_DIR?=/etc/wireless-regdb/pubkeys
+ CFLAGS += -O2 -fpic
+ CFLAGS += -std=gnu99 -Wall -Werror -pedantic
+ CFLAGS += -Wall -g
+-LDLIBS += -lm
+ LDLIBREG += -lreg
++LDLIBS += $(LDLIBREG)
++LDLIBS += -lm
+ LIBREG += libreg.so
+-LDFLAGS += -L ./ $(LDLIBREG)
++LDFLAGS += -L ./
+
+ all: all_noverify verify
+
+--
+1.9.0
+