summaryrefslogtreecommitdiffstats
path: root/abs/extra/crda/0002-crda-Add-DESTDIR-support-in-install-libreg-rules-in-.patch
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-04-16 17:16:01 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-04-16 17:16:01 (GMT)
commit8e41fcf367697e694aa00b9c6e5e0613803548b0 (patch)
tree259f2842bc8d453c208a7131c08455c4b40f8128 /abs/extra/crda/0002-crda-Add-DESTDIR-support-in-install-libreg-rules-in-.patch
parent0fd0dca48ba1af407f134304909c7ccb25f42b61 (diff)
downloadlinhes_pkgbuild-8e41fcf367697e694aa00b9c6e5e0613803548b0.zip
linhes_pkgbuild-8e41fcf367697e694aa00b9c6e5e0613803548b0.tar.gz
linhes_pkgbuild-8e41fcf367697e694aa00b9c6e5e0613803548b0.tar.bz2
crda: update to 3.13. refs #961
Diffstat (limited to 'abs/extra/crda/0002-crda-Add-DESTDIR-support-in-install-libreg-rules-in-.patch')
-rw-r--r--abs/extra/crda/0002-crda-Add-DESTDIR-support-in-install-libreg-rules-in-.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/abs/extra/crda/0002-crda-Add-DESTDIR-support-in-install-libreg-rules-in-.patch b/abs/extra/crda/0002-crda-Add-DESTDIR-support-in-install-libreg-rules-in-.patch
new file mode 100644
index 0000000..c69f8f7
--- /dev/null
+++ b/abs/extra/crda/0002-crda-Add-DESTDIR-support-in-install-libreg-rules-in-.patch
@@ -0,0 +1,37 @@
+From 2cabb2588da56735369131b709f191453c080be0 Mon Sep 17 00:00:00 2001
+From: "John W. Linville" <linville@tuxdriver.com>
+Date: Fri, 14 Feb 2014 13:58:44 -0500
+Subject: [PATCH 2/2] crda: Add DESTDIR support in install-libreg* rules in
+ Makefile
+
+Signed-off-by: John W. Linville <linville@tuxdriver.com>
+Signed-off-by: Luis R. Rodriguez <mcgrof@do-not-panic.com>
+---
+ Makefile | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 0b2f0d7..1f25509 100644
+--- a/Makefile
++++ b/Makefile
+@@ -120,13 +120,13 @@ $(LIBREG): regdb.h reglib.h reglib.c
+
+ install-libreg-headers:
+ $(NQ) ' INSTALL libreg-headers'
+- $(Q)mkdir -p $(INCLUDE_DIR)
+- $(Q)cp *.h $(INCLUDE_DIR)/
++ $(Q)mkdir -p $(DESTDIR)/$(INCLUDE_DIR)
++ $(Q)cp *.h $(DESTDIR)/$(INCLUDE_DIR)/
+
+ install-libreg:
+ $(NQ) ' INSTALL libreg'
+- $(Q)mkdir -p $(LIBDIR)
+- $(Q)cp $(LIBREG) $(LIBDIR)/
++ $(Q)mkdir -p $(DESTDIR)/$(LIBDIR)
++ $(Q)cp $(LIBREG) $(DESTDIR)/$(LIBDIR)/
+ $(Q)ldconfig
+
+ %.o: %.c regdb.h $(LIBREG)
+--
+1.9.0
+