summaryrefslogtreecommitdiffstats
path: root/abs/extra/crda
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2013-02-19 21:10:18 (GMT)
committerJames Meyer <james.meyer@operamail.com>2013-02-19 21:10:18 (GMT)
commit2648e999d277eac5c3d331a3609bcc73fafbea71 (patch)
tree40951fb8e7fdbe28a0baa324ae615055203f1e2e /abs/extra/crda
parentc759b5e0c4aa6fc37412b4dee2cf9ad993fd376d (diff)
parent7e6f7ca174e1af67178dc5293a312a4a733eb095 (diff)
downloadlinhes_pkgbuild-2648e999d277eac5c3d331a3609bcc73fafbea71.zip
linhes_pkgbuild-2648e999d277eac5c3d331a3609bcc73fafbea71.tar.gz
linhes_pkgbuild-2648e999d277eac5c3d331a3609bcc73fafbea71.tar.bz2
Merge branch 'testing'
# By James Meyer (1091) and others # Via James Meyer (5) and others * testing: (1148 commits) LinHES-config: during install don't kill off lirc. This keeps the remote active all the way to the finish Change version numbers to 8.0 to match the release number. LinHES-conifg LinHES-system mythdb-initial runit-scripts supplemental-web LinHES-conifig: mv_install.py for the last partition don't go all the way to the end. Gotta leave room for gpt tables. xf86-video-ati: xorg ati driver. LinHES-config: timezip.py add syncing up of parental lvl passwords and starting level with MBE. LinHES-system: correct the logic for breaking out of the wmctrl loop. As written it would break out of the inner loop..but not the 60 iteration loop. e16_theme_settings: remove slide-in prop for new windows. For whatever reason this was preventing mplayer from being positioned correctly for appletrailers. LinHES-config, mythinstall: change case of hd_pvr and serial to all lower refs #902 zilog-firmware: firmware for TX support of the hdpvr and pvr-150 In general I can't recommend anybody using these transmitters but including the firmware just in case someone really wants to linhes-udev-rules: added hdprv_lirc rule. All of these lirc rules are limited to exactly one device. If more then one device is present then only the last device in init will get the symlink runit-scripts: fix logging for igdeamon, add support to remote init script so that the blaster is always the first device in the chain. added support specificly for hd_pvr LinHES-system: add lh_system_restore and lh_system_backup. These scripts are called from the mythmenu. refs #900 iguanair: rebuild with python 2.7 LinHES-system: msg_daemon.py fix init and nasty bug related to timeout. In a nutshell timeout wouldn't work unless a msg without a timeout was called first. linhes-udev-rules: add rules for mce,streamzap,serial lirc devices. mythinstall: recompile for matching libs mythtv: latest .25-fixes and change mythbackup/restore call lh_system_$op to replace mythbackup/mythrestore. mythbackup no longer works correctly with the new windowmanager linhes-scripts: myth2mp3, myth2x264, myth2xvid: use mythutil to get cutlist LinHES-config, supplimental-web: Fix proxy numbering for Ceton infiniTV linhes-system: add additional stuff to the system backup and also introduced an exclude file. The exclude/include files are locate in /home/mythtv/backup_config/ ...
Diffstat (limited to 'abs/extra/crda')
-rw-r--r--abs/extra/crda/PKGBUILD36
-rw-r--r--abs/extra/crda/crda.conf.d4
-rw-r--r--abs/extra/crda/libnl32.patch12
3 files changed, 32 insertions, 20 deletions
diff --git a/abs/extra/crda/PKGBUILD b/abs/extra/crda/PKGBUILD
index 4fbb201..88ad6cc 100644
--- a/abs/extra/crda/PKGBUILD
+++ b/abs/extra/crda/PKGBUILD
@@ -1,10 +1,10 @@
-# $Id: PKGBUILD 79865 2010-05-08 15:22:52Z thomas $
+# $Id: PKGBUILD 158615 2012-05-05 03:17:06Z allan $
# Maintainer: Thomas Bächler <thomas@archlinux.org>
pkgname=crda
-pkgver=1.1.1
-pkgrel=1
-pkgdesc="Central Regulatory Domain Agent"
+pkgver=1.1.2
+pkgrel=3
+pkgdesc="Central Regulatory Domain Agent for wireless networks"
arch=(i686 x86_64)
url="http://wireless.kernel.org/en/developers/Regulatory/CRDA"
license=('custom')
@@ -12,22 +12,26 @@ depends=('wireless-regdb' 'libnl' 'libgcrypt' 'udev' 'iw')
makedepends=('python-m2crypto')
install=crda.install
source=(http://wireless.kernel.org/download/crda/${pkgname}-${pkgver}.tar.bz2
- crda.rc)
-md5sums=('5fc77af68b3e21736b8ef2f8b061c810'
- '014eef3f8655e9a130064ec6891317fc')
+ crda.rc libnl32.patch)
+md5sums=('5226f65aebacf94baaf820f8b4e06df4'
+ '014eef3f8655e9a130064ec6891317fc'
+ 'c1f7aff29f15a0364ae6f7905a1d4ae6')
build() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ patch -Np1 -i "$srcdir/libnl32.patch"
+ sed 's|^#!/usr/bin/env python|#!/usr/bin/python2|' -i utils/key2pub.py
+ make crda regdbdump
+}
+
+package() {
# Install crda, regdbdump and udev rules
- msg "Compiling and installing crda ..."
- cd ${srcdir}/${pkgname}-${pkgver}
- make crda regdbdump || return 1
- make DESTDIR=${pkgdir} install || return 1
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" UDEV_RULE_DIR=/usr/lib/udev/rules.d/ install
# This rule automatically sets the regulatory domain when cfg80211 is loaded
- echo 'ACTION=="add" SUBSYSTEM=="module", DEVPATH=="/module/cfg80211", RUN+="/etc/rc.d/wireless-regdom start >/dev/null"' >> ${pkgdir}/lib/udev/rules.d/85-regulatory.rules || return 1
+ echo 'ACTION=="add" SUBSYSTEM=="module", DEVPATH=="/module/cfg80211", RUN+="/etc/rc.d/wireless-regdom start >/dev/null"' >> "${pkgdir}"/usr/lib/udev/rules.d/85-regulatory.rules
- msg "Installing license ..."
- install -D -m644 ${srcdir}/${pkgname}-${pkgver}/LICENSE ${pkgdir}/usr/share/licenses/crda/LICENSE || return 1
+ install -D -m644 "${srcdir}"/${pkgname}-${pkgver}/LICENSE "${pkgdir}"/usr/share/licenses/crda/LICENSE
- msg "Installing boot script ..."
- install -D -m755 ${srcdir}/crda.rc ${pkgdir}/etc/rc.d/wireless-regdom || return 1
+ install -D -m755 "${srcdir}"/crda.rc "${pkgdir}"/etc/rc.d/wireless-regdom
}
diff --git a/abs/extra/crda/crda.conf.d b/abs/extra/crda/crda.conf.d
deleted file mode 100644
index 8511238..0000000
--- a/abs/extra/crda/crda.conf.d
+++ /dev/null
@@ -1,4 +0,0 @@
-#
-# Wireless regulatory domain configuration
-#
-
diff --git a/abs/extra/crda/libnl32.patch b/abs/extra/crda/libnl32.patch
new file mode 100644
index 0000000..682b6c5
--- /dev/null
+++ b/abs/extra/crda/libnl32.patch
@@ -0,0 +1,12 @@
+diff -u -r crda-1.1.2/Makefile crda-1.1.2-libnl32/Makefile
+--- crda-1.1.2/Makefile 2011-08-10 01:36:19.000000000 +0200
++++ crda-1.1.2-libnl32/Makefile 2012-02-09 18:53:33.376430180 +0100
+@@ -51,7 +51,7 @@
+
+ ifeq ($(NL3FOUND),Y)
+ CFLAGS += -DCONFIG_LIBNL30
+-NLLIBS += -lnl-genl
++NLLIBS += $(shell pkg-config --libs libnl-genl-3.0)
+ NLLIBNAME = libnl-3.0
+ else
+ ifeq ($(NL2FOUND),Y)