summaryrefslogtreecommitdiffstats
path: root/abs/extra/cups/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2014-08-16 17:49:53 (GMT)
committerJames Meyer <james.meyer@operamail.com>2014-08-16 17:59:16 (GMT)
commitedfc437426e7dd540b35ea7cd436b886e5c46866 (patch)
tree0ad4f92323d408104d7b073f2999c40b41745341 /abs/extra/cups/PKGBUILD
parent9b3d5cb2a36836482a2409d54bf183a1af879fe3 (diff)
downloadlinhes_pkgbuild-edfc437426e7dd540b35ea7cd436b886e5c46866.zip
linhes_pkgbuild-edfc437426e7dd540b35ea7cd436b886e5c46866.tar.gz
linhes_pkgbuild-edfc437426e7dd540b35ea7cd436b886e5c46866.tar.bz2
cups: 1.7.0
refs #961
Diffstat (limited to 'abs/extra/cups/PKGBUILD')
-rw-r--r--abs/extra/cups/PKGBUILD37
1 files changed, 20 insertions, 17 deletions
diff --git a/abs/extra/cups/PKGBUILD b/abs/extra/cups/PKGBUILD
index 63bb641..08a3e19 100644
--- a/abs/extra/cups/PKGBUILD
+++ b/abs/extra/cups/PKGBUILD
@@ -1,16 +1,15 @@
-# $Id$
+# $Id: PKGBUILD 199750 2013-11-15 15:38:18Z andyrtr $
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
pkgbase="cups"
pkgname=('libcups' 'cups')
-pkgver=1.7.1
-pkgrel=4
+pkgver=1.7.0
+pkgrel=2
arch=('i686' 'x86_64')
license=('GPL')
url="http://www.cups.org/"
-makedepends=('libtiff>=4.0.0' 'libpng>=1.5.7' 'acl' 'pam' 'xdg-utils' 'krb5' 'openssl'
- 'cups-filters' 'bc' 'colord' 'xinetd' 'gzip' 'autoconf' 'libusb' 'dbus'
- 'avahi' 'hicolor-icon-theme' 'systemd' 'inetutils' 'libpaper' 'valgrind')
+makedepends=('libtiff>=4.0.0' 'libpng>=1.5.7' 'acl' 'pam' 'xdg-utils' 'krb5' 'gnutls>=2.8.3' 'cups-filters' 'bc'
+ 'colord' 'xinetd' 'gzip' 'autoconf' 'libusb' 'dbus-core' 'avahi' 'hicolor-icon-theme' 'systemd')
source=(#http://mirror.easysw.com/pub/cups/${pkgver}/cups-${pkgver}-source.tar.bz2
http://www.cups.org/software/${pkgver}/cups-${pkgver}-source.tar.bz2
cups.logrotate cups.pam
@@ -20,6 +19,7 @@ source=(#http://mirror.easysw.com/pub/cups/${pkgver}/cups-${pkgver}-source.tar.b
cups-no-gzip-man.patch
# FC
cups-systemd-socket.patch
+ cups-dbus-utf8.patch
cups-res_init.patch
cups-avahi-address.patch
cups-enum-all.patch
@@ -31,13 +31,14 @@ source=(#http://mirror.easysw.com/pub/cups/${pkgver}/cups-${pkgver}-source.tar.b
cupsd-no-crash-on-avahi-threaded-poll-shutdown.patch
get-ppd-file-for-statically-configured-ipp-shared-queues.patch
ppd-poll-with-client-conf.patch)
-md5sums=('55277c40fd4b7183dc3671d39c5c42b7'
+md5sums=('5ab496a2ce27017fcdb3d7ec4818a75a'
'f861b18f4446c43918c8643dcbbd7f6d'
'96f82c38f3f540b53f3e5144900acf17'
'3ba9e3410df1dc3015463d615ef91b3b'
'cc4101beccb5ed6deb1c92707a575925'
'90c30380d4c8cd48a908cfdadae1ea24'
- 'cf2f881967b0531ec49bcb5d0e9573a8'
+ '555a1c71151ce990e176315b46e3de2f'
+ 'a2a88b3a3257c3b5fd3edcc169e6aca4'
'8fe27d4248cacbc02824e7937cab4088'
'df0c367c0022e3c7d8e01827e8a6c5e7'
'f30c2a161caaf27854581507cde8cac6'
@@ -68,6 +69,9 @@ prepare() {
# various bugfixes (upstream reports/SVN or Fedora/Debian
+ # Ensure attributes are valid UTF-8 in dbus notifier
+ patch -Np1 -i ${srcdir}/cups-dbus-utf8.patch
+
# Fixed crash which sometimes happens on shutdown of the CUPS daemon, caused by a wrong shutdown sequence for shutting down the Avahi threaded poll.
# patch -Np1 -i ${srcdir}/cupsd-no-crash-on-avahi-threaded-poll-shutdown.patch
# Applications could not get the PPD file for statically-configured IPP-shared print queues
@@ -108,10 +112,9 @@ build() {
--enable-pam=yes \
--enable-raw-printing \
--enable-dbus --with-dbusdir=/etc/dbus-1 \
- --enable-ssl=yes --enable-openssl \
+ --enable-ssl=yes --enable-gnutls \
--enable-threads \
--enable-avahi\
- --enable-libpaper \
--with-php=/usr/bin/php-cgi \
--with-optim="$CFLAGS"
make
@@ -119,14 +122,15 @@ build() {
check() {
cd ${pkgbase}-${pkgver}
-#./run-stp-tests.sh: line 782: 6307 Aborted (core dumped) $VALGRIND ../scheduler/cupsd -c /tmp/cups-$user/cupsd.conf -f > /tmp/cups-$user/log/debug_log 2>&1
-#FAIL: 87 error messages, expected 33.
+ #httpAddrGetList(workstation64): FAIL
+ #1 TESTS FAILED!
+ #make[1]: *** [testhttp] Error 1
make -k check || /bin/true
}
package_libcups() {
pkgdesc="The CUPS Printing System - client libraries and headers"
-depends=('openssl' 'libtiff>=4.0.0' 'libpng>=1.5.7' 'krb5' 'avahi')
+depends=('gnutls>=2.8.3' 'libtiff>=4.0.0' 'libpng>=1.5.7' 'krb5' 'avahi')
backup=(etc/cups/client.conf)
cd ${pkgbase}-${pkgver}
@@ -158,8 +162,7 @@ backup=(etc/cups/cupsd.conf
etc/logrotate.d/cups
etc/pam.d/cups
etc/xinetd.d/cups-lpd)
-depends=('acl' 'pam' "libcups>=${pkgver}" 'cups-filters' 'bc' 'colord'
- 'libusb' 'dbus' 'systemd' 'libpaper' 'hicolor-icon-theme')
+depends=('acl' 'pam' "libcups>=${pkgver}" 'cups-filters' 'bc' 'colord' 'libusb' 'dbus-core' 'libsystemd' 'hicolor-icon-theme')
optdepends=('xdg-utils: xdg .desktop file support')
cd ${pkgbase}-${pkgver}
@@ -180,8 +183,8 @@ optdepends=('xdg-utils: xdg .desktop file support')
# install ssl directory where to store the certs, solves some samba issues
install -dm700 -g lp ${pkgdir}/etc/cups/ssl
- # remove directory from package, it will be recreated at each server start
- rm -rf ${pkgdir}/run
+ # remove directory from package, we create it in cups rc.d file
+ rm -rf ${pkgdir}/var/run
# install some more configuration files that will get filled by cupsd
touch ${pkgdir}/etc/cups/printers.conf