summaryrefslogtreecommitdiffstats
path: root/abs/extra/dbus-c++
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-11-25 04:49:14 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-11-25 04:49:14 (GMT)
commitf591ead4c8a9b64b0630900aa12c260027a7db6f (patch)
tree091b31cdc3a24c0b9108f0ea718ecaad166cc834 /abs/extra/dbus-c++
parent9b35fb3e4f637252b4674a78adf9026faeaa5340 (diff)
downloadlinhes_pkgbuild-f591ead4c8a9b64b0630900aa12c260027a7db6f.zip
linhes_pkgbuild-f591ead4c8a9b64b0630900aa12c260027a7db6f.tar.gz
linhes_pkgbuild-f591ead4c8a9b64b0630900aa12c260027a7db6f.tar.bz2
compiled/added programs needed by xbmc: Moved some programs out of community into extra.
libmpeg2 pm-utils afpfs-ng fluidsynth libmodplug libnfs libshairport dbus-c__ doxygen libocnfig libffado libimobiledevice libmicrothttpd sdl_image sdl_mixer smpeg upower usbmuxd vdpau-video
Diffstat (limited to 'abs/extra/dbus-c++')
-rw-r--r--abs/extra/dbus-c++/PKGBUILD40
-rw-r--r--abs/extra/dbus-c++/gcc47.patch10
2 files changed, 50 insertions, 0 deletions
diff --git a/abs/extra/dbus-c++/PKGBUILD b/abs/extra/dbus-c++/PKGBUILD
new file mode 100644
index 0000000..d79922e
--- /dev/null
+++ b/abs/extra/dbus-c++/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Ray Rashif <schiv@archlinux.org>
+# Contributor: Xavier D. <magicrhesus@ouranos.be>
+# Contributor: Zarra <zarraxx@gmail.com>
+
+pkgname=dbus-c++
+_pkgname=lib$pkgname
+pkgver=0.9.0
+pkgrel=4
+pkgdesc="A C++ API for D-BUS"
+url="http://sourceforge.net/projects/dbus-cplusplus/"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('dbus>=1.2.0' 'glib2')
+makedepends=('autoconf' 'automake' 'libtool')
+options=('!libtool')
+source=("http://sourceforge.net/projects/dbus-cplusplus/files/dbus-c%2B%2B/$pkgver/libdbus-c%2B%2B-$pkgver.tar.gz"
+ 'gcc47.patch')
+md5sums=('e752116f523fa88ef041e63d3dee4de2'
+ '9319b402b15f37d881b51bc758368900')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ patch -Np0 -i "$srcdir/gcc47.patch"
+ export LDFLAGS+=" -lexpat -lpthread" # -lpthread needed for i686
+
+ ./autogen.sh --prefix=/usr \
+ --disable-static \
+ --enable-glib \
+ --disable-ecore
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/abs/extra/dbus-c++/gcc47.patch b/abs/extra/dbus-c++/gcc47.patch
new file mode 100644
index 0000000..6a82773
--- /dev/null
+++ b/abs/extra/dbus-c++/gcc47.patch
@@ -0,0 +1,10 @@
+--- src/eventloop-integration.cpp.orig 2012-05-09 11:22:09.683290763 +0200
++++ src/eventloop-integration.cpp 2012-05-09 11:22:44.313288912 +0200
+@@ -38,6 +38,7 @@
+ #include <cassert>
+ #include <sys/poll.h>
+ #include <fcntl.h>
++#include <unistd.h>
+
+ using namespace DBus;
+ using namespace std;