summaryrefslogtreecommitdiffstats
path: root/abs/extra/dconf
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-15 15:42:39 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-15 15:42:39 (GMT)
commit0bc4c71a5f10876a7e1276e42198cc294e81e167 (patch)
tree073d35a929b2f1f1307f3272fd2278ac14145e96 /abs/extra/dconf
parent9798db5585024e1194aa827e218f06fbd9461d01 (diff)
downloadlinhes_pkgbuild-0bc4c71a5f10876a7e1276e42198cc294e81e167.zip
linhes_pkgbuild-0bc4c71a5f10876a7e1276e42198cc294e81e167.tar.gz
linhes_pkgbuild-0bc4c71a5f10876a7e1276e42198cc294e81e167.tar.bz2
dconf .12.1
Diffstat (limited to 'abs/extra/dconf')
-rw-r--r--abs/extra/dconf/PKGBUILD27
-rw-r--r--abs/extra/dconf/dconf.install4
2 files changed, 19 insertions, 12 deletions
diff --git a/abs/extra/dconf/PKGBUILD b/abs/extra/dconf/PKGBUILD
index 4d95f6b..8b4743d 100644
--- a/abs/extra/dconf/PKGBUILD
+++ b/abs/extra/dconf/PKGBUILD
@@ -1,26 +1,31 @@
-# $Id:
+# $Id: PKGBUILD 161615 2012-06-12 13:50:01Z heftig $
# Maintainer: Ionut Biru <ibiru@archlinux.org>
+
pkgname=dconf
-pkgver=0.5.1
-pkgrel=1
+pkgver=0.12.1
+pkgrel=2
pkgdesc="A low-level configuration system."
arch=(i686 x86_64)
url="http://live.gnome.org/dconf"
license=('LGPL2.1')
-depends=('glib2>=2.25.17')
-makedepends=('vala' 'gobject-introspection' 'gtk2')
-optdepends=('gtk2: for dconf-editor')
+depends=('glib2' 'gtk-update-icon-cache')
+makedepends=('vala' 'gtk3')
+optdepends=('gtk3: for dconf-editor')
install=dconf.install
-source=(http://download.gnome.org/sources/${pkgname}/0.5/${pkgname}-${pkgver}.tar.bz2)
-sha256sums=('0083d70e1b5e540d8d4b3f04fa5d17dff4c574136682fe3bdd9b5ecc196ec4f6')
+source=(http://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz)
+sha256sums=('3cd32b78d88ed7be90dace5d45e2cf8a6abdb253d43dbfa5ef52103b329dc214')
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$pkgname-$pkgver"
- ./configure --prefix=/usr \
+ ./configure --prefix=/usr --sysconfdir=/etc \
--libexecdir=/usr/lib/dconf
make
- make DESTDIR="$pkgdir/" install
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make completiondir=/usr/share/bash-completion/completions DESTDIR="$pkgdir" install
}
# vim:set ts=2 sw=2 et:
diff --git a/abs/extra/dconf/dconf.install b/abs/extra/dconf/dconf.install
index 5a87df8..75d713d 100644
--- a/abs/extra/dconf/dconf.install
+++ b/abs/extra/dconf/dconf.install
@@ -1,5 +1,7 @@
post_install() {
- usr/bin/gio-querymodules usr/lib/gio/modules
+ gio-querymodules /usr/lib/gio/modules
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
}
post_upgrade(){