summaryrefslogtreecommitdiffstats
path: root/abs/extra/ddclient
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-12-07 01:38:55 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-12-07 01:38:55 (GMT)
commit863579ebaafe72c842dc617ce8fbb87a96188d0c (patch)
tree6a10a066dc870a04e1536004101e2b69ff699043 /abs/extra/ddclient
parentf38908ca3ffe3bfca6f795e991635cb5af222662 (diff)
downloadlinhes_pkgbuild-863579ebaafe72c842dc617ce8fbb87a96188d0c.zip
linhes_pkgbuild-863579ebaafe72c842dc617ce8fbb87a96188d0c.tar.gz
linhes_pkgbuild-863579ebaafe72c842dc617ce8fbb87a96188d0c.tar.bz2
ddclient: upgrade
Diffstat (limited to 'abs/extra/ddclient')
-rw-r--r--abs/extra/ddclient/ChangeLog22
-rw-r--r--abs/extra/ddclient/PKGBUILD32
-rw-r--r--abs/extra/ddclient/ddclient.conf.d2
-rw-r--r--abs/extra/ddclient/ddclient.install37
-rw-r--r--abs/extra/ddclient/ddclient.rc37
5 files changed, 115 insertions, 15 deletions
diff --git a/abs/extra/ddclient/ChangeLog b/abs/extra/ddclient/ChangeLog
new file mode 100644
index 0000000..4520b69
--- /dev/null
+++ b/abs/extra/ddclient/ChangeLog
@@ -0,0 +1,22 @@
+2008-08-07 Abhishek Dasgupta <abhidg@gmail.com>
+
+ * ddclient 3.7.3-2
+ * added /etc/conf.d/ddclient for modifying
+ daemon poll frequency. This overrides the
+ setting specified in /etc/ddclient/ddclient.conf
+ when ddclient is called as an rc script.
+
+2007-08-08 Alessio 'mOLOk' Bolognino <themolok@gmail.com>
+
+ * ddclient-3.7.3-1
+ * version bump
+ * GPL -> GPL2
+ * shortened pkgdesc
+
+2007-07-02 tardo <tardo@nagi-fanboi.net>
+
+ * Built for x86_64
+
+2007-06-29 Georg Grabler (STiAT) <ggrabler@gmail.com>
+
+ * Version Bump to 3.7.2
diff --git a/abs/extra/ddclient/PKGBUILD b/abs/extra/ddclient/PKGBUILD
index f283cb9..4942d7b 100644
--- a/abs/extra/ddclient/PKGBUILD
+++ b/abs/extra/ddclient/PKGBUILD
@@ -1,33 +1,35 @@
-# $Id: PKGBUILD,v 1.13 2008/08/07 07:11:09 abhidg Exp $
+# $Id: PKGBUILD 17388 2010-05-24 09:45:55Z spupykin $
# Maintainer: Abhishek Dasgupta <abhidg@gmail.com>
# Contributor: David Rosenstrauch <darose@darose.net>
pkgname=ddclient
pkgver=3.8.0
-pkgrel=1
+pkgrel=2
pkgdesc="Update dynamic DNS entries for accounts on many dynamic DNS services."
-arch=('i686' 'x86_64')
+arch=('any')
url="http://ddclient.sourceforge.net/"
license=('GPL2')
depends=('perl' 'perl-io-socket-ssl')
-backup=('etc/ddclient.conf')
-source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2
- ddclient.conf.dynamic.dyndns.sample
- ddclient-foreground.patch)
+backup=('etc/ddclient/ddclient.conf' 'etc/conf.d/ddclient')
+install=ddclient.install
+source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2 ddclient.rc ddclient.conf.d)
+md5sums=('6cac7a5eb1da781bfd4d98cef0b21f8e'
+ '7035bf8132f3517a59167f61ee5e8b90'
+ 'b8f39c82827776da948b76ef83544d33')
build() {
- cd ${srcdir}/$pkgname-${pkgver}
- patch < ${srcdir}/ddclient-foreground.patch
+ cd ${srcdir}/ddclient-${pkgver}
# core files
install -D -m755 ddclient ${pkgdir}/usr/sbin/ddclient
- install -D -m600 sample-etc_ddclient.conf ${pkgdir}/etc/ddclient/ddclient.conf.sample
- install -D -m600 ${srcdir}/ddclient.conf.dynamic.dyndns.sample ${pkgdir}/etc/ddclient/
+ install -D -m755 ${srcdir}/ddclient.rc ${pkgdir}/etc/rc.d/ddclient
+ install -D -m600 sample-etc_ddclient.conf ${pkgdir}/etc/ddclient/ddclient.conf
+ install -D -m644 ${srcdir}/ddclient.conf.d ${pkgdir}/etc/conf.d/ddclient
install -d ${pkgdir}/var/cache/ddclient
# additional instructions, sample configs
- install -D -m644 README ${pkgdir}/etc/ddclient/README
+ install -D -m644 README ${pkgdir}/etc/ddclient/samples/README
+ install -D -m644 sample-etc_cron.d_ddclient ${pkgdir}/etc/ddclient/samples/sample-etc_cron.d_ddclient
+ install -D -m644 sample-etc_dhcpc_dhcpcd-eth0.exe ${pkgdir}/etc/ddclient/samples/sample-etc_dhcpc_dhcpcd-eth0.exe
+ install -D -m644 sample-etc_ppp_ip-up.local ${pkgdir}/etc/ddclient/samples/sample-etc_ppp_ip-up.local
}
-md5sums=('6cac7a5eb1da781bfd4d98cef0b21f8e'
- '4194825b9b4a7fcc1c57c2f5a4f6162b'
- 'd8ffc95f98f9afcb4a06a1e192220e35')
diff --git a/abs/extra/ddclient/ddclient.conf.d b/abs/extra/ddclient/ddclient.conf.d
new file mode 100644
index 0000000..8b754a3
--- /dev/null
+++ b/abs/extra/ddclient/ddclient.conf.d
@@ -0,0 +1,2 @@
+# Parameters passed to ddclient
+EXTRA_ARGS="-daemon 300"
diff --git a/abs/extra/ddclient/ddclient.install b/abs/extra/ddclient/ddclient.install
new file mode 100644
index 0000000..55b0e1b
--- /dev/null
+++ b/abs/extra/ddclient/ddclient.install
@@ -0,0 +1,37 @@
+# arg 1: the new package version
+post_install() {
+cat << EOM
+
+If you want to use ddclient with dhcpcd, cron or pppd,
+see /etc/ddclient/samples for further instructions.
+
+If you have ddclient in the DAEMONS array of /etc/rc.conf:
+- Change /etc/conf.d/ddclient according to your needs.
+- This setting OVERRIDES any setting in
+ /etc/ddclient/ddclient.conf
+
+EOM
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+
+if [ -f /etc/ddclient/ddclient.cache ]; then
+ echo -n "Moving ddclient.cache from /etc/ddclient/ to /var/cache/ddclient/."
+ mv /etc/ddclient/ddclient.cache /var/cache/ddclient/
+ echo " (done)"
+fi
+
+if [ "$(vercmp $2 3.7.3-2)" -lt 0 ]; then
+cat << EOM
+
+If you have ddclient in the DAEMONS array of /etc/rc.conf:
+- Change /etc/conf.d/ddclient according to your needs.
+- This setting OVERRIDES any setting in
+ /etc/ddclient/ddclient.conf
+
+EOM
+fi
+
+}
diff --git a/abs/extra/ddclient/ddclient.rc b/abs/extra/ddclient/ddclient.rc
new file mode 100644
index 0000000..a9093f7
--- /dev/null
+++ b/abs/extra/ddclient/ddclient.rc
@@ -0,0 +1,37 @@
+#!/bin/bash
+
+[ -f /etc/conf.d/ddclient ] && . /etc/conf.d/ddclient
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+PID=`pidof -o %PPID /usr/sbin/ddclient`
+case "$1" in
+ start)
+ stat_busy "Starting ddclient"
+ [ -z "$PID" ] && /usr/sbin/ddclient ${EXTRA_ARGS}
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ add_daemon ddclient
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping ddclient"
+ [ -n "$PID" ] && kill -15 $PID >/dev/null
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm_daemon ddclient
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 1
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart}"
+esac