summaryrefslogtreecommitdiffstats
path: root/abs/extra/deb2targz
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-12-07 01:36:50 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-12-07 01:36:50 (GMT)
commit380717c55ae76b3a2edf231ec0a060012109c1c2 (patch)
tree498465dc31dc823be05c442f67213e0ee771824a /abs/extra/deb2targz
parent23ed0d89033c36dd2674aadf3320aa393a26422b (diff)
downloadlinhes_pkgbuild-380717c55ae76b3a2edf231ec0a060012109c1c2.zip
linhes_pkgbuild-380717c55ae76b3a2edf231ec0a060012109c1c2.tar.gz
linhes_pkgbuild-380717c55ae76b3a2edf231ec0a060012109c1c2.tar.bz2
deb2targz: recompile
Diffstat (limited to 'abs/extra/deb2targz')
-rw-r--r--abs/extra/deb2targz/COPYING25
-rw-r--r--abs/extra/deb2targz/PKGBUILD16
2 files changed, 33 insertions, 8 deletions
diff --git a/abs/extra/deb2targz/COPYING b/abs/extra/deb2targz/COPYING
new file mode 100644
index 0000000..918ae90
--- /dev/null
+++ b/abs/extra/deb2targz/COPYING
@@ -0,0 +1,25 @@
+This is a generic place holder for a class of licenses that boil down to do
+no guarantees and all you get is what you have. The language is usually
+similar to:
+
+ Permission to use, copy, modify, and distribute this software and its
+ documentation for any purpose and without fee is hereby granted, provided
+ that the above copyright notice appears in all copies and that both the
+ copyright notice and this permission notice appear in supporting
+ documentation, and that the same name not be used in advertising or
+ publicity pertaining to distribution of the software without specific,
+ written prior permission. We make no representations about the
+ suitability this software for any purpose. It is provided "as is"
+ without express or implied warranty.
+
+
+You will need to check the license that came with the software for the exact
+specifics. Generally you are free to do most anything you want with "as is"
+software but you should not take this license as legal advice.
+
+Note: Most all license have an "as is" clause. For our purposes this does
+not make all software in this category. This category is for software with
+very little restrictions.
+
+The information in this license about licenses is presented "as is". :-P
+
diff --git a/abs/extra/deb2targz/PKGBUILD b/abs/extra/deb2targz/PKGBUILD
index adf074d..e503b6f 100644
--- a/abs/extra/deb2targz/PKGBUILD
+++ b/abs/extra/deb2targz/PKGBUILD
@@ -3,18 +3,18 @@
pkgname=deb2targz
pkgver=1
-pkgrel=2
+pkgrel=3
pkgdesc="Converts .deb archives to tar.gz"
-arch=('i686' 'x86_64')
+arch=('any')
+license=('custom')
url="http://www.miketaylor.org.uk/tech/deb/"
depends=("perl")
-source=("http://www.miketaylor.org.uk/tech/deb/$pkgname")
-
-md5sums=('5b944785778d023a43e33af53bea2056')
+source=("http://www.miketaylor.org.uk/tech/deb/$pkgname" "COPYING")
build() {
- mkdir -p $startdir/pkg/usr/bin
- install -m755 $startdir/src/$pkgname $startdir/pkg/usr/bin
+ install -Dm755 $startdir/src/$pkgname $startdir/pkg/usr/bin/$pkgname
+ install -Dm644 $startdir/src/COPYING $startdir/pkg/usr/share/licenses/$pkgname/COPYING
}
-
+md5sums=('5b944785778d023a43e33af53bea2056'
+ 'dca32f6f6096435ad67b537d830810c6')