summaryrefslogtreecommitdiffstats
path: root/abs/extra/dnsmasq/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 19:44:50 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 19:44:50 (GMT)
commitc7d5220cabb6b67862e1bfa188c07e0d3821a294 (patch)
treef36132c071183cd86a6f7dd720ea054c74e1c9f0 /abs/extra/dnsmasq/PKGBUILD
parentfb1608aa973e24afe26c8fc754ddd11d9466d8ca (diff)
downloadlinhes_pkgbuild-c7d5220cabb6b67862e1bfa188c07e0d3821a294.zip
linhes_pkgbuild-c7d5220cabb6b67862e1bfa188c07e0d3821a294.tar.gz
linhes_pkgbuild-c7d5220cabb6b67862e1bfa188c07e0d3821a294.tar.bz2
dnsmasq 2.62
Diffstat (limited to 'abs/extra/dnsmasq/PKGBUILD')
-rw-r--r--abs/extra/dnsmasq/PKGBUILD58
1 files changed, 34 insertions, 24 deletions
diff --git a/abs/extra/dnsmasq/PKGBUILD b/abs/extra/dnsmasq/PKGBUILD
index f888ccd..1fd617d 100644
--- a/abs/extra/dnsmasq/PKGBUILD
+++ b/abs/extra/dnsmasq/PKGBUILD
@@ -1,41 +1,51 @@
-# $Id: PKGBUILD 66607 2010-02-01 01:42:17Z giovanni $
-# Maintainer: Paul Mattal <paul@archlinux.org>
+# $Id: PKGBUILD 160917 2012-06-07 00:05:24Z dreisner $
+# Maintainer: Dave Reisner <dreisner@archlinux.org>
+# Contributor: Paul Mattal <paul@archlinux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
pkgname=dnsmasq
-pkgver=2.55
+pkgver=2.62
pkgrel=1
pkgdesc="Lightweight, easy to configure DNS forwarder and DHCP server"
url="http://www.thekelleys.org.uk/dnsmasq/doc.html"
arch=('i686' 'x86_64')
license=('GPL')
-depends=('glibc' 'bash')
-makedepends=('libcap>=2.16')
-backup=('etc/dnsmasq.conf')
-install=
-source=("http://www.thekelleys.org.uk/$pkgname/$pkgname-$pkgver.tar.gz"
- 'rc.dnsmasq')
+depends=('glibc' 'dbus-core')
+install=$pkgname.install
+backup=('etc/dnsmasq.conf'
+ 'etc/conf.d/dnsmasq')
+source=("http://www.thekelleys.org.uk/$pkgname/$pkgname-$pkgver.tar.gz"
+ 'dnsmasq.confd'
+ 'rc.dnsmasq'
+ 'dnsmasq.service')
+md5sums=('f47e5cb8f5bac6343f24b2dbe317ab40'
+ '66479e99123faeab83ebaed709ef95b5'
+ '819fbdf6440d710616e6df5f8ca9cdba'
+ '631d8349acbed1b01d4e11d9f42fdb7d')
build() {
- cd $srcdir/$pkgname-$pkgver
+ cd "$pkgname-$pkgver"
- # Build
- make || return 1
+ # link against dbus. this ugliness is needed to ensure that the
+ # compile time opts report properly on startup. yuck.
+ sed -i '/^#ifdef DNSMASQ_COMPILE_OPTS/ {
+ i#define HAVE_DBUS
+ }' src/config.h
- # Install
- install -d $pkgdir/etc/rc.d || return 1
- make PREFIX=/usr DESTDIR=$pkgdir install || return 1
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make BINDIR=/usr/bin PREFIX=/usr DESTDIR="$pkgdir" install
- install -D -m755 \
- $srcdir/rc.dnsmasq $pkgdir/etc/rc.d/dnsmasq || return 1
- install -D -m644 \
- dnsmasq.conf.example $pkgdir/etc/dnsmasq.conf || return 1
+ install -Dm755 "$srcdir"/rc.dnsmasq "$pkgdir"/etc/rc.d/dnsmasq
+ install -Dm644 "$srcdir"/dnsmasq.confd "$pkgdir/etc/conf.d/dnsmasq"
- # Make the Required Directories for DHCP Server Default Directories
- install -d $pkgdir/var/db || return 1
- install -d $pkgdir/var/lib/misc || return 1
+ install -Dm644 "dbus/dnsmasq.conf" "$pkgdir"/etc/dbus-1/system.d/dnsmasq.conf
+ install -Dm644 "dnsmasq.conf.example" "$pkgdir"/etc/dnsmasq.conf
+ install -Dm644 "$srcdir/dnsmasq.service" "$pkgdir"/usr/lib/systemd/system/dnsmasq.service
}
# vim: ts=2 sw=2 et ft=sh
-md5sums=('b093d7c6bc7f97ae6fd35d048529232a'
- 'e956eee1ec24212a3254d2b168187495')