summaryrefslogtreecommitdiffstats
path: root/abs/extra/dnsmasq
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2010-08-30 22:26:00 (GMT)
committerJames Meyer <james.meyer@operamail.com>2010-08-30 22:26:00 (GMT)
commit1f175a7b07b9553ce98d0546ac04dbb925ec0bc9 (patch)
treec969070115611a8a75f23d468aa5e0cf86a08121 /abs/extra/dnsmasq
parentc4bd4457b5d640e1c8f5afbca7cd54c53691e5fc (diff)
downloadlinhes_pkgbuild-1f175a7b07b9553ce98d0546ac04dbb925ec0bc9.zip
linhes_pkgbuild-1f175a7b07b9553ce98d0546ac04dbb925ec0bc9.tar.gz
linhes_pkgbuild-1f175a7b07b9553ce98d0546ac04dbb925ec0bc9.tar.bz2
RESYNC EXTRA:
synced extra-testing -> extra repo Signed-off-by: James Meyer <james.meyer@operamail.com>
Diffstat (limited to 'abs/extra/dnsmasq')
-rw-r--r--abs/extra/dnsmasq/PKGBUILD41
-rwxr-xr-xabs/extra/dnsmasq/rc.dnsmasq36
2 files changed, 77 insertions, 0 deletions
diff --git a/abs/extra/dnsmasq/PKGBUILD b/abs/extra/dnsmasq/PKGBUILD
new file mode 100644
index 0000000..f888ccd
--- /dev/null
+++ b/abs/extra/dnsmasq/PKGBUILD
@@ -0,0 +1,41 @@
+# $Id: PKGBUILD 66607 2010-02-01 01:42:17Z giovanni $
+# Maintainer: Paul Mattal <paul@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=dnsmasq
+pkgver=2.55
+pkgrel=1
+pkgdesc="Lightweight, easy to configure DNS forwarder and DHCP server"
+url="http://www.thekelleys.org.uk/dnsmasq/doc.html"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('glibc' 'bash')
+makedepends=('libcap>=2.16')
+backup=('etc/dnsmasq.conf')
+install=
+source=("http://www.thekelleys.org.uk/$pkgname/$pkgname-$pkgver.tar.gz"
+ 'rc.dnsmasq')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+
+ # Build
+ make || return 1
+
+ # Install
+ install -d $pkgdir/etc/rc.d || return 1
+ make PREFIX=/usr DESTDIR=$pkgdir install || return 1
+
+ install -D -m755 \
+ $srcdir/rc.dnsmasq $pkgdir/etc/rc.d/dnsmasq || return 1
+ install -D -m644 \
+ dnsmasq.conf.example $pkgdir/etc/dnsmasq.conf || return 1
+
+ # Make the Required Directories for DHCP Server Default Directories
+ install -d $pkgdir/var/db || return 1
+ install -d $pkgdir/var/lib/misc || return 1
+}
+
+# vim: ts=2 sw=2 et ft=sh
+md5sums=('b093d7c6bc7f97ae6fd35d048529232a'
+ 'e956eee1ec24212a3254d2b168187495')
diff --git a/abs/extra/dnsmasq/rc.dnsmasq b/abs/extra/dnsmasq/rc.dnsmasq
new file mode 100755
index 0000000..1676072
--- /dev/null
+++ b/abs/extra/dnsmasq/rc.dnsmasq
@@ -0,0 +1,36 @@
+#!/bin/bash
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+PID=`pidof -o %PPID /usr/sbin/dnsmasq`
+case "$1" in
+ start)
+ stat_busy "Starting DNS/DHCP daemon"
+ [ -z "$PID" ] && /usr/sbin/dnsmasq
+ if [ $? -gt 0 ] ; then
+ stat_fail
+ else
+ add_daemon dnsmasq # create the 'state' dir
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping DNS/DHCP daemon"
+ [ "$PID" ] && kill $PID &> /dev/null
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm_daemon dnsmasq # remove the 'state' dir
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 5
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart}"
+esac
+exit 0