summaryrefslogtreecommitdiffstats
path: root/abs/extra/docbook-utils
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-02-15 20:55:38 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-02-15 20:55:38 (GMT)
commit9be8cfb27c3db59bd8392d411162b6e5c20b9d03 (patch)
tree74b08d1663b65e74a97609d3e75352e9714e1d5d /abs/extra/docbook-utils
parent85af7820ddf206711d890bdbd707c396824aac15 (diff)
downloadlinhes_pkgbuild-9be8cfb27c3db59bd8392d411162b6e5c20b9d03.zip
linhes_pkgbuild-9be8cfb27c3db59bd8392d411162b6e5c20b9d03.tar.gz
linhes_pkgbuild-9be8cfb27c3db59bd8392d411162b6e5c20b9d03.tar.bz2
ijs: dep of ghostscript
Diffstat (limited to 'abs/extra/docbook-utils')
-rw-r--r--abs/extra/docbook-utils/PKGBUILD47
-rw-r--r--abs/extra/docbook-utils/docbook-utils-0.6.14-grep_fix-1.patch33
2 files changed, 80 insertions, 0 deletions
diff --git a/abs/extra/docbook-utils/PKGBUILD b/abs/extra/docbook-utils/PKGBUILD
new file mode 100644
index 0000000..096ead7
--- /dev/null
+++ b/abs/extra/docbook-utils/PKGBUILD
@@ -0,0 +1,47 @@
+# $Id$
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
+
+# Contributor: Chris Severance aur.severach aATt spamgourmet dott com
+# Contributor: Andreas B. Wagner <AndreasBWagner@pointfree.net>
+# Contributor: Suat SARIALP <muhendis.suat@gmail.com>
+
+pkgname=docbook-utils
+pkgver=0.6.14
+pkgrel=8
+pkgdesc='Shell scripts to manage DocBook documents'
+arch=('any')
+url="https://www.sourceware.org/docbook-tools/"
+license=('GPL2')
+depends=('openjade' 'docbook-dsssl' 'docbook-sgml31')
+makedepends=('perl-sgmls')
+optdepends=('perl-sgmls: for conversion to man and texinfo'
+ 'lynx: for conversion to txt'
+ 'texlive-htmlxml: for conversion to pdf')
+conflicts=('docbook2x')
+source=(ftp://sources.redhat.com/pub/docbook-tools/new-trials/SOURCES/${pkgname}-${pkgver}.tar.gz
+ docbook-utils-0.6.14-grep_fix-1.patch)
+sha256sums=('48faab8ee8a7605c9342fb7b906e0815e3cee84a489182af38e8f7c0df2e92e9'
+ 'ddf0ddca0a540fd4f34f38b7b9090f96746e37da12b4e2bf8f4174c5ad61f54a')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ patch -Np1 -i ${srcdir}/docbook-utils-0.6.14-grep_fix-1.patch
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make install DESTDIR="${pkgdir}" htmldir="/usr/share/doc/${pkgname}/html"
+
+ #common alternative names
+ for doctype in 'html' 'ps' 'dvi' 'man' 'pdf' 'rtf' 'tex' 'texi' 'txt'; do
+ ln -svf "docbook2${doctype}" "${pkgdir}/usr/bin/db2${doctype}"
+ done
+}
diff --git a/abs/extra/docbook-utils/docbook-utils-0.6.14-grep_fix-1.patch b/abs/extra/docbook-utils/docbook-utils-0.6.14-grep_fix-1.patch
new file mode 100644
index 0000000..f966697
--- /dev/null
+++ b/abs/extra/docbook-utils/docbook-utils-0.6.14-grep_fix-1.patch
@@ -0,0 +1,33 @@
+Submitted By: Ken Moffat <ken at linuxfromscratch dot org>
+Date: 2011-01-01
+Initial Package Version: 0.6.14
+Upstream Status: unknown
+Origin: fedora
+Description: Grep-2.7 errors out on the 'space' syntax, causing
+docbook2html to fail. Fixed up by hand (the fedora version depends
+on a different patch which adds --color=never).
+
+diff -Naur docbook-utils-0.6.14.orig/bin/jw.in docbook-utils-0.6.14//bin/jw.in
+--- docbook-utils-0.6.14.orig/bin/jw.in 2003-04-30 17:21:49.000000000 +0100
++++ docbook-utils-0.6.14//bin/jw.in 2011-01-01 18:43:21.558959786 +0000
+@@ -80,9 +80,9 @@
+ SGML_CATALOGS_DIR="/etc/sgml"
+ if [ -f "$SGML_CONF" ]
+ then
+- RE='^[:space:]*SGML_BASE_DIR[:space:]*=[:space:]*'
++ RE='^[[:space:]]*SGML_BASE_DIR[[:space:]]*=[[:space:]]*'
+ SGML_BASE_DIR=`grep $RE $SGML_CONF | sed "s/$RE//"`
+- RE='^[:space:]*SGML_CATALOGS_DIR[:space:]*=[:space:]*'
++ RE='^[[:space:]]*SGML_CATALOGS_DIR[[:space:]]*=[[:space:]]*'
+ SGML_CATALOGS_DIR=`grep $RE $SGML_CONF | sed "s/$RE//"`
+ fi
+
+@@ -312,7 +312,7 @@
+ SGML_CATALOG_FILES=$SGML_CENTRALIZED_CATALOG
+ else
+ SGML_CATALOG_FILES=`find $SGML_BASE_DIR -name catalog`
+- SGML_CATALOG_FILES=`echo "$SGML_CATALOG_FILES" | tr [:space:] :`
++ SGML_CATALOG_FILES=`echo "$SGML_CATALOG_FILES" | tr [[:space:]] :`
+ fi
+ ;;
+ no) SGML_CATALOG_FILES=""