summaryrefslogtreecommitdiffstats
path: root/abs/extra/dotconf
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2013-10-16 20:41:16 (GMT)
committerBritney Fransen <brfransen@gmail.com>2013-10-16 20:41:16 (GMT)
commit4fb36a904c3818185105d2fe09adc512c46285c7 (patch)
tree56c1deb162824e4695133a955a6022e90282dd79 /abs/extra/dotconf
parent2648e999d277eac5c3d331a3609bcc73fafbea71 (diff)
parent36f4b0be52fddbd5f491da90475e69c25bf6903f (diff)
downloadlinhes_pkgbuild-4fb36a904c3818185105d2fe09adc512c46285c7.zip
linhes_pkgbuild-4fb36a904c3818185105d2fe09adc512c46285c7.tar.gz
linhes_pkgbuild-4fb36a904c3818185105d2fe09adc512c46285c7.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/extra/dotconf')
-rw-r--r--abs/extra/dotconf/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/abs/extra/dotconf/PKGBUILD b/abs/extra/dotconf/PKGBUILD
new file mode 100644
index 0000000..07e7e91
--- /dev/null
+++ b/abs/extra/dotconf/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id$
+# Maintainer:
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Chris Brannon <cmbrannon@cox.net>
+
+pkgname=dotconf
+pkgver=1.3
+pkgrel=3
+pkgdesc='A C library for parsing configuration files'
+url="https://github.com/williamh/dotconf"
+arch=('i686' 'x86_64')
+depends=('glibc')
+makedepends=('pkgconfig' 'findutils')
+license=('LGPL2.1')
+source=(${pkgname}-${pkgver}.tar.gz::"https://github.com/williamh/${pkgname}/tarball/v${pkgver}")
+md5sums=('36bfdde245072fc2f4f5766b7db97c45')
+options=('!libtool')
+
+build() {
+ cd "${srcdir}"/williamh-${pkgname}-4cd7b3a
+ autoreconf -i
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}"/williamh-${pkgname}-4cd7b3a
+ make DESTDIR="${pkgdir}" install
+}