summaryrefslogtreecommitdiffstats
path: root/abs/extra/enchant
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 19:46:25 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 19:46:25 (GMT)
commit8d5f9eddfaded22bdb0ff3c34d8bce4410107ab6 (patch)
treefebbd7cf342383a0e142ffd8ab2a3e17e9779a93 /abs/extra/enchant
parentb398233fbdc6f81348c8a6b845bdc0bc096f37e0 (diff)
downloadlinhes_pkgbuild-8d5f9eddfaded22bdb0ff3c34d8bce4410107ab6.zip
linhes_pkgbuild-8d5f9eddfaded22bdb0ff3c34d8bce4410107ab6.tar.gz
linhes_pkgbuild-8d5f9eddfaded22bdb0ff3c34d8bce4410107ab6.tar.bz2
enchant 1.6.0
Diffstat (limited to 'abs/extra/enchant')
-rw-r--r--abs/extra/enchant/PKGBUILD36
1 files changed, 22 insertions, 14 deletions
diff --git a/abs/extra/enchant/PKGBUILD b/abs/extra/enchant/PKGBUILD
index 0937bd8..a8dc20d 100644
--- a/abs/extra/enchant/PKGBUILD
+++ b/abs/extra/enchant/PKGBUILD
@@ -1,21 +1,29 @@
-# $Id: PKGBUILD 2581 2008-06-08 12:52:18Z jgc $
-# Maintainer: dorphell <dorphell@archlinux.org>
+# $Id: PKGBUILD 139539 2011-10-03 12:17:06Z jgc $
+# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: dorphell <dorphell@archlinux.org>
+
pkgname=enchant
pkgver=1.6.0
-pkgrel=1
+pkgrel=4
pkgdesc="A wrapper library for generic spell checking"
-arch=(i686 x86_64)
-license=('LGPL')
-depends=('aspell' 'dbus-glib>=0.74' 'hunspell>=1.2.2')
-makedepends=('hspell')
-options=(!libtool)
-source=(http://www.abisource.com/downloads/enchant/${pkgver}/${pkgname}-${pkgver}.tar.gz)
+arch=('i686' 'x86_64')
url="http://www.abisource.com/enchant/"
+license=('LGPL')
+depends=('aspell' 'dbus-glib' 'hunspell' 'hspell')
+options=('!libtool')
+source=("http://www.abisource.com/downloads/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+md5sums=('de11011aff801dc61042828041fb59c7')
build() {
- cd ${startdir}/src/${pkgname}-${pkgver}
- ./configure --prefix=/usr --disable-static || return 1
- make || return 1
- make DESTDIR=${startdir}/pkg install || return 1
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr \
+ --disable-static \
+ --disable-ispell \
+ --with-myspell-dir=/usr/share/myspell
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
}
-md5sums=('de11011aff801dc61042828041fb59c7')