summaryrefslogtreecommitdiffstats
path: root/abs/extra/ethtool
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-11-01 20:48:33 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-11-01 20:48:33 (GMT)
commit27f45d1e24fb070e85617fc6736e4a41a9a2035c (patch)
tree1b3e64ff648c54d5c63294f95a0316b6e61e5d23 /abs/extra/ethtool
parent812d4cea8f79d400ef9bc3604ccecb2fcd8f7a0c (diff)
downloadlinhes_pkgbuild-27f45d1e24fb070e85617fc6736e4a41a9a2035c.zip
linhes_pkgbuild-27f45d1e24fb070e85617fc6736e4a41a9a2035c.tar.gz
linhes_pkgbuild-27f45d1e24fb070e85617fc6736e4a41a9a2035c.tar.bz2
ethtool: recompile for 64 bits
Diffstat (limited to 'abs/extra/ethtool')
-rw-r--r--abs/extra/ethtool/PKGBUILD32
1 files changed, 17 insertions, 15 deletions
diff --git a/abs/extra/ethtool/PKGBUILD b/abs/extra/ethtool/PKGBUILD
index b137e4a..27ba9a5 100644
--- a/abs/extra/ethtool/PKGBUILD
+++ b/abs/extra/ethtool/PKGBUILD
@@ -1,25 +1,27 @@
-# $Id: PKGBUILD 127195 2011-06-11 08:04:12Z ibiru $
-# Maintainer: Paul Mattal <paul@archlinux.org>
-# Contributer: Martin Kemp <mdkemp@elys.com>
+# $Id: PKGBUILD 161868 2012-06-16 00:18:47Z ibiru $
+# Maintainer : Ionut Biru <ibiru@archlinux.org>
+# Contributor: Paul Mattal <paul@archlinux.org>
+# Contributor: Martin Kemp <mdkemp@elys.com>
+
pkgname=ethtool
-pkgver=2.6.39
-pkgrel=3
-epoch=2
-pkgdesc="gkernel ethtool"
-arch=(i686 x86_64)
+pkgver=3.4
+pkgrel=1
+epoch=1
+pkgdesc="Utility for controlling network drivers and hardware"
+arch=('i686' 'x86_64')
url="http://www.kernel.org/pub/software/network/ethtool/"
license=('GPL')
depends=('glibc')
-source=(http://www.kernel.org/pub/software/network/$pkgname/$pkgname-$pkgver.tar.bz2)
-md5sums=('97211a1e3a496bc3bd0b75849d0fbae9')
+source=(http://www.kernel.org/pub/software/network/$pkgname/$pkgname-$pkgver.tar.xz)
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix=/usr --mandir=/usr/share/man
- make
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr --mandir=/usr/share/man
+ make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
}
+md5sums=('cc4c4cf3ac086a53cd24f17d426f2b8f')