summaryrefslogtreecommitdiffstats
path: root/abs/extra/exo/PKGBUILD
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-12-01 02:08:47 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-12-01 02:08:47 (GMT)
commit257ea17e8d63e1d6de02fe352bb34d3214e43d2f (patch)
treec23678858b440aafd3b27b9be34ee883148bea93 /abs/extra/exo/PKGBUILD
parent923345b7416119a104584680da6f2bfa4ceba7e3 (diff)
downloadlinhes_pkgbuild-257ea17e8d63e1d6de02fe352bb34d3214e43d2f.zip
linhes_pkgbuild-257ea17e8d63e1d6de02fe352bb34d3214e43d2f.tar.gz
linhes_pkgbuild-257ea17e8d63e1d6de02fe352bb34d3214e43d2f.tar.bz2
exo: upgrade for thunar
Diffstat (limited to 'abs/extra/exo/PKGBUILD')
-rw-r--r--abs/extra/exo/PKGBUILD34
1 files changed, 19 insertions, 15 deletions
diff --git a/abs/extra/exo/PKGBUILD b/abs/extra/exo/PKGBUILD
index e402aac..e4eaf14 100644
--- a/abs/extra/exo/PKGBUILD
+++ b/abs/extra/exo/PKGBUILD
@@ -1,29 +1,33 @@
-# $Id: PKGBUILD 28206 2009-02-28 11:01:08Z andyrtr $
-# Maintainer: tobias <tobias funnychar archlinux.org>
+# $Id: PKGBUILD 89681 2010-09-03 08:02:13Z remy $
+# Maintainer: AndyRTR <andyrtr@archlinux.org>
+# Contributor: tobias <tobias funnychar archlinux.org>
# Contributor: Aurelien Foret <orelien@chez.com>
pkgname=exo
-pkgver=0.3.100
-pkgrel=1
+pkgver=0.3.107
+pkgrel=2
pkgdesc="Extensions to Xfce by os-cillation"
arch=('i686' 'x86_64')
-license=('GPL2' 'LGPL2')
-url="http://www.os-cillation.com/article.php?sid=40"
-groups=('xfce4')
-depends=("libxfce4util" "hal" 'hicolor-icon-theme')
-makedepends=("pygtk>=2.14.0" 'pkgconfig' 'libnotify' 'perl-uri')
-optdepends=('libnotify enables notification support' \
- 'perl enables mail-compose helper script')
+license=('GPL2' 'LGPL')
+url="http://www.xfce.org/projects/exo"
+depends=("libxfce4util>=4.6.2" "hal>=0.5.14" 'gtk2' 'hicolor-icon-theme' 'sh')
+makedepends=("pygtk>=2.17.0" 'pkgconfig' 'libnotify' 'perl-uri' 'intltool')
+optdepends=('libnotify: notification support for exo-mount-notify' \
+ 'perl-uri: for mail-compose helper script')
options=('!libtool')
install=${pkgname}.install
-source=(http://www.xfce.org/archive/xfce-4.6.0/src/${pkgname}-${pkgver}.tar.bz2)
-md5sums=('ebded97ff55f43cd0fe6b16242992ecf')
+source=(http://archive.xfce.org/src/xfce/${pkgname}/0.3/${pkgname}-${pkgver}.tar.bz2)
+md5sums=('3a92cca0c99ee940db4410891c9e8498')
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "${srcdir}/${pkgname}-${pkgver}"
./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib/xfce4 \
--localstatedir=/var --disable-static --enable-notifications \
--enable-python || return 1
make || return 1
- make DESTDIR=${pkgdir} install || return 1
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install || return 1
}