summaryrefslogtreecommitdiffstats
path: root/abs/extra/fceux/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-11-26 15:36:18 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-11-26 15:36:18 (GMT)
commit59aee5f62813dd69aa7a9896bf380d8828eaa855 (patch)
treefc50576e67b24120b58c9c097d0864876dc9da7d /abs/extra/fceux/PKGBUILD
parentb9b5401f69b3471813c44d11072dcb1a0cf5ea36 (diff)
downloadlinhes_pkgbuild-59aee5f62813dd69aa7a9896bf380d8828eaa855.zip
linhes_pkgbuild-59aee5f62813dd69aa7a9896bf380d8828eaa855.tar.gz
linhes_pkgbuild-59aee5f62813dd69aa7a9896bf380d8828eaa855.tar.bz2
fceux: updated from ABS no version change
Diffstat (limited to 'abs/extra/fceux/PKGBUILD')
-rw-r--r--abs/extra/fceux/PKGBUILD52
1 files changed, 31 insertions, 21 deletions
diff --git a/abs/extra/fceux/PKGBUILD b/abs/extra/fceux/PKGBUILD
index 4e9ccae..3d18d67 100644
--- a/abs/extra/fceux/PKGBUILD
+++ b/abs/extra/fceux/PKGBUILD
@@ -1,35 +1,45 @@
-# $Id: PKGBUILD 49458 2011-06-16 19:25:29Z angvp $
-# Maintainer: Eric Belanger <eric@archlinux.org>
-# Contributor: Jo Christian Bergskås <jcberg@gmail.com>
-
+# $Id: PKGBUILD 57567 2011-10-30 20:09:10Z arodseth $
+# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+# Contributor: Eric Belanger <eric@archlinux.org>
+# Contributor: Jo Christian Bergskås <jcberg@gmail.com>
pkgname=fceux
pkgver=2.1.5
-pkgrel=1
-arch=('i686' 'x86_64')
-url="http://fceux.com/web/home.html"
-pkgdesc="A fast and ultra-compatible NES/Famicom emulator with SDL, OpenGL and SVGALIB support"
+pkgrel=3
+arch=('x86_64' 'i686')
+url="http://fceux.com/"
+pkgdesc="Fast and ultra-compatible NES/Famicom emulator"
license=('GPL')
-depends=('sdl' 'lua' 'gtk2')
-makedepends=('scons' 'mesa')
-optdepends=('xchm: for viewing the help manual')
+depends=('sdl' 'gtk2' 'gd' 'desktop-file-utils')
+makedepends=('scons' 'mesa' 'lua')
+optdepends=('xchm: for viewing the manual')
provides=('fceu' 'gfceux')
replaces=('fceu' 'gfceux')
-source=(http://downloads.sourceforge.net/fceultra/$pkgname-${pkgver}.src.tar.bz2 \
- fceux.desktop fceux.png)
+install=fceux.install
+source=("http://downloads.sourceforge.net/fceultra/$pkgname-$pkgver.src.tar.bz2"
+ "fceux.desktop"
+ "fceux.png")
build() {
- cd "${srcdir}/fceu$pkgver"
- scons
+ cd "$srcdir/fceu${pkgver}"
+
+ sed -i "s|/usr/local|$pkgdir/usr|" SConstruct
+ scons OPENGL=0 install
+}
- sed -i "s|/usr/local|${pkgdir}/usr|" SConstruct
- scons install
+package() {
+ cd "$srcdir/fceu${pkgver}"
- install -D -m644 bin/$pkgname.chm "${pkgdir}/usr/share/doc/$pkgname/$pkgname.chm"
- install -D -m644 "$srcdir"/fceux.desktop "${pkgdir}"/usr/share/applications/fceux.desktop
- install -D -m644 "$srcdir"/fceux.png "$pkgdir"/usr/share/pixmaps/fceux.png
+ install -Dm644 bin/$pkgname.chm \
+ "$pkgdir/usr/share/doc/$pkgname/$pkgname.chm"
+ install -Dm644 $srcdir/fceux.desktop \
+ "$pkgdir/usr/share/applications/fceux.desktop"
+ install -Dm644 $srcdir/fceux.png \
+ "$pkgdir/usr/share/pixmaps/fceux.png"
+ install -Dm644 COPYING \
+ "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}
# vim:set ts=2 sw=2 et:
md5sums=('e8b20e62bbbb061b1a59d51b47c827bd'
- '30baf915c936926fa50f59d8276f6575'
+ '3c6a259d88825ff1b9387d191a6c970e'
'3fe753731ac46b5fee528b1f73abd3e3')