summaryrefslogtreecommitdiffstats
path: root/abs/extra/ffmpeg2.8/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-10-25 14:58:41 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-10-25 14:58:41 (GMT)
commit8d29737682e67ca7276fae0b1e8e69578ce61428 (patch)
tree4cc01d92c820214a4e5249575eb7f5ccd6c142bb /abs/extra/ffmpeg2.8/PKGBUILD
parentdb8bcbe3926e77c0144204beda14dee25a388d39 (diff)
parent927a8f226e532ba2187e8a9c9292453c3896f571 (diff)
downloadlinhes_pkgbuild-8d29737682e67ca7276fae0b1e8e69578ce61428.zip
linhes_pkgbuild-8d29737682e67ca7276fae0b1e8e69578ce61428.tar.gz
linhes_pkgbuild-8d29737682e67ca7276fae0b1e8e69578ce61428.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/extra/ffmpeg2.8/PKGBUILD')
-rw-r--r--abs/extra/ffmpeg2.8/PKGBUILD110
1 files changed, 110 insertions, 0 deletions
diff --git a/abs/extra/ffmpeg2.8/PKGBUILD b/abs/extra/ffmpeg2.8/PKGBUILD
new file mode 100644
index 0000000..8e00522
--- /dev/null
+++ b/abs/extra/ffmpeg2.8/PKGBUILD
@@ -0,0 +1,110 @@
+# $Id$
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+# Contributor: Paul Mattal <paul@archlinux.org>
+
+pkgname=ffmpeg2.8
+pkgver=2.8.7
+pkgrel=2
+pkgdesc='Complete solution to record, convert and stream audio and video'
+arch=('i686' 'x86_64')
+url='http://ffmpeg.org/'
+license=('GPL3')
+depends=('alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'gnutls' 'gsm' 'lame'
+ 'libass' 'libbluray' 'libmodplug' 'libsoxr' 'libssh'
+ 'libtheora' 'libva' 'libvdpau' 'libwebp' 'opencore-amr' 'openjpeg'
+ 'opus' 'schroedinger' 'sdl' 'speex' 'v4l-utils' 'xvidcore' 'zlib'
+ 'libdcadec.so' 'libvidstab.so' 'libvorbis.so' 'libvorbisenc.so'
+ 'libvpx.so' 'libx264.so' 'libx265.so')
+makedepends=('hardening-wrapper' 'ladspa' 'libvdpau' 'yasm')
+optdepends=('ladspa: LADSPA filters')
+provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
+ 'libavresample.so' 'libavutil.so' 'libpostproc.so' 'libswresample.so'
+ 'libswscale.so')
+source=("http://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.bz2"
+ "http://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.bz2.asc"
+ 'ffmpeg-2.8-kodi.patch'
+ 'ffmpeg-2.8-Resolve-plex-direct-domains.patch'
+ 'ffmpeg-99.0011-mpeg4video-Signal-unsupported-GMC-with-more-than-one.patch'
+ 'ffmpeg-Speed_up_wtv_index_creation.patch'
+)
+validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
+sha256sums=('8777ce4a335640fdd13680ba423ef6da330ff5071bfbe27cdbb452379167efe5'
+ 'SKIP'
+ 'f89a26cb409bab1ac00106db008eccf72c6390e04d7cde2a63fbb1f2e9fbc669'
+ 'ca7eca1b9476c93efbdea457b64b0e5d925ad437f79168112aae52319d59d155'
+ 'fa78aa79ff861edbb8b6443978a0da60c4241f7a7f3888b242031ba916fa7514'
+ 'd1191e3e3fc980535e4835b5ef9b52fd15a14b58ef56ac6d2710bd589ce94b40'
+)
+
+prepare() {
+ cd ${srcdir}/ffmpeg-${pkgver}
+ patch -Np1 -i ${srcdir}/ffmpeg-2.8-kodi.patch
+ patch -Np1 -i ${srcdir}/ffmpeg-2.8-Resolve-plex-direct-domains.patch
+ patch -Np1 -i ${srcdir}/ffmpeg-99.0011-mpeg4video-Signal-unsupported-GMC-with-more-than-one.patch
+ patch -Np1 -i ${srcdir}/ffmpeg-Speed_up_wtv_index_creation.patch
+}
+
+build() {
+ cd ffmpeg-${pkgver}
+
+ ./configure \
+ --prefix='/usr' \
+ --incdir='/usr/include/ffmpeg2.8' \
+ --libdir='/usr/lib/ffmpeg2.8' \
+ --shlibdir='/usr/lib/ffmpeg2.8' \
+ --disable-debug \
+ --disable-static \
+ --disable-stripping \
+ --enable-avisynth \
+ --enable-avresample \
+ --enable-fontconfig \
+ --enable-gnutls \
+ --enable-gpl \
+ --enable-ladspa \
+ --enable-libass \
+ --enable-libbluray \
+ --enable-libdcadec \
+ --enable-libfreetype \
+ --enable-libfribidi \
+ --enable-libgsm \
+ --enable-libmodplug \
+ --enable-libmp3lame \
+ --enable-libopencore_amrnb \
+ --enable-libopencore_amrwb \
+ --enable-libopenjpeg \
+ --enable-libopus \
+ --disable-libpulse \
+ --enable-libschroedinger \
+ --enable-libsoxr \
+ --enable-libspeex \
+ --enable-libssh \
+ --enable-libtheora \
+ --enable-libv4l2 \
+ --enable-libvidstab \
+ --enable-libvorbis \
+ --enable-libvpx \
+ --enable-libwebp \
+ --enable-libx264 \
+ --enable-libx265 \
+ --enable-libxvid \
+ --enable-shared \
+ --enable-version3 \
+ --enable-x11grab
+ make
+}
+
+package() {
+ cd ffmpeg-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}"/usr/{bin,share}
+
+ install -dm 755 "${pkgdir}"/etc/ld.so.conf.d
+ echo -e '/usr/lib/\n/usr/lib/ffmpeg2.8/' > "${pkgdir}"/etc/ld.so.conf.d/ffmpeg2.8.conf
+}
+
+# vim: ts=2 sw=2 et:
+