summaryrefslogtreecommitdiffstats
path: root/abs/extra/ffmpeg2.8
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-07-06 21:36:42 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-07-06 21:36:42 (GMT)
commit370c082af575c996e4afad0d6e3f4192801054d3 (patch)
tree686c92d183a541513105991176625cc54559ed8e /abs/extra/ffmpeg2.8
parentfa99d61bf0c063ad51b341128789c1dce11f30f9 (diff)
downloadlinhes_pkgbuild-370c082af575c996e4afad0d6e3f4192801054d3.zip
linhes_pkgbuild-370c082af575c996e4afad0d6e3f4192801054d3.tar.gz
linhes_pkgbuild-370c082af575c996e4afad0d6e3f4192801054d3.tar.bz2
ffmpeg2.8: initial commit
Diffstat (limited to 'abs/extra/ffmpeg2.8')
-rw-r--r--abs/extra/ffmpeg2.8/PKGBUILD92
-rw-r--r--abs/extra/ffmpeg2.8/__changelog1
2 files changed, 93 insertions, 0 deletions
diff --git a/abs/extra/ffmpeg2.8/PKGBUILD b/abs/extra/ffmpeg2.8/PKGBUILD
new file mode 100644
index 0000000..00354ed
--- /dev/null
+++ b/abs/extra/ffmpeg2.8/PKGBUILD
@@ -0,0 +1,92 @@
+# $Id$
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+# Contributor: Paul Mattal <paul@archlinux.org>
+
+pkgname=ffmpeg2.8
+pkgver=2.8.7
+pkgrel=1
+pkgdesc='Complete solution to record, convert and stream audio and video'
+arch=('i686' 'x86_64')
+url='http://ffmpeg.org/'
+license=('GPL3')
+depends=('alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'gnutls' 'gsm' 'lame'
+ 'libass' 'libbluray' 'libmodplug' 'libsoxr' 'libssh'
+ 'libtheora' 'libva' 'libvdpau' 'libwebp' 'opencore-amr' 'openjpeg'
+ 'opus' 'schroedinger' 'sdl' 'speex' 'v4l-utils' 'xvidcore' 'zlib'
+ 'libdcadec.so' 'libvidstab.so' 'libvorbis.so' 'libvorbisenc.so'
+ 'libvpx.so' 'libx264.so' 'libx265.so')
+makedepends=('hardening-wrapper' 'ladspa' 'libvdpau' 'yasm')
+optdepends=('ladspa: LADSPA filters')
+provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
+ 'libavresample.so' 'libavutil.so' 'libpostproc.so' 'libswresample.so'
+ 'libswscale.so')
+source=("http://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.bz2"
+ "http://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.bz2.asc")
+validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
+sha256sums=('8777ce4a335640fdd13680ba423ef6da330ff5071bfbe27cdbb452379167efe5'
+ 'SKIP')
+
+build() {
+ cd ffmpeg-${pkgver}
+
+ ./configure \
+ --prefix='/usr' \
+ --incdir='/usr/include/ffmpeg2.8' \
+ --libdir='/usr/lib/ffmpeg2.8' \
+ --shlibdir='/usr/lib/ffmpeg2.8' \
+ --disable-debug \
+ --disable-static \
+ --disable-stripping \
+ --enable-avisynth \
+ --enable-avresample \
+ --enable-fontconfig \
+ --enable-gnutls \
+ --enable-gpl \
+ --enable-ladspa \
+ --enable-libass \
+ --enable-libbluray \
+ --enable-libdcadec \
+ --enable-libfreetype \
+ --enable-libfribidi \
+ --enable-libgsm \
+ --enable-libmodplug \
+ --enable-libmp3lame \
+ --enable-libopencore_amrnb \
+ --enable-libopencore_amrwb \
+ --enable-libopenjpeg \
+ --enable-libopus \
+ --disable-libpulse \
+ --enable-libschroedinger \
+ --enable-libsoxr \
+ --enable-libspeex \
+ --enable-libssh \
+ --enable-libtheora \
+ --enable-libv4l2 \
+ --enable-libvidstab \
+ --enable-libvorbis \
+ --enable-libvpx \
+ --enable-libwebp \
+ --enable-libx264 \
+ --enable-libx265 \
+ --enable-libxvid \
+ --enable-shared \
+ --enable-version3 \
+ --enable-x11grab
+ make
+}
+
+package() {
+ cd ffmpeg-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}"/usr/{bin,share}
+
+ install -dm 755 "${pkgdir}"/etc/ld.so.conf.d
+ echo -e '/usr/lib/\n/usr/lib/ffmpeg2.8/' > "${pkgdir}"/etc/ld.so.conf.d/ffmpeg2.8.conf
+}
+
+# vim: ts=2 sw=2 et:
+
diff --git a/abs/extra/ffmpeg2.8/__changelog b/abs/extra/ffmpeg2.8/__changelog
new file mode 100644
index 0000000..5ec137b
--- /dev/null
+++ b/abs/extra/ffmpeg2.8/__changelog
@@ -0,0 +1 @@
+PKGBUILD: remove dep libpulse and disable in configure