summaryrefslogtreecommitdiffstats
path: root/abs/extra/ffnvcodec-headers
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2019-03-19 20:11:10 (GMT)
committerBritney Fransen <brfransen@gmail.com>2019-03-19 20:11:10 (GMT)
commit73cfb83a5baecfe0529fda59ca57233d8843f783 (patch)
tree2dba2103a6f6e43912fc645ca8b48a85ab500ad2 /abs/extra/ffnvcodec-headers
parent7b41a9288f5d1332c8136df798bb8ca2465bc21c (diff)
parent448cb8d0708224d78c24ce3615dc7eef44d4689b (diff)
downloadlinhes_pkgbuild-73cfb83a5baecfe0529fda59ca57233d8843f783.zip
linhes_pkgbuild-73cfb83a5baecfe0529fda59ca57233d8843f783.tar.gz
linhes_pkgbuild-73cfb83a5baecfe0529fda59ca57233d8843f783.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/extra/ffnvcodec-headers')
-rw-r--r--abs/extra/ffnvcodec-headers/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/extra/ffnvcodec-headers/PKGBUILD b/abs/extra/ffnvcodec-headers/PKGBUILD
new file mode 100644
index 0000000..c496cda
--- /dev/null
+++ b/abs/extra/ffnvcodec-headers/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Daniel Bermond <danielbermond@yahoo.com>
+
+pkgname=ffnvcodec-headers
+pkgver=8.2.15.6
+pkgrel=1
+pkgdesc='FFmpeg version of headers required to interface with Nvidias codec APIs'
+arch=('any')
+url='https://git.videolan.org/?p=ffmpeg/nv-codec-headers.git'
+license=('MIT')
+makedepends=('git')
+source=("git+https://git.videolan.org/git/ffmpeg/nv-codec-headers.git#tag=n${pkgver}")
+sha256sums=('SKIP')
+
+build() {
+ make PREFIX='/usr' -C nv-codec-headers
+ sed -n '4,25p' nv-codec-headers/include/ffnvcodec/nvEncodeAPI.h > LICENSE # Extract license
+ sed -i '1,22s/^.\{,3\}//' LICENSE # Delete C comments
+}
+
+package() {
+ make PREFIX='/usr' DESTDIR="${pkgdir}" -C nv-codec-headers install
+ install -Dm 644 LICENSE -t "${pkgdir}"/usr/share/licenses/ffnvcodec-headers/
+}
+
+# vim: ts=2 sw=2 et: