summaryrefslogtreecommitdiffstats
path: root/abs/extra/fluidsynth
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-11-25 04:49:14 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-11-25 04:49:14 (GMT)
commitf591ead4c8a9b64b0630900aa12c260027a7db6f (patch)
tree091b31cdc3a24c0b9108f0ea718ecaad166cc834 /abs/extra/fluidsynth
parent9b35fb3e4f637252b4674a78adf9026faeaa5340 (diff)
downloadlinhes_pkgbuild-f591ead4c8a9b64b0630900aa12c260027a7db6f.zip
linhes_pkgbuild-f591ead4c8a9b64b0630900aa12c260027a7db6f.tar.gz
linhes_pkgbuild-f591ead4c8a9b64b0630900aa12c260027a7db6f.tar.bz2
compiled/added programs needed by xbmc: Moved some programs out of community into extra.
libmpeg2 pm-utils afpfs-ng fluidsynth libmodplug libnfs libshairport dbus-c__ doxygen libocnfig libffado libimobiledevice libmicrothttpd sdl_image sdl_mixer smpeg upower usbmuxd vdpau-video
Diffstat (limited to 'abs/extra/fluidsynth')
-rw-r--r--abs/extra/fluidsynth/PKGBUILD52
-rw-r--r--abs/extra/fluidsynth/__changelog1
-rw-r--r--abs/extra/fluidsynth/fluidsynth.conf2
-rw-r--r--abs/extra/fluidsynth/fluidsynth.install19
-rw-r--r--abs/extra/fluidsynth/fluidsynth.rc40
-rw-r--r--abs/extra/fluidsynth/fluidsynth.systemd9
6 files changed, 123 insertions, 0 deletions
diff --git a/abs/extra/fluidsynth/PKGBUILD b/abs/extra/fluidsynth/PKGBUILD
new file mode 100644
index 0000000..bef6083
--- /dev/null
+++ b/abs/extra/fluidsynth/PKGBUILD
@@ -0,0 +1,52 @@
+# $Id: PKGBUILD 166870 2012-09-20 10:08:01Z schiv $
+# Maintainer: Ray Rashif <schiv@archlinux.org>
+# Contributor: damir <damir@archlinux.org>
+
+pkgname=fluidsynth
+pkgver=1.1.6
+pkgrel=1
+pkgdesc="A real-time software synthesizer based on the SoundFont 2 specifications"
+arch=('i686' 'x86_64')
+url="http://www.fluidsynth.org/"
+#depends=('glib2' 'jack' 'dbus-core' 'libpulse')
+depends=('glib2' 'dbus-core' )
+makedepends=('cmake' 'ladspa' 'doxygen')
+#optdepends=('pulseaudio: PulseAudio sound support')
+license=('LGPL')
+backup=('etc/conf.d/fluidsynth')
+install=$pkgname.install
+source=("http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+ 'fluidsynth.conf'
+ 'fluidsynth.rc'
+ 'fluidsynth.systemd')
+md5sums=('ae5aca6de824b4173667cbd3a310b263'
+ '7d0ab0d75d4e87652f4cb7ffeac8a82b'
+ 'b296dbfb524c2164f552f68bd9abe2ec'
+ 'e0406748a154409907df62292be32e8a')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -Denable-ladspa=ON \
+ -DLIB_SUFFIX=""
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+
+ install -Dm644 "$srcdir/fluidsynth.conf" \
+ "$pkgdir/etc/conf.d/fluidsynth"
+
+ install -Dm755 "$srcdir/fluidsynth.rc" \
+ "$pkgdir/etc/rc.d/fluidsynth"
+
+ install -Dm644 "$srcdir/fluidsynth.systemd" \
+ "$pkgdir/usr/lib/systemd/system/fluidsynth.service"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/abs/extra/fluidsynth/__changelog b/abs/extra/fluidsynth/__changelog
new file mode 100644
index 0000000..144c13b
--- /dev/null
+++ b/abs/extra/fluidsynth/__changelog
@@ -0,0 +1 @@
+removed pulse jack
diff --git a/abs/extra/fluidsynth/fluidsynth.conf b/abs/extra/fluidsynth/fluidsynth.conf
new file mode 100644
index 0000000..b8465fa
--- /dev/null
+++ b/abs/extra/fluidsynth/fluidsynth.conf
@@ -0,0 +1,2 @@
+FSYNTH_OPTS="-a alsa -m alsa_seq -r 48000"
+FSYNTH_SOUNDFONT="" # path to your soundfont
diff --git a/abs/extra/fluidsynth/fluidsynth.install b/abs/extra/fluidsynth/fluidsynth.install
new file mode 100644
index 0000000..86e05f8
--- /dev/null
+++ b/abs/extra/fluidsynth/fluidsynth.install
@@ -0,0 +1,19 @@
+post_install() {
+ echo
+ echo " > To use FluidSynth as a daemon edit /etc/conf.d/fluidsynth"
+ echo
+ echo " > Systemd users need to copy the service file from:"
+ echo " /usr/lib/systemd/system/fluidsynth.service"
+ echo " > to:"
+ echo " /etc/systemd/system/multi-user.target.wants/"
+ echo " > and then edit accordingly."
+ echo
+ echo " > PulseAudio output when running as a daemon"
+ echo " > is known to be problematic. See:"
+ echo " https://bbs.archlinux.org/viewtopic.php?id=135092"
+ echo
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/abs/extra/fluidsynth/fluidsynth.rc b/abs/extra/fluidsynth/fluidsynth.rc
new file mode 100644
index 0000000..ca1e8fa
--- /dev/null
+++ b/abs/extra/fluidsynth/fluidsynth.rc
@@ -0,0 +1,40 @@
+#!/bin/bash
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+[ -f /etc/conf.d/fluidsynth ] && . /etc/conf.d/fluidsynth
+
+PID=`pidof -o %PPID /usr/bin/fluidsynth`
+case "$1" in
+ start)
+ stat_busy "Starting Fluidsynth soundfont synthesizer"
+ [ -z "$PID" ] && /usr/bin/fluidsynth -is $FSYNTH_OPTS $FSYNTH_SOUNDFONT > /dev/null 2>&1 &
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ echo $PID > /var/run/fluidsynth.pid
+ add_daemon fluidsynth
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping Fluidsynth soundfont synthesizer"
+ [ ! -z "$PID" ] && kill $PID &> /dev/null 2>&1
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm /var/run/fluidsynth.pid
+ rm_daemon fluidsynth
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 1
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart}"
+esac
+exit 0
diff --git a/abs/extra/fluidsynth/fluidsynth.systemd b/abs/extra/fluidsynth/fluidsynth.systemd
new file mode 100644
index 0000000..06784fe
--- /dev/null
+++ b/abs/extra/fluidsynth/fluidsynth.systemd
@@ -0,0 +1,9 @@
+[Unit]
+Description=FluidSynth Daemon
+After=sound.target
+
+[Service]
+ExecStart=/usr/bin/fluidsynth -is -a alsa -m alsa_seq -r 48000 # append soundfont path here
+
+[Install]
+WantedBy=multi-user.target