summaryrefslogtreecommitdiffstats
path: root/abs/extra/foldingathome/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-11-26 14:53:38 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-11-26 14:53:38 (GMT)
commit19921178a861f4bb631f6ec05d19fcaebc5836a6 (patch)
tree2ac297a54dad219302261345254fd167c146aaa9 /abs/extra/foldingathome/PKGBUILD
parentc4497a9290ec83a0472113d91cc369b82ba33b47 (diff)
downloadlinhes_pkgbuild-19921178a861f4bb631f6ec05d19fcaebc5836a6.zip
linhes_pkgbuild-19921178a861f4bb631f6ec05d19fcaebc5836a6.tar.gz
linhes_pkgbuild-19921178a861f4bb631f6ec05d19fcaebc5836a6.tar.bz2
folding at home: moved to extra from community
Diffstat (limited to 'abs/extra/foldingathome/PKGBUILD')
-rw-r--r--abs/extra/foldingathome/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/extra/foldingathome/PKGBUILD b/abs/extra/foldingathome/PKGBUILD
new file mode 100644
index 0000000..c78cb93
--- /dev/null
+++ b/abs/extra/foldingathome/PKGBUILD
@@ -0,0 +1,28 @@
+# Contributor: Jason Taylor <jftaylor21@gmail.com>
+# Contributor: seratne
+# Contributor: Nick B <Shirakawasuna at gmail _dot_com>
+
+pkgname=foldingathome
+pkgver=6.02
+pkgrel=7
+pkgdesc="Folding@Home is a distributed computing project which studies protein folding, misfolding, aggregation, and related diseases."
+arch=('i686' 'x86_64')
+url="http://folding.stanford.edu/"
+license=('custom')
+depends=('bash')
+backup=('etc/conf.d/foldingathome')
+install=foldingathome.install
+source=(http://www.stanford.edu/group/pandegroup/folding/release/FAH$pkgver-Linux.tgz
+ run)
+
+build() {
+ cd $startdir/src/
+
+ tar zxf FAH${pkgver}-Linux.tgz
+
+ # At this stage, the mpiexec is not included because it requires x86_64.
+ install -D -c -m755 fah6 $startdir/pkg/usr/bin/fah6 || return 1
+ install -D -m755 run $startdir/pkg/etc/sv/fah/run
+}
+md5sums=('112b3d66909050f1bb990993a1464cb9'
+ 'cefaf5ba2f3e2fe81533b5ee4795dc78')