summaryrefslogtreecommitdiffstats
path: root/abs/extra/foldingathome/foldingathome-v7
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-04 21:43:33 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-04 21:43:33 (GMT)
commit03a4f6f5c9a43baf1dd7d5e9b44e5113b90ba35b (patch)
tree5d7dd7d95011fda5712356e67792d4d89b3d3f1f /abs/extra/foldingathome/foldingathome-v7
parent251aa67903af196b8cfe6eac0ff04a37a456238d (diff)
downloadlinhes_pkgbuild-03a4f6f5c9a43baf1dd7d5e9b44e5113b90ba35b.zip
linhes_pkgbuild-03a4f6f5c9a43baf1dd7d5e9b44e5113b90ba35b.tar.gz
linhes_pkgbuild-03a4f6f5c9a43baf1dd7d5e9b44e5113b90ba35b.tar.bz2
foldingathome: updated client to v7
refs #872
Diffstat (limited to 'abs/extra/foldingathome/foldingathome-v7')
-rw-r--r--abs/extra/foldingathome/foldingathome-v7/PKGBUILD45
-rw-r--r--abs/extra/foldingathome/foldingathome-v7/foldingathome-v7.install12
-rw-r--r--abs/extra/foldingathome/foldingathome-v7/foldingathome-v7.rc.d46
-rw-r--r--abs/extra/foldingathome/foldingathome-v7/foldingathome-v7.service12
4 files changed, 115 insertions, 0 deletions
diff --git a/abs/extra/foldingathome/foldingathome-v7/PKGBUILD b/abs/extra/foldingathome/foldingathome-v7/PKGBUILD
new file mode 100644
index 0000000..c98ef7c
--- /dev/null
+++ b/abs/extra/foldingathome/foldingathome-v7/PKGBUILD
@@ -0,0 +1,45 @@
+# Contributor: paul2lv [at] gmail dot com
+# Maintainer:
+
+pkgname=foldingathome-v7
+pkgver=7.2.9
+pkgrel=1
+pkgdesc="Folding@Home is a distributed computing project which studies protein folding, misfolding, aggregation, and related diseases."
+arch=('i686' 'x86_64')
+url="http://folding.stanford.edu/"
+license=('CUSTOM')
+depends=('glibc')
+install=foldingathome-v7.install
+
+# Moronic server
+DLAGENTS=("https::/usr/bin/curl -k -o %o %u")
+
+[ "$CARCH" = "i686" ] &&_source_arch="32bit"
+[ "$CARCH" = "x86_64" ] && _source_arch="64bit"
+
+if [ "$CARCH" = "i686" ]; then
+ source=(https://fah-web.stanford.edu/file-releases/public/release/fahclient/debian-testing-32bit/v7.2/fahclient_7.2.9-32bit-release.tar.bz2 foldingathome-v7.rc.d foldingathome-v7.service)
+ md5sums=('f8a0b43bfc4110f2200b689d8d788962' '50481b4e31edb24519e855d770955eda' 'fe7c7652443e72830cf6d641846c07f6')
+
+elif [ "$CARCH" = "x86_64" ]; then
+ source=(https://fah-web.stanford.edu/file-releases/public/release/fahclient/debian-testing-64bit/v7.2/fahclient_7.2.9-64bit-release.tar.bz2 foldingathome-v7.rc.d foldingathome-v7.service)
+ md5sums=('d8d93d3436e5ebb52876c73cf375c9ac' '50481b4e31edb24519e855d770955eda' 'fe7c7652443e72830cf6d641846c07f6')
+fi
+
+
+build() {
+ cd ${srcdir}
+
+ install -D -c -m755 fahclient_${pkgver}-${_source_arch}-release/FAHClient ${pkgdir}/opt/fah-v7/FAHClient
+ install -D -c -m755 fahclient_${pkgver}-${_source_arch}-release/FAHCoreWrapper ${pkgdir}/opt/fah-v7/FAHCoreWrapper
+ install -D -c -m755 ${srcdir}/foldingathome-v7.rc.d ${pkgdir}/etc/rc.d/foldingathome-v7
+ install -D -c -m755 fahclient_${pkgver}-${_source_arch}-release/sample-config.xml ${pkgdir}/opt/fah-v7/sample-config.xml
+
+ chmod 755 ${pkgdir}/opt/fah-v7/FAHClient
+ chmod 755 ${pkgdir}/opt/fah-v7/FAHCoreWrapper
+ install -D -m644 fahclient_${pkgver}-${_source_arch}-release/copyright ${pkgdir}/usr/share/licenses/${pkgname}/copyright
+ install -D -m644 fahclient_${pkgver}-${_source_arch}-release/README ${pkgdir}/opt/fah-v7/README
+ install -D -m644 fahclient_${pkgver}-${_source_arch}-release/ChangeLog ${pkgdir}/opt/fah-v7/ChangeLog
+ install -D -m644 ${srcdir}/foldingathome-v7.service ${pkgdir}/etc/systemd/system/foldingathome-v7.service
+}
+
diff --git a/abs/extra/foldingathome/foldingathome-v7/foldingathome-v7.install b/abs/extra/foldingathome/foldingathome-v7/foldingathome-v7.install
new file mode 100644
index 0000000..6899bba
--- /dev/null
+++ b/abs/extra/foldingathome/foldingathome-v7/foldingathome-v7.install
@@ -0,0 +1,12 @@
+post_install() {
+ cat << 'EOM'
+ --> Please cd to /opt/fah-v7/ and execute ./FAHClient --configure
+ --> as root to configure your settings. If you are using systemd,
+ --> then run "systemctl enable foldingathome-v7.service" to enable
+ --> the folding service. If you are using initscripts, then add
+ --> "foldingathome-v7" to the list of daemons in /etc/rc.conf.
+ --> If you would like join the Arch Linux team, use team number
+ --> 45032.
+EOM
+}
+
diff --git a/abs/extra/foldingathome/foldingathome-v7/foldingathome-v7.rc.d b/abs/extra/foldingathome/foldingathome-v7/foldingathome-v7.rc.d
new file mode 100644
index 0000000..91a395a
--- /dev/null
+++ b/abs/extra/foldingathome/foldingathome-v7/foldingathome-v7.rc.d
@@ -0,0 +1,46 @@
+#!/bin/bash
+#/etc/rc.d/foldingathome-v7
+#
+# Starts the Folding@Home-v7 client in the background
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+DAEMON=foldingathome-v7
+#ARGS=
+
+#[ -r /etc/conf.d/$DAEMON ] && . /etc/conf.d/$DAEMON
+
+PID=$(pidof -x -o %PPID /opt/fah-v7/FAHClient)
+case "${1}" in
+ start)
+ stat_busy "Starting $DAEMON"
+ [ -z "${PID}" ] && /opt/fah-v7/FAHClient --config /opt/fah-v7/config.xml --exec-directory=/opt/fah-v7 --data-directory=/opt/fah-v7 &> /dev/null &
+ add_daemon $DAEMON
+ if [ ! -z "$PID" -o $? -gt 0 ]; then
+ stat_fail
+ exit 1
+ else
+ stat_done
+ exit 1
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping $DAEMON"
+ [ ! -z "${PID}" ] && kill ${PID} &> /dev/null
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm_daemon $DAEMON
+ stat_done
+ exit 1
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 1
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart}"
+esac
diff --git a/abs/extra/foldingathome/foldingathome-v7/foldingathome-v7.service b/abs/extra/foldingathome/foldingathome-v7/foldingathome-v7.service
new file mode 100644
index 0000000..4634582
--- /dev/null
+++ b/abs/extra/foldingathome/foldingathome-v7/foldingathome-v7.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Folding@home V7 distributed computing client
+After=network.target
+
+[Service]
+Type=simple
+WorkingDirectory=/opt/fah-v7
+ExecStart=/opt/fah-v7/FAHClient --config /opt/fah-v7/config.xml --exec-directory=/opt/fah-v7 --data-directory=/opt/fah-v7
+
+[Install]
+WantedBy=multi-user.target
+