summaryrefslogtreecommitdiffstats
path: root/abs/extra/frozen-bubble
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2013-02-19 21:10:18 (GMT)
committerJames Meyer <james.meyer@operamail.com>2013-02-19 21:10:18 (GMT)
commit2648e999d277eac5c3d331a3609bcc73fafbea71 (patch)
tree40951fb8e7fdbe28a0baa324ae615055203f1e2e /abs/extra/frozen-bubble
parentc759b5e0c4aa6fc37412b4dee2cf9ad993fd376d (diff)
parent7e6f7ca174e1af67178dc5293a312a4a733eb095 (diff)
downloadlinhes_pkgbuild-2648e999d277eac5c3d331a3609bcc73fafbea71.zip
linhes_pkgbuild-2648e999d277eac5c3d331a3609bcc73fafbea71.tar.gz
linhes_pkgbuild-2648e999d277eac5c3d331a3609bcc73fafbea71.tar.bz2
Merge branch 'testing'
# By James Meyer (1091) and others # Via James Meyer (5) and others * testing: (1148 commits) LinHES-config: during install don't kill off lirc. This keeps the remote active all the way to the finish Change version numbers to 8.0 to match the release number. LinHES-conifg LinHES-system mythdb-initial runit-scripts supplemental-web LinHES-conifig: mv_install.py for the last partition don't go all the way to the end. Gotta leave room for gpt tables. xf86-video-ati: xorg ati driver. LinHES-config: timezip.py add syncing up of parental lvl passwords and starting level with MBE. LinHES-system: correct the logic for breaking out of the wmctrl loop. As written it would break out of the inner loop..but not the 60 iteration loop. e16_theme_settings: remove slide-in prop for new windows. For whatever reason this was preventing mplayer from being positioned correctly for appletrailers. LinHES-config, mythinstall: change case of hd_pvr and serial to all lower refs #902 zilog-firmware: firmware for TX support of the hdpvr and pvr-150 In general I can't recommend anybody using these transmitters but including the firmware just in case someone really wants to linhes-udev-rules: added hdprv_lirc rule. All of these lirc rules are limited to exactly one device. If more then one device is present then only the last device in init will get the symlink runit-scripts: fix logging for igdeamon, add support to remote init script so that the blaster is always the first device in the chain. added support specificly for hd_pvr LinHES-system: add lh_system_restore and lh_system_backup. These scripts are called from the mythmenu. refs #900 iguanair: rebuild with python 2.7 LinHES-system: msg_daemon.py fix init and nasty bug related to timeout. In a nutshell timeout wouldn't work unless a msg without a timeout was called first. linhes-udev-rules: add rules for mce,streamzap,serial lirc devices. mythinstall: recompile for matching libs mythtv: latest .25-fixes and change mythbackup/restore call lh_system_$op to replace mythbackup/mythrestore. mythbackup no longer works correctly with the new windowmanager linhes-scripts: myth2mp3, myth2x264, myth2xvid: use mythutil to get cutlist LinHES-config, supplimental-web: Fix proxy numbering for Ceton infiniTV linhes-system: add additional stuff to the system backup and also introduced an exclude file. The exclude/include files are locate in /home/mythtv/backup_config/ ...
Diffstat (limited to 'abs/extra/frozen-bubble')
-rw-r--r--abs/extra/frozen-bubble/PKGBUILD49
-rw-r--r--abs/extra/frozen-bubble/frozen-bubble.desktop2
2 files changed, 31 insertions, 20 deletions
diff --git a/abs/extra/frozen-bubble/PKGBUILD b/abs/extra/frozen-bubble/PKGBUILD
index 1989276..c003f80 100644
--- a/abs/extra/frozen-bubble/PKGBUILD
+++ b/abs/extra/frozen-bubble/PKGBUILD
@@ -1,30 +1,41 @@
-# $Id: PKGBUILD 22250 2008-12-24 11:30:19Z allan $
-# Maintainer: Allan McRae <allan@archlinux.org>
+# $Id: PKGBUILD 160465 2012-06-02 10:25:48Z bluewind $
+# Maintainer: Jan "heftig" Steffens <jan.steffens@gmail.com>
+# Contributor: Allan McRae <allan@archlinux.org>
# Contributor: Brandon Niemczyk <maccorin@cfl.rr.com>
pkgname=frozen-bubble
-pkgver=2.2.0
-pkgrel=2
+_pkgver=2.2.1-beta1
+pkgver=${_pkgver/-/}
+pkgrel=4
pkgdesc="A game in which you throw colorful bubbles and build groups to destroy the bubbles"
-arch=('i686' 'x86_64')
+arch=(i686 x86_64)
url="http://www.frozen-bubble.org"
-license=('GPL2')
-depends=('sdl_perl' 'sdl_mixer' 'perl-locale-gettext' 'sdl_pango')
+license=(GPL2)
+depends=(perl-sdl perl-ipc-system-simple perl-compress-bzip2 perl-file-which)
+makedepends=(perl-file-slurp perl-locale-maketext-lexicon)
options=('!emptydirs')
-source=(http://www.frozen-bubble.org/data/${pkgname}-${pkgver}.tar.bz2 \
+source=(http://www.frozen-bubble.org/data/$pkgname-$_pkgver.tar.bz2 \
frozen-bubble.desktop)
-md5sums=('f7987201470d6755ed309762d348e0dd' '3e0755836580e374e0911653f8cd33e2')
+md5sums=('825cc23ed806838b9d86de9982a5687a'
+ '01b10b77ba6ad856f5c199121c582272')
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
- make OPTIMIZE="${CFLAGS}" \
- CFLAGS="$(pkg-config glib-2.0 --cflags)" INSTALLDIRS=vendor \
- PREFIX=/usr || return 1
-
- make DESTDIR=${pkgdir} PREFIX=/usr install || return 1
- install -D -m644 icons/frozen-bubble-icon-64x64.png ${pkgdir}/usr/share/pixmaps/frozen-bubble.png || return 1
- install -D -m644 ${srcdir}/frozen-bubble.desktop ${pkgdir}/usr/share/applications/frozen-bubble.desktop || return 1
+ cd "$srcdir/$pkgname-$_pkgver"
+ unset CFLAGS
+ # install module in vendor directories
+ perl Build.PL installdirs=vendor
+ perl Build
+}
+
+check() {
+ cd "$srcdir/$pkgname-$_pkgver"
+ perl Build test
+}
+
+package() {
+ cd "$srcdir/$pkgname-$_pkgver"
+ perl Build install destdir="$pkgdir"
- find $startdir/pkg -name '.packlist' -delete
- find $startdir/pkg -name '*.pod' -delete
+ install -D -m644 share/icons/frozen-bubble-icon-64x64.png "$pkgdir/usr/share/pixmaps/frozen-bubble.png"
+ install -D -m644 "$srcdir/frozen-bubble.desktop" "$pkgdir/usr/share/applications/frozen-bubble.desktop"
}
diff --git a/abs/extra/frozen-bubble/frozen-bubble.desktop b/abs/extra/frozen-bubble/frozen-bubble.desktop
index 6e53e5d..76a7bcd 100644
--- a/abs/extra/frozen-bubble/frozen-bubble.desktop
+++ b/abs/extra/frozen-bubble/frozen-bubble.desktop
@@ -4,6 +4,6 @@ Version=1.0
Encoding=UTF-8
Name=Frozen Bubble
Icon=frozen-bubble.png
-Exec=frozen-bubble
+Exec=/usr/bin/vendor_perl/frozen-bubble
Terminal=false
Categories=Game;