summaryrefslogtreecommitdiffstats
path: root/abs/extra/gconf
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-20 03:54:42 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-20 03:54:42 (GMT)
commit2e5365676de337da87a7731db1567b688095da37 (patch)
tree22320f8984d5e52a1a169ba487843606e3186f1c /abs/extra/gconf
parent0509dbb80831e3d25fea547036198f05630ce6aa (diff)
downloadlinhes_pkgbuild-2e5365676de337da87a7731db1567b688095da37.zip
linhes_pkgbuild-2e5365676de337da87a7731db1567b688095da37.tar.gz
linhes_pkgbuild-2e5365676de337da87a7731db1567b688095da37.tar.bz2
gconf: upgrade
Diffstat (limited to 'abs/extra/gconf')
-rw-r--r--abs/extra/gconf/PKGBUILD43
-rw-r--r--abs/extra/gconf/gconf.install20
2 files changed, 30 insertions, 33 deletions
diff --git a/abs/extra/gconf/PKGBUILD b/abs/extra/gconf/PKGBUILD
index 3da7a0c..66de23f 100644
--- a/abs/extra/gconf/PKGBUILD
+++ b/abs/extra/gconf/PKGBUILD
@@ -1,42 +1,45 @@
-# $Id: PKGBUILD 74317 2010-03-30 19:00:27Z ibiru $
+# $Id: PKGBUILD 91729 2010-09-27 18:54:15Z ibiru $
# Maintainer: Jan de Groot <jan@archlinux.org>
pkgname=gconf
-pkgver=2.28.1
+pkgver=2.32.0
pkgrel=1
pkgdesc="A configuration database system"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
license=('LGPL')
-depends=('orbit2>=2.14.17' 'gtk2>=2.20.0' 'libxml2>=2.7.7' 'polkit>=0.96' 'libldap>=2.4.18' 'dbus')
-makedepends=('pkgconfig' 'intltool' 'gtk-doc')
+depends=('orbit2>=2.14.18' 'gtk2>=2.22.0' 'libxml2>=2.7.7' 'polkit>=0.96' 'libldap>=2.4.22' 'dbus-glib>=0.86')
+makedepends=('pkgconfig' 'intltool' 'gtk-doc' 'gobject-introspection')
options=('!libtool')
install=gconf.install
url="http://www.gnome.org"
-source=(http://ftp.gnome.org/pub/gnome/sources/GConf/2.28/GConf-${pkgver}.tar.bz2
+source=(http://ftp.gnome.org/pub/gnome/sources/GConf/2.32/GConf-${pkgver}.tar.bz2
gconf-merge-schema
gconfpkg
gconf-reload.patch
01_xml-gettext-domain.patch)
-md5sums=('27663faf0af4f6a6d534de9270f6d24a'
- '240b473fa17b748fc9020caf372d936c'
- 'b745f04b4121d8724c002b14a4c110b6'
- 'cfcc8e15be7b8a48de4aa34336ff6090'
- '1f9362976d71312bdb57c57fa031681d')
+sha256sums=('54dd1dd7f49928a9cc42574bef6ef0481753770fc19986dc2004bbb7fac977a0'
+ 'ee6b6e6f4975dad13a8c45f1c1f0547a99373bdecdcd6604bfc12965c328a028'
+ 'bf1928718caa5df2b9e54a13cfd0f15a8fe0e09e86b84385ce023616a114e898'
+ '567b78d8b4b4bbcb77c5f134d57bc503c34867fcc6341c0b01716bcaa4a21694'
+ 'c883dec2b96978874a53700cfe7f26f24f8296767203e970bc6402b4b9945eb8')
build() {
cd "${srcdir}/GConf-${pkgver}"
# Patch from fedora - reloads gconf after installing schemas
- patch -Np1 -i "${srcdir}/gconf-reload.patch" || return 1
+ patch -Np1 -i "${srcdir}/gconf-reload.patch"
# http://bugzilla.gnome.org/show_bug.cgi?id=568845
- patch -Np1 -i "${srcdir}/01_xml-gettext-domain.patch" || return 1
-
+ patch -Np1 -i "${srcdir}/01_xml-gettext-domain.patch"
+
./configure --prefix=/usr --sysconfdir=/etc \
--localstatedir=/var --libexecdir=/usr/lib/GConf \
- --disable-static --enable-defaults-service || return 1
- make pkglibdir=/usr/lib/GConf || return 1
- make DESTDIR="${pkgdir}" install || return 1
- install -m755 -d "${pkgdir}/etc/gconf/gconf.xml.system" || return 1
- install -m755 "${srcdir}/gconf-merge-schema" "${pkgdir}/usr/bin/" || return 1
+ --disable-static --enable-defaults-service
+ make pkglibdir=/usr/lib/GConf
+}
+package() {
+ cd "${srcdir}/GConf-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -m755 -d "${pkgdir}/etc/gconf/gconf.xml.system"
+ install -m755 "${srcdir}/gconf-merge-schema" "${pkgdir}/usr/bin/"
install -d -m755 "${pkgdir}/usr/sbin"
- install -m755 "${srcdir}/gconfpkg" "${pkgdir}/usr/sbin/" || return 1
+ install -m755 "${srcdir}/gconfpkg" "${pkgdir}/usr/sbin/"
}
diff --git a/abs/extra/gconf/gconf.install b/abs/extra/gconf/gconf.install
index 4e792c4..f7945d1 100644
--- a/abs/extra/gconf/gconf.install
+++ b/abs/extra/gconf/gconf.install
@@ -1,26 +1,20 @@
post_install() {
ldconfig -r .
chmod 755 etc/gconf/gconf.xml.system
+ usr/bin/gio-querymodules usr/lib/gio/modules
}
post_upgrade() {
ldconfig -r .
- if [ `vercmp $2 2.18.0.1-2` -lt 0 ]; then
- echo "Regenerating GConf database... "
- # Move from /opt/gnome to /usr
- ldconfig -r .
- export GCONF_CONFIG_SOURCE=`usr/bin/gconftool-2 --get-default-source`
- find /opt/gnome/{etc,share}/gconf/schemas -name "*.schemas" | xargs \
- usr/bin/gconftool-2 --makefile-install-rule > /dev/null
- if [ -f opt/gnome/etc/gconf/panel-default-setup.entries ]; then
- usr/bin/gconftool-2 --direct --load opt/gnome/etc/gconf/panel-default-setup.entries > /dev/null
- fi
- echo "done."
- fi
chmod 755 etc/gconf/gconf.xml.system
-
+ usr/bin/gio-querymodules usr/lib/gio/modules
+
PID=`pidof gconfd-2`
if [ ! -z "${PID}" ]; then
kill ${PID}
fi
}
+
+post_remove() {
+ usr/bin/gio-querymodules usr/lib/gio/modules
+}